]> git.pld-linux.org Git - packages/bootil.git/blob - bootil.spec
- new
[packages/bootil.git] / bootil.spec
1 Summary:        Garry Newman's utility library
2 Summary(pl.UTF-8):      Biblioteka narzędziowa Garry'ego Newmana
3 Name:           bootil
4 Version:        0
5 %define snap    20140109
6 Release:        0.%{snap}.1
7 # URL says: "My personal utility library, feel free to steal :)"
8 License:        unknown (free)
9 Group:          Libraries
10 # git clone https://github.com/garrynewman/bootil
11 # tar cJ --exclude=.git -f bootil.tar.xz
12 Source0:        %{name}.tar.xz
13 # Source0-md5:  fcbf821466349cc3d91f362fea8bd9de
14 Patch0:         %{name}-includes.patch
15 URL:            https://github.com/garrynewman/bootil
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  premake >= 4
18 BuildRequires:  sed >= 4.0
19 BuildRequires:  tar >= 1:1.22
20 BuildRequires:  xz
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Garry Newman's utility library.
25
26 %description -l pl.UTF-8
27 Biblioteka narzędziowa Garry'ego Newmana.
28
29 %package devel
30 Summary:        Header files for Bootil library
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Bootil
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       libstdc++-devel
35
36 %description devel
37 Header files for Bootil library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe biblioteki Bootil.
41
42 %prep
43 %setup -q -n bootil
44 %patch0 -p1
45
46 %{__sed} -i -e 's/bootil_static/bootil/;s/StaticLib/SharedLib/' projects/bootil.lua
47
48 %build
49 cd projects
50 premake4 gmake
51 LDFLAGS="%{rpmldflags}" \
52 %{__make} -C linux/gmake \
53         CC="%{__cc}" \
54         CXX="%{__cxx}" \
55         CFLAGS='%{rpmcflags} %{rpmcppflags} $(CPPFLAGS) $(ARCH) -ffast-math -fPIC' \
56         verbose=1
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_includedir}
61
62 install -D lib/linux/gmake/libbootil.so $RPM_BUILD_ROOT%{_libdir}/libbootil.so
63 cp -pr include/Bootil $RPM_BUILD_ROOT%{_includedir}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post   -p /sbin/ldconfig
69 %postun -p /sbin/ldconfig
70
71 %files
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_libdir}/libbootil.so
74
75 %files devel
76 %defattr(644,root,root,755)
77 %{_includedir}/Bootil
This page took 0.073544 seconds and 3 git commands to generate.