]> git.pld-linux.org Git - packages/bluez-pin.git/commitdiff
- update for dbus 0.50 API
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 28 Oct 2005 22:38:26 +0000 (22:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bluez-pin-dbus.patch -> 1.1

bluez-pin-dbus.patch [new file with mode: 0644]

diff --git a/bluez-pin-dbus.patch b/bluez-pin-dbus.patch
new file mode 100644 (file)
index 0000000..5b579e1
--- /dev/null
@@ -0,0 +1,51 @@
+--- bluez-pin-0.26/Makefile.orig       2005-10-29 00:34:42.105626656 +0200
++++ bluez-pin-0.26/Makefile    2005-10-29 00:12:31.352931816 +0200
+@@ -14,7 +14,7 @@
+ CFLAGS += -O2 -g
+-CFLAGS += `pkg-config --cflags gtk+-2.0 libglade-2.0 dbus-glib-1 gconf-2.0` -DGTK_DISABLE_DEPRECATED -DDBUS_API_SUBJECT_TO_CHANGE
++CFLAGS += `pkg-config --cflags gtk+-2.0 libglade-2.0 dbus-glib-1 gconf-2.0` -DGTK_DISABLE_DEPRECATED -DDBUS_API_SUBJECT_TO_CHANGE -DHAVE_DBUS_MESSAGE_ITER_GET_BASIC
+ LDFLAGS += `pkg-config --libs gtk+-2.0 libglade-2.0 dbus-glib-1 gconf-2.0` -lbluetooth
+ CFLAGS += -Wall
+--- bluez-pin-0.26/main.c.orig 2005-09-05 21:11:20.000000000 +0200
++++ bluez-pin-0.26/main.c      2005-10-29 00:07:57.466568872 +0200
+@@ -47,7 +47,7 @@
+     return bluez_pin_handle_dbus_request (connection, message);
+   if (dbus_message_is_signal (message,
+-                              DBUS_INTERFACE_ORG_FREEDESKTOP_LOCAL,
++                              DBUS_INTERFACE_LOCAL,
+                               "Disconnected"))
+     exit (0);
+   
+@@ -84,7 +84,7 @@
+   dbus_connection_register_object_path (connection, new_object_path, &dbus_vtable, NULL);
+   dbus_connection_register_object_path (connection, old_object_path, &dbus_vtable, NULL);
+-  dbus_bus_acquire_service (connection, NEW_SERVICE_NAME, 0, &error);
++  dbus_bus_request_name (connection, NEW_SERVICE_NAME, 0, &error);
+   if (dbus_error_is_set (&error))
+     {
+       fprintf (stderr, "Failed to acquire %s service: %s\n", NEW_SERVICE_NAME, error.message);
+@@ -92,7 +92,7 @@
+       errors++;
+     }
+-  dbus_bus_acquire_service (connection, OLD_SERVICE_NAME, 0, &error);
++  dbus_bus_request_name (connection, OLD_SERVICE_NAME, 0, &error);
+   if (dbus_error_is_set (&error))
+     {
+       fprintf (stderr, "Failed to acquire %s service: %s\n", OLD_SERVICE_NAME, error.message);
+--- bluez-pin-0.26/pin-dbus.c.orig     2005-09-05 21:09:13.000000000 +0200
++++ bluez-pin-0.26/pin-dbus.c  2005-10-29 00:08:41.074939392 +0200
+@@ -42,7 +42,7 @@
+ #ifndef HAVE_DBUS_MESSAGE_ITER_GET_BASIC
+   DBusMessageIter iter;
+-  dbus_message_append_iter_init (message, &iter);
++  dbus_message_iter_init_append (message, &iter);
+   if (pin)
+     dbus_message_iter_append_string (&iter, pin);
+ #else
This page took 0.27955 seconds and 4 git commands to generate.