]> git.pld-linux.org Git - packages/bluefish.git/blob - bluefish.spec
- starting up to 2.0.0
[packages/bluefish.git] / bluefish.spec
1 #
2 # Conditional build:
3 %bcond_with     python  # enable python integration (HIGHLY EXPERIMENTAL)
4 #
5 # note: optflags used with this bcond are very strong, and partially
6 #       obsoleted for C (like -fno-rtti) - use at own risk!
7 #
8 Summary:        Bluefish - HTML editor for the experienced web designer
9 Summary(pl.UTF-8):      Bluefish - Edytor HTML-a dla zaawansowanych
10 Name:           bluefish
11 Version:        2.0.0
12 Release:        0.1
13 License:        GPL
14 Group:          X11/Applications/Editors
15 # The master server is here
16 Source0:        http://www.bennewitz.com/bluefish/stable/source/%{name}-%{version}.tar.bz2
17 # Source0-md5:  ac9b1e8ef6d5691718a0daa6c78d5618
18 # but if you want ftp: try this one
19 # Source0:      ftp://bluefish.advancecreations.com/bluefish/downloads/%{name}-%{version}.tar.bz2
20 Patch0:         %{name}-desktop.patch
21 Patch1:         %{name}-locales.patch
22 URL:            http://bluefish.openoffice.nl/
23 BuildRequires:  aspell-devel
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  gettext-devel
27 BuildRequires:  giflib-devel
28 BuildRequires:  gnome-vfs2-devel >= 2.2
29 BuildRequires:  gtk+2-devel     >= 2.14
30 BuildRequires: intltool
31 BuildRequires:  libbonobo-devel >= 2.2
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libpng >= 1.2.5
34 BuildRequires:  libtiff-devel
35 BuildRequires: libtool
36 BuildRequires:  pcre-devel      >=      3.0
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(macros) >= 1.311
39 Requires(post,postun):  desktop-file-utils
40 Requires(post,postun):  gtk+2
41 Requires(post,postun):  hicolor-icon-theme
42 Requires(post,postun):  shared-mime-info
43 Requires:       gnome-vfs2 >= 2.2
44 # sr@Latn vs. sr@latin
45 Conflicts:      glibc-misc < 6:2.7
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Bluefish is a GTK+ based HTML editor designed for the experienced web
50 designer.
51
52 %description -l pl.UTF-8
53 Bluefish jest opartym na GTK+ edytorem HTML-a, przeznaczonym dla
54 doświadczonych projektantów stron WWW.
55
56 %description -l pt_BR.UTF-8
57 O bluefish é um editor HTML feito com GTK+ para web designers
58 experientes. Atualmente ele está em estágio alfa, mas já está bastante
59 usável. Algumas opções ainda não estão completamente finalizadas.
60 Bluefish é liberado sob a licença GPL.
61
62 %prep
63 %setup -q
64 %patch0 -p0
65 %patch1 -p1
66
67 mv -f po/sr{,@Latn}.po
68 mv -f src/plugin_about/po/sr{,@Latn}.po  
69 mv -f src/plugin_charmap/po/sr{,@Latn}.po  
70 mv -f src/plugin_entities/po/sr{,@Latn}.po  
71 mv -f src/plugin_htmlbar/po/sr{,@Latn}.po  
72 mv -f src/plugin_infbrowser/po/sr{,@Latn}.po  
73 mv -f src/plugin_snippets/po/sr{,@Latn}.po
74
75 %{__intltoolize}
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %configure \
80         --disable-update-databases \
81         %{?with_python:--enable-python}
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 mv %{buildroot}/%{_docdir}/bluefish/* %{buildroot}/%{_docdir}/bluefish-%{version}/
92
93 %find_lang %{name} --all-name
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 %update_mime_database
100 %update_desktop_database_post
101 %update_icon_cache hicolor
102
103 %postun
104 %update_desktop_database_postun
105 %update_mime_database
106 %update_icon_cache hicolor
107
108 %files -f %{name}.lang
109 %defattr(644,root,root,755)
110 %doc AUTHORS README TODO 
111 %attr(755,root,root) %{_bindir}/bluefish
112 %dir %{_datadir}/%{name}
113 %{_datadir}/mime/packages/bluefish.xml
114 %dir %{_datadir}/xml/bluefish
115 %{_datadir}/xml/bluefish/catalog.xml
116 %{_datadir}/xml/bluefish/2.0/bflang2.rng
117 %{_datadir}/bluefish/bflang/*.bflang2
118 %{_datadir}/bluefish/bflang/*.bfinc
119 %{_datadir}/bluefish/bflib/*.gz
120 %{_mandir}/man1/bluefish.1*
121 %{_iconsdir}/hicolor/128x128/apps/bluefish.png
122 %{_iconsdir}/hicolor/128x128/mimetypes/application-x-bluefish-project.png
123 %{_iconsdir}/hicolor/16x16/apps/bluefish.png
124 %{_iconsdir}/hicolor/16x16/mimetypes/application-x-bluefish-project.png
125 %{_iconsdir}/hicolor/192x192/apps/bluefish.png
126 %{_iconsdir}/hicolor/192x192/mimetypes/application-x-bluefish-project.png
127 %{_iconsdir}/hicolor/22x22/apps/bluefish.png
128 %{_iconsdir}/hicolor/22x22/mimetypes/application-x-bluefish-project.png
129 %{_iconsdir}/hicolor/32x32/apps/bluefish.png
130 %{_iconsdir}/hicolor/32x32/mimetypes/application-x-bluefish-project.png
131 %{_iconsdir}/hicolor/36x36/apps/bluefish.png
132 %{_iconsdir}/hicolor/36x36/mimetypes/application-x-bluefish-project.png
133 %{_iconsdir}/hicolor/48x48/apps/bluefish.png
134 %{_iconsdir}/hicolor/48x48/mimetypes/application-x-bluefish-project.png
135 %{_iconsdir}/hicolor/64x64/apps/bluefish.png
136 %{_iconsdir}/hicolor/64x64/mimetypes/application-x-bluefish-project.png
137 %{_iconsdir}/hicolor/72x72/apps/bluefish.png
138 %{_iconsdir}/hicolor/72x72/mimetypes/application-x-bluefish-project.png
139 %{_iconsdir}/hicolor/96x96/apps/bluefish.png
140 %{_iconsdir}/hicolor/96x96/mimetypes/application-x-bluefish-project.png
141 %{_iconsdir}/hicolor/scalable/apps/bluefish-icon.svg
142 %{_iconsdir}/hicolor/scalable/mimetypes/bluefish-project.svg
143 %{_desktopdir}/bluefish.desktop
144 %{_pixmapsdir}/application-x-bluefish-project.png
145 %{_pixmapsdir}/bluefish.png
146 %dir %{_libdir}/bluefish
147 %attr(755,root,root) %{_libdir}/bluefish/*.so
This page took 0.085201 seconds and 4 git commands to generate.