]> git.pld-linux.org Git - packages/bitbake.git/blob - bitbake.spec
b3532ed4b33555cca11005f9819d565e58f4cc44
[packages/bitbake.git] / bitbake.spec
1 Summary:        BitBake build tool
2 Name:           bitbake
3 Version:        1.2
4 Release:        1
5 License:        GPL
6 Group:          Development
7 Source0:        http://download.berlios.de/bitbake/%{name}-%{version}.tar.gz
8 # Source0-md5:  62c799d91d291a17078d6c23a94e793e
9 URL:            http://developer.berlios.de/projects/bitbake/
10 BuildRequires:  python-devel >= 2.0
11 %pyrequires_eq  python
12 Requires:       python-modules
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 BitBake is a simple tool for the execution of tasks. It is derived
18 from Portage, which is the package management system used by the
19 Gentoo Linux distribution. It is most commonly used to build packages,
20 as it can easily use its rudamentary inheritence to abstract common
21 operations, such as fetching sources, unpacking them, patching them,
22 compiling them, and so on. It is the basis of the OpenEmbedded
23 project, which is being used for OpenZaurus, Familiar, and a number of
24 other Linux distributions.
25
26 %prep
27 %setup -q
28
29 %build
30 python setup.py build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT%{_sysconfdir}
35 python setup.py install \
36         --prefix=%{_prefix} \
37         --root=$RPM_BUILD_ROOT
38
39 mv $RPM_BUILD_ROOT%{_prefix}/%{name} $RPM_BUILD_ROOT%{_sysconfdir}
40
41 %clean
42 rm -rf ${RPM_BUILD_ROOT}
43
44 %files
45 %defattr(644,root,root,755)
46 %attr(755,root,root) %{_bindir}/*
47 %{_sysconfdir}/%{name}
48 %dir %{py_sitescriptdir}/bb
49 %{py_sitescriptdir}/bb/*py[co]
50 %dir %{py_sitescriptdir}/bb/parse
51 %{py_sitescriptdir}/bb/parse/*py[co]
This page took 0.063341 seconds and 2 git commands to generate.