]> git.pld-linux.org Git - packages/bitbake.git/blob - bitbake.spec
- pl, typos
[packages/bitbake.git] / bitbake.spec
1 Summary:        BitBake build tool
2 Summary(pl):    BitBake - narzêdzie do budowania
3 Name:           bitbake
4 Version:        1.2
5 Release:        1
6 License:        GPL
7 Group:          Development
8 Source0:        http://download.berlios.de/bitbake/%{name}-%{version}.tar.gz
9 # Source0-md5:  62c799d91d291a17078d6c23a94e793e
10 URL:            http://developer.berlios.de/projects/bitbake/
11 BuildRequires:  python-devel >= 2.0
12 %pyrequires_eq  python
13 Requires:       python-modules
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 BitBake is a simple tool for the execution of tasks. It is derived
19 from Portage, which is the package management system used by the
20 Gentoo Linux distribution. It is most commonly used to build packages,
21 as it can easily use its rudimentary inheritance to abstract common
22 operations, such as fetching sources, unpacking them, patching them,
23 compiling them, and so on. It is the basis of the OpenEmbedded
24 project, which is being used for OpenZaurus, Familiar, and a number of
25 other Linux distributions.
26
27 %description -l pl
28 BitBake to proste narzêdzie do wykonywania zadañ. Wywodzi siê z
29 Portage, ktore jest systemem zarz±dzania pakietami u¿ywanym w
30 dystrybucji Linuksa Gentoo. Najczê¶ciej jest u¿ywane do budowania
31 pakietów, jako ¿e mo¿e ³atwo u¿ywaæ swojej elementarnej dziedziczno¶ci
32 do abstrahowania wspólnych operacji, takich jak pobieranie ¼róde³,
33 rozpakowywanie ich, ³atanie, kompilowanie i tak dalej. Jest podstaw±
34 projektu OpenEmbedded, u¿ywanego przez projekty OpenZaurus, Familiar i
35 wiele innych dystrybucji Linuksa.
36
37 %prep
38 %setup -q
39
40 %build
41 python setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_sysconfdir}
46 python setup.py install \
47         --prefix=%{_prefix} \
48         --root=$RPM_BUILD_ROOT
49
50 mv $RPM_BUILD_ROOT%{_prefix}/%{name} $RPM_BUILD_ROOT%{_sysconfdir}
51
52 %clean
53 rm -rf ${RPM_BUILD_ROOT}
54
55 %files
56 %defattr(644,root,root,755)
57 %attr(755,root,root) %{_bindir}/*
58 %{_sysconfdir}/%{name}
59 %dir %{py_sitescriptdir}/bb
60 %{py_sitescriptdir}/bb/*py[co]
61 %dir %{py_sitescriptdir}/bb/parse
62 %{py_sitescriptdir}/bb/parse/*py[co]
This page took 0.053086 seconds and 3 git commands to generate.