]> git.pld-linux.org Git - packages/bitbake.git/blob - bitbake.spec
BC self
[packages/bitbake.git] / bitbake.spec
1 Summary:        BitBake build tool
2 Summary(pl.UTF-8):      BitBake - narzędzie do budowania
3 Name:           bitbake
4 Version:        1.17.0
5 Release:        1
6 License:        GPL v2
7 Group:          Development
8 Source0:        http://git.openembedded.org/bitbake/snapshot/%{name}-%{version}.tar.gz
9 # Source0-md5:  6ff19a24fdd20623b792225d84017506
10 URL:            https://www.yoctoproject.org/tools-resources/projects/bitbake
11 BuildRequires:  dblatex
12 BuildRequires:  libxslt
13 BuildRequires:  lynx
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  python-sqlite
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  xmlto
19 BuildConflicts: bitbake
20 Requires:       bash
21 Requires:       python
22 Requires:       python-modules
23 Requires:       python-ply
24 Requires:       python-progressbar
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 BitBake is a make-like build tool with the special focus of
30 distributions and packages for embedded Linux cross compilation
31 although it is not limited to that. It is inspired by Portage, which
32 is the package management system used by the Gentoo Linux
33 distribution. BitBake existed for some time in the OpenEmbedded
34 project until it was separated out into a standalone, maintained,
35 distribution-independent tool. BitBake is co-maintained by the Yocto
36 Project and the OpenEmbedded project.
37
38 %description -l pl.UTF-8
39 BitBake to proste narzędzie do wykonywania zadań. Wywodzi się z
40 Portage, które jest systemem zarządzania pakietami używanym w
41 dystrybucji Linuksa Gentoo. Najczęściej jest używane do budowania
42 pakietów, jako że może łatwo używać swojej elementarnej dziedziczności
43 do abstrahowania wspólnych operacji, takich jak pobieranie źródeł,
44 rozpakowywanie ich, łatanie, kompilowanie i tak dalej. Jest podstawą
45 projektu OpenEmbedded, używanego przez projekty OpenZaurus, Familiar i
46 wiele innych dystrybucji Linuksa.
47
48 %prep
49 %setup -q
50 sed -i  -e 's@#!/bin/sh[[:space:]]@#!/bin/bash @'       \
51         -e 's@%s%ssh[[:space:]]@%s%sbash @'     lib/bb/build.py
52
53 %build
54 %{__python} setup.py build
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 %{__python} setup.py install \
59         --prefix=%{_prefix} \
60         --root=$RPM_BUILD_ROOT
61
62 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
63
64 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
65 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
66 ln -s %{_sysconfdir}/%{name}/%{name}.conf $RPM_BUILD_ROOT%{_datadir}/%{name}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %dir %{_sysconfdir}/%{name}
74 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
75 %attr(755,root,root) %{_bindir}/bitbake
76 %attr(755,root,root) %{_bindir}/bitbake-diffsigs
77 %attr(755,root,root) %{_bindir}/bitbake-layers
78 %attr(755,root,root) %{_bindir}/bitbake-prserv
79 %attr(755,root,root) %{_bindir}/bitbake-selftest
80 %attr(755,root,root) %{_bindir}/image-writer
81 %{_datadir}/%{name}
82 %{py_sitescriptdir}/bb
83 %{py_sitescriptdir}/bitbake-%{version}-py*.egg-info
84 %{py_sitescriptdir}/codegen.py[co]
85 %{py_sitescriptdir}/prserv
This page took 0.079602 seconds and 3 git commands to generate.