]> git.pld-linux.org Git - packages/bioapi.git/blob - bioapi.spec
bf4e1137b8733f6214f7dfb9e78f8707675a9a56
[packages/bioapi.git] / bioapi.spec
1 # TODO:
2 # - fix qt build on gcc 4.1
3 # - change code to do not require *.so libs and use *.so.X.X.X
4 %bcond_with qt
5 #
6 Summary:        Framework for biometric-based authentication
7 Name:           bioapi
8 Version:        1.2.2
9 Release:        0.1
10 License:        BSD
11 Group:          Applications/Networking
12 Source0:        http://www.qrivy.net/~michael/blua/bioapi/%{name}-%{version}.tar.bz2
13 # Source0-md5:  924f723895c339552e501999945b7920
14 Patch0:         %{name}-c++.patch
15 URL:            http://www.qrivy.net/~michael/blua/
16 %{?with_qt:BuildRequires:       qt-devel}
17 BuildRequires:  xorg-lib-libX11-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 BioAPI reference implementation for Unix-based platforms. The
22 Unix-based reference implementation was developed by the Convergent
23 Information Division (CISD), Information Technology Laboratory (ITL)
24 of the National Institute of Standards and Technology (NIST). The
25 Unix-based reference implementation is based directly on the BioAPI
26 Consortium's Windows reference implementation and the Common Data
27 Security Architecture (CDSA) reference implementation. The Unix-based
28 reference implementation includes the Sample application and the
29 MdsEdit utility from code provided by the International Biometric
30 Group (IBG).
31
32 %package devel
33 Summary:        Header files and development documentation for BioAPI
34 Group:          Development/Libraries
35 Requires:       %{name} = %{epoch}:%{version}-%{release}
36 %{?with_qt:Requires:    %{name}-qt = %{epoch}:%{version}-%{release}}
37
38 %description devel
39 Header files and development documentation for BioAPI.
40
41 %package static
42 Summary:        Static BioAPI libraries
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
45
46 %description static
47 Static BioAPI libraries.
48
49 %package qt
50 Summary:        Sample BioAPI QT application
51 Group:          Applications
52
53 %description qt
54 Sample BioAPI QT application.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59
60 %build
61 %configure \
62 %if %{with qt}
63         --with-Qt-lib-dir=%{_libdir} \
64 %else
65         --with-Qt-dir=no \
66 %endif
67         --includedir=%{_includedir}/%{name}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 install include/bioapi_util.h include/installdefs.h imports/cdsa/v2_0/inc/cssmtype.h \
78         $RPM_BUILD_ROOT%{_includedir}/%{name}
79
80 mv $RPM_BUILD_ROOT%{_bindir}/Sample $RPM_BUILD_ROOT%{_bindir}/BioAPI-Sample
81 mv $RPM_BUILD_ROOT%{_bindir}/mds_install $RPM_BUILD_ROOT%{_bindir}/BioAPI-mds_install
82 mv $RPM_BUILD_ROOT%{_bindir}/mod_install $RPM_BUILD_ROOT%{_bindir}/BioAPI-mod_install
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post
88 /sbin/ldconfig
89 %{_bindir}/BioAPI-mds_install -s %{_libdir}
90 %{_bindir}/BioAPI-mod_install -fi %{_libdir}/libbioapi100.so
91 %{_bindir}/BioAPI-mod_install -fi %{_libdir}/libbioapi_dummy100.so
92
93 %postun -p /sbin/ldconfig
94
95 %post qt
96 /sbin/ldconfig
97 %{_bindir}/BioAPI-mod_install -fi %{_libdir}/libqtpwbsp.so
98
99 %postun qt -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc *.htm Disclaimer
104 %attr(755,root,root) %{_bindir}/*
105 %{?with_qt:%exclude %{_libdir}/libqtpwbsp.so*}
106 %attr(755,root,root) %{_libdir}/lib*.so*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %{_includedir}/%{name}
111 %{_libdir}/lib*.la
112 # *.so needed in main package
113 #%{?with_qt:%exclude %{_libdir}/libqtpwbsp.so.*}
114 #%attr(755,root,root) %{_libdir}/lib*.so
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/*.a
119
120 %if %{with qt}
121 %files qt
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/*qt*
124 %attr(755,root,root) %{_libdir}/libqtpwbsp.so*
125 %endif
This page took 0.057657 seconds and 2 git commands to generate.