]> git.pld-linux.org Git - packages/binutils.git/commitdiff
upstream fix for gas regression; rel 3 auto/th/binutils-2.39-3
authorJan Palus <atler@pld-linux.org>
Wed, 17 Aug 2022 12:19:47 +0000 (14:19 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 17 Aug 2022 12:19:47 +0000 (14:19 +0200)
see https://sourceware.org/bugzilla/show_bug.cgi?id=29451

binutils.spec
pr29451.patch [new file with mode: 0644]

index 4687ade0814d3981e384b11b9720e87230275372..4f18269ed84e8207390507bcd4b9859e27f5a1e5 100644 (file)
@@ -35,7 +35,7 @@ Summary(tr.UTF-8):    GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
 Version:       2.39
-Release:       2
+Release:       3
 Epoch:         4
 License:       GPL v3+
 Group:         Development/Tools
@@ -52,6 +52,7 @@ Patch6:               %{name}-absolute-gnu_debuglink-path.patch
 Patch7:                %{name}-libtool-m.patch
 Patch9:                %{name}-tooldir.patch
 Patch10:       %{name}-sanity-check.patch
+Patch11:       pr29451.patch
 URL:           http://www.sourceware.org/binutils/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake >= 1:1.11
@@ -184,6 +185,7 @@ niektórych pakietów.
 %patch7 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 %{__sed} -i -e '1s,.*env perl,#!%{__perl},' gprofng/gp-display-html/gp-display-html.in
 
diff --git a/pr29451.patch b/pr29451.patch
new file mode 100644 (file)
index 0000000..9a822ee
--- /dev/null
@@ -0,0 +1,95 @@
+From e8cf73215187b0c08679d726a5cc7c019fa3ea2e Mon Sep 17 00:00:00 2001
+From: Jan Beulich <jbeulich@suse.com>
+Date: Wed, 10 Aug 2022 10:34:22 +0200
+Subject: [PATCH] gas/Dwarf: properly skip zero-size functions
+
+PR gas/29451
+
+While out_debug_abbrev() properly skips such functions, out_debug_info()
+mistakenly didn't. It needs to calculate the high_pc expression ahead of
+time, in order to skip emitting any data for the function if the value
+is zero.
+
+The one case which would still leave a zero-size entry is when
+symbol_get_obj(symp)->size ends up evaluating to zero. I hope we can
+expect that to not be the case, otherwise we'd need to have a way to
+post-process .debug_info contents between resolving expressions and
+actually writing the data out to the file. Even then it wouldn't be
+entirely obvious in which way to alter the data.
+
+(cherry picked from commit d7abcbcea5ddd40a3bf28758b62f35933c59f996)
+---
+ gas/dwarf2dbg.c | 39 ++++++++++++++++++++-------------------
+ 1 file changed, 20 insertions(+), 19 deletions(-)
+
+diff --git a/gas/dwarf2dbg.c b/gas/dwarf2dbg.c
+index 868ec79ee2c..f346bd6a412 100644
+--- a/gas/dwarf2dbg.c
++++ b/gas/dwarf2dbg.c
+@@ -2882,6 +2882,7 @@ out_debug_info (segT info_seg, segT abbrev_seg, segT line_seg, segT str_seg,
+       {
+         const char *name;
+         size_t len;
++        expressionS size = { .X_op = O_constant };
+         /* Skip warning constructs (see above).  */
+         if (symbol_get_bfdsym (symp)->flags & BSF_WARNING)
+@@ -2895,6 +2896,18 @@ out_debug_info (segT info_seg, segT abbrev_seg, segT line_seg, segT str_seg,
+         if (!S_IS_DEFINED (symp) || !S_IS_FUNCTION (symp))
+           continue;
++#if defined (OBJ_ELF) /* || defined (OBJ_MAYBE_ELF) */
++        size.X_add_number = S_GET_SIZE (symp);
++        if (size.X_add_number == 0 && IS_ELF
++            && symbol_get_obj (symp)->size != NULL)
++          {
++            size.X_op = O_add;
++            size.X_op_symbol = make_expr_symbol (symbol_get_obj (symp)->size);
++          }
++#endif
++        if (size.X_op == O_constant && size.X_add_number == 0)
++          continue;
++
+         subseg_set (str_seg, 0);
+         name_sym = symbol_temp_new_now_octets ();
+         name = S_GET_NAME (symp);
+@@ -2920,29 +2933,17 @@ out_debug_info (segT info_seg, segT abbrev_seg, segT line_seg, segT str_seg,
+         emit_expr (&exp, sizeof_address);
+         /* DW_AT_high_pc */
+-        exp.X_op = O_constant;
+-#if defined (OBJ_ELF) /* || defined (OBJ_MAYBE_ELF) */
+-        exp.X_add_number = S_GET_SIZE (symp);
+-        if (exp.X_add_number == 0 && IS_ELF
+-            && symbol_get_obj (symp)->size != NULL)
+-          {
+-            exp.X_op = O_add;
+-            exp.X_op_symbol = make_expr_symbol (symbol_get_obj (symp)->size);
+-          }
+-#else
+-        exp.X_add_number = 0;
+-#endif
+         if (DWARF2_VERSION < 4)
+           {
+-            if (exp.X_op == O_constant)
+-              exp.X_op = O_symbol;
+-            exp.X_add_symbol = symp;
+-            emit_expr (&exp, sizeof_address);
++            if (size.X_op == O_constant)
++              size.X_op = O_symbol;
++            size.X_add_symbol = symp;
++            emit_expr (&size, sizeof_address);
+           }
+-        else if (exp.X_op == O_constant)
+-          out_uleb128 (exp.X_add_number);
++        else if (size.X_op == O_constant)
++          out_uleb128 (size.X_add_number);
+         else
+-          emit_leb128_expr (symbol_get_value_expression (exp.X_op_symbol), 0);
++          emit_leb128_expr (symbol_get_value_expression (size.X_op_symbol), 0);
+       }
+       /* End of children.  */
+-- 
+2.31.1
+
This page took 0.161697 seconds and 4 git commands to generate.