]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- rel 2; Close resource leaks in the BFD library's plugin handler. https://sourceware...
[packages/binutils.git] / binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     allarchs        # enable all targets
4 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
5                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
6 %bcond_without  pax             # without PaX flags (for upstream bugreports)
7 %bcond_without  gold            # don't build gold (no C++ dependencies)
8 %bcond_without  default_bfd     # default ld.bfd instead of gold
9 %bcond_without  gasp            # gasp
10 %bcond_with     tests           # check target
11
12 %ifnarch %{ix86} %{x8664} x32
13 %undefine       with_gold
14 %endif
15
16 Summary:        GNU Binary Utility Development Utilities
17 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
18 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
19 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
20 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
21 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
22 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
23 Summary(tr.UTF-8):      GNU geliştirme araçları
24 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
25 Name:           binutils
26 Version:        2.31.1
27 Release:        2
28 Epoch:          4
29 License:        GPL v3+
30 Group:          Development/Tools
31 Source0:        http://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
32 # Source0-md5:  a517a836dd5747cc9e64d81addc517ad
33 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
34 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
35 Patch0:         %{name}-gasp.patch
36 Patch1:         %{name}-info.patch
37 Patch2:         %{name}-libtool-relink.patch
38 Patch3:         %{name}-pt_pax_flags.patch
39 Patch4:         %{name}-libdir.patch
40
41 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
42 Patch7:         %{name}-libtool-m.patch
43 Patch8:         %{name}-build-id.patch
44 Patch9:         %{name}-tooldir.patch
45 Patch10:        %{name}-sanity-check.patch
46 # https://bugzilla.redhat.com/show_bug.cgi?id=1599521
47 Patch11:        binutils-do-not-provide-shared-section-symbols.patch
48 Patch12:        fd-leak.patch
49 URL:            http://sources.redhat.com/binutils/
50 BuildRequires:  autoconf >= 2.64
51 BuildRequires:  automake >= 1:1.11
52 BuildRequires:  bison
53 BuildRequires:  flex
54 BuildRequires:  gettext-tools
55 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
56 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
57 BuildRequires:  lzip
58 BuildRequires:  perl-tools-pod
59 %ifarch sparc sparc32
60 BuildRequires:  sparc32
61 %endif
62 BuildRequires:  tar >= 1:1.22
63 BuildRequires:  texinfo >= 4.2
64 BuildRequires:  zlib-devel
65 %{?with_tests:BuildRequires:    zlib-static}
66 Conflicts:      gcc-c++ < 5:3.3
67 Conflicts:      modutils < 2.4.17
68 Conflicts:      rpmbuild(macros) < 1.660
69 Obsoletes:      binutils-gold
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 Binutils is a collection of binary utilities, including:
74 - ar - create, modify and extract from archives,
75 - nm - lists symbols from object files,
76 - objcopy - copy and translate object files,
77 - objdump - display information from object files,
78 - ranlib - generate an index for the contents of an archive,
79 - size - list the section sizes of an object or archive file,
80 - strings - list printable strings from files,
81 - strip - discard symbols,
82 - addr2line - convert addresses to file and line.
83
84 %description -l es.UTF-8
85 Binutils es una colección de utilitarios necesarios para compilar
86 programas. Incluye assembler y linker, así como varios otros programas
87 para trabajar con formatos que se puedan ejecutar.
88
89 %description -l pl.UTF-8
90 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
91 programów. Znajdują się tutaj między innymi assembler, konsolidator
92 (linker), a także inne narzędzia do manipulowania binarnymi plikami
93 programów i bibliotek.
94
95 %description -l pt_BR.UTF-8
96 binutils é uma coletânea de utilitários necessários para compilar
97 programas. Inclui assembler e linker, assim como vários outros
98 programas para trabalhar com formatos executáveis.
99
100 %description -l ru.UTF-8
101 binutils - это набор инструментов, необходимых для компилляции
102 программ. Включает ассемблер, компоновщик и набор других программ для
103 работы с исполняемыми файлами разнообразных форматов.
104
105 %description -l uk.UTF-8
106 binutils - це набір інструментів, необхідних для компіляції програм.
107 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
108 виконуваними файлами різних форматів.
109
110 %package libs
111 Summary:        GNU binutils shared libraries
112 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
113 Group:          Libraries
114 Conflicts:      binutils < 3:2.17.50.0.8-3
115
116 %description libs
117 GNU binutils shared libraries (libbfd, libopcodes).
118
119 %description libs -l pl.UTF-8
120 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
121
122 %package devel
123 Summary:        Development files for GNU binutils libraries
124 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
125 Group:          Development/Libraries
126 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
127
128 %description devel
129 Development files for GNU binutils libraries (libbfd, libopcodes) and
130 static libiberty library.
131
132 %description devel -l pl.UTF-8
133 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
134 statyczna biblioteka libiberty.
135
136 %package static
137 Summary:        GNU binutils static libraries
138 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
139 Group:          Development/Libraries
140 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
141 #Requires:      zlib-static
142
143 %description static
144 Static GNU binutils libraries (libbfd, libopcodes).
145
146 %description static -l pl.UTF-8
147 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
148
149 %package gasp
150 Summary:        GASP - old preprocessor for assembly programs
151 Summary(pl.UTF-8):      GASP - stary preprocesor dla programów w asemblerze
152 Group:          Development/Tools
153 Requires:       %{name} = %{epoch}:%{version}-%{release}
154
155 %description gasp
156 GASP - old preprocessor for assembly programs. It's officially
157 obsoleted, but it's still needed to build some packages.
158
159 %description gasp -l pl.UTF-8
160 GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
161 uznany za przestarzały, ale jest nadal potrzebny do zbudowania
162 niektórych pakietów.
163
164 %prep
165 %setup -q
166 %{?with_gasp:%patch0 -p1}
167 %patch1 -p1
168 %patch2 -p1
169 %{?with_pax:%patch3 -p1}
170 %patch4 -p1
171
172 %patch6 -p1
173 %patch7 -p1
174 %patch8 -p1
175 %patch9 -p1
176 %patch10 -p1
177 %patch11 -p1
178 %patch12 -p1
179
180 # file contains hacks for ac 2.59 only
181 %{__rm} config/override.m4
182
183 %build
184 %{__aclocal}
185 %{__autoconf}
186
187 # non-standard regeneration (needed because of gasp patch)
188 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
189 for dir in gas bfd; do
190         cd $dir || exit 1
191         %{__aclocal} -I .. -I ../config -I ../bfd
192         %{__automake} Makefile
193         %{__automake} doc/Makefile
194         %{__autoconf}
195         cd ..
196 done
197
198 # More targets
199 TARGETS=
200 %ifarch ia64
201 TARGETS=i686-linux
202 %endif
203 # uhm?
204 %ifarch %{ix86}
205 TARGETS=x86_64-linux
206 %endif
207 %ifarch sparc
208 TARGETS=sparc64-linux
209 %endif
210 %ifarch %{x8664}
211 TARGETS="x86_64-pep"
212 %endif
213 %ifarch x32
214 TARGETS="x86_64-linux,x86_64-pep"
215 %endif
216 %{?addtargets:TARGETS="%{addtargets}"}
217
218 cp -f /usr/share/automake/config.* .
219 CFLAGS="%{rpmcflags}"; export CFLAGS
220 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
221 CC="%{__cc}"; export CC
222 CXX="%{__cxx}"; export CXX
223 %ifarch sparc
224 sparc32 \
225 %endif
226 ./configure %{_target_platform} \
227         --prefix=%{_prefix} \
228         --libdir=%{_libdir} \
229         --infodir=%{_infodir} \
230         --mandir=%{_mandir} \
231         --disable-debug \
232         --disable-werror \
233 %ifarch sparc
234         --enable-64-bit-bfd \
235 %else
236         %{?with_allarchs:--enable-64-bit-bfd} \
237 %endif
238         --enable-build-warnings=,-Wno-missing-prototypes \
239         --enable-install-libiberty \
240         --enable-lto \
241         --enable-plugins \
242         --enable-shared \
243         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
244         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
245         --with-tooldir=%{_prefix} \
246         --with-zlib \
247 %if %{with gold}
248         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
249 %endif
250
251 %{__make} -j1
252
253 %{?with_tests:%{__make} -j1 check}
254
255 %install
256 rm -rf $RPM_BUILD_ROOT
257 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
258
259 %{__make} install \
260         DESTDIR=$RPM_BUILD_ROOT
261
262 # remove these man pages unless we cross-build for win*/netware platforms.
263 # however, this should be done in Makefiles.
264 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
265
266 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
267
268 # overwrite libiberty.a with PIC version
269 cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
270
271 # remove evil -L pointing inside builder's home
272 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
273
274 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
275
276 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
277
278 %find_lang bfd
279 %find_lang binutils
280 %find_lang gas
281 %find_lang gprof
282 touch ld.lang gold.lang
283 %find_lang ld
284 %if %{with gold}
285 %find_lang gold
286 %endif
287 %find_lang opcodes
288 cat bfd.lang opcodes.lang > %{name}-libs.lang
289 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
290
291 %clean
292 rm -rf $RPM_BUILD_ROOT
293
294 %post   -p /sbin/postshell
295 -/usr/sbin/fix-info-dir -c %{_infodir}
296
297 %postun -p /sbin/postshell
298 -/usr/sbin/fix-info-dir -c %{_infodir}
299
300 %post   libs -p /sbin/ldconfig
301 %postun libs -p /sbin/ldconfig
302
303 %post   devel -p /sbin/postshell
304 -/usr/sbin/fix-info-dir -c %{_infodir}
305
306 %postun devel -p /sbin/postshell
307 -/usr/sbin/fix-info-dir -c %{_infodir}
308
309 %post   gasp -p /sbin/postshell
310 -/usr/sbin/fix-info-dir -c %{_infodir}
311
312 %postun gasp -p /sbin/postshell
313 -/usr/sbin/fix-info-dir -c %{_infodir}
314
315 %files -f %{name}.lang
316 %defattr(644,root,root,755)
317 %doc README
318 %{?with_gold:%doc gold/{ChangeLog,README,TODO}}
319 %attr(755,root,root) %{_bindir}/addr2line
320 %attr(755,root,root) %{_bindir}/ar
321 %attr(755,root,root) %{_bindir}/as
322 %attr(755,root,root) %{_bindir}/c++filt
323 %attr(755,root,root) %{_bindir}/elfedit
324 %attr(755,root,root) %{_bindir}/gprof
325 %attr(755,root,root) %{_bindir}/ld
326 %attr(755,root,root) %{_bindir}/ld.bfd
327 %if %{with gold}
328 %attr(755,root,root) %{_bindir}/ld.gold
329 %attr(755,root,root) %{_bindir}/dwp
330 %endif
331 %attr(755,root,root) %{_bindir}/nm
332 %attr(755,root,root) %{_bindir}/objcopy
333 %attr(755,root,root) %{_bindir}/objdump
334 %attr(755,root,root) %{_bindir}/ranlib
335 %attr(755,root,root) %{_bindir}/readelf
336 %attr(755,root,root) %{_bindir}/size
337 %attr(755,root,root) %{_bindir}/strings
338 %attr(755,root,root) %{_bindir}/strip
339 %{_prefix}/lib/ldscripts
340 %{_infodir}/as.info*
341 %{_infodir}/binutils.info*
342 %{_infodir}/gprof.info*
343 %{_infodir}/ld.info*
344 %{_mandir}/man1/addr2line.1*
345 %{_mandir}/man1/ar.1*
346 %{_mandir}/man1/as.1*
347 %{_mandir}/man1/c++filt.1*
348 %{_mandir}/man1/elfedit.1*
349 %{_mandir}/man1/gprof.1*
350 %{_mandir}/man1/ld.1*
351 %{_mandir}/man1/nm.1*
352 %{_mandir}/man1/objcopy.1*
353 %{_mandir}/man1/objdump.1*
354 %{_mandir}/man1/ranlib.1*
355 %{_mandir}/man1/readelf.1*
356 %{_mandir}/man1/size.1*
357 %{_mandir}/man1/strings.1*
358 %{_mandir}/man1/strip.1*
359 %lang(cs) %{_mandir}/cs/man1/*
360 %lang(de) %{_mandir}/de/man1/*
361 %lang(es) %{_mandir}/es/man1/*
362 %lang(fi) %{_mandir}/fi/man1/*
363 %lang(fr) %{_mandir}/fr/man1/*
364 %lang(hu) %{_mandir}/hu/man1/*
365 %lang(ja) %{_mandir}/ja/man1/*
366 %lang(pl) %{_mandir}/pl/man1/*
367
368 %files libs -f %{name}-libs.lang
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_libdir}/libbfd-%{version}.so
371 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
372 %dir %{_libdir}/bfd-plugins
373
374 %files devel
375 %defattr(644,root,root,755)
376 %attr(755,root,root) %{_libdir}/libbfd.so
377 %attr(755,root,root) %{_libdir}/libopcodes.so
378 %{_libdir}/libbfd.la
379 %{_libdir}/libopcodes.la
380 %{_libdir}/libiberty.a
381 %{_includedir}/ansidecl.h
382 %{_includedir}/bfd.h
383 %{_includedir}/bfdlink.h
384 %{_includedir}/diagnostics.h
385 %{_includedir}/dis-asm.h
386 %{_includedir}/plugin-api.h
387 %{_includedir}/symcat.h
388 %{_includedir}/libiberty
389 %{_infodir}/bfd.info*
390
391 %files static
392 %defattr(644,root,root,755)
393 %{_libdir}/libbfd.a
394 %{_libdir}/libopcodes.a
395
396 %if %{with gasp}
397 %files gasp
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_bindir}/gasp
400 %{_infodir}/gasp.info*
401 %endif
This page took 0.144905 seconds and 4 git commands to generate.