]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
c764fa0c48eb72c8a07907574f8b122d57b306e6
[packages/binutils.git] / binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(pl):    Narzêdzia GNU dla programistów
3 Name:           binutils
4 Version:        2.9.1.0.24
5 Release:        2
6 Copyright:      GPL
7 Group:          Development/Tools
8 Group(pl):      Programowanie/Narzêdzia
9 #######         ftp://ftp.varesearch.com/pub/support/hjl/binutils/
10 Source:         %{name}-%{version}.tar.gz
11 Patch0:         binutils-info.patch
12 BuildRoot:      /tmp/%{name}-%{version}-root
13
14 %description
15 binutils is a collection of utilities necessary for compiling programs. It
16 includes the assembler and linker, as well as a number of other
17 miscellaneous programs for dealing with executable formats.
18
19 %description -l pl
20 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê programów. 
21 Znajduj± siê tutaj miêdzy innymi assembler, konsolidator (linker), a tak¿e 
22 inne narzêdzia do manipulowania binarnymi plikami programów i bibliotek.
23
24 %package        static
25 Summary:        GNU Binutils static libraries
26 Summary(pl):    Biblioteki statyczne do GNU Binutils
27 Group:          Development/Libraries
28 Group(pl):      Programowanie/Biblioteki
29 Requires:       %{name} = %{version}
30
31 %description static
32 Static libraries for GNU Binutils.
33
34 %description -l pl static
35 Biblioteki statyczne GNU Binutils.
36
37 %prep
38 %setup -q 
39 %patch0 -p1
40
41 %build
42 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
43 %ifarch sparc sparc64
44 sparc32 ./configure %{_target} \
45 %else
46     ./configure \
47          --prefix=%{_prefix} \
48          --enable-shared \
49          --disable-debug \
50          --infodir=%{_infodir} %{_target_platform}
51 %endif
52
53 make tooldir=/usr all info
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 install -d $RPM_BUILD_ROOT/usr
59
60 make install install-info \
61         prefix=$RPM_BUILD_ROOT/usr \
62         tooldir=$RPM_BUILD_ROOT/usr \
63         mandir=$RPM_BUILD_ROOT%{_mandir} \
64         infodir=$RPM_BUILD_ROOT%{_infodir}
65
66 gzip -9nf $RPM_BUILD_ROOT%{_infodir}/*.inf*
67
68 rm -f $RPM_BUILD_ROOT%{_bindir}/c++filt $RPM_BUILD_ROOT%{_mandir}/man1/c++*
69
70 strip $RPM_BUILD_ROOT%{_bindir}/*
71 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so
72
73 install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
74
75 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
76         README
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 /sbin/install-info %{_infodir}/as.info.gz /etc/info-dir
83 /sbin/install-info %{_infodir}/bfd.info.gz /etc/info-dir
84 /sbin/install-info %{_infodir}/binutils.info.gz /etc/info-dir 
85 /sbin/install-info %{_infodir}/ld.info.gz /etc/info-dir
86 /sbin/install-info %{_infodir}/gasp.info.gz /etc/info-dir 
87 /sbin/install-info %{_infodir}/gprof.info.gz /etc/info-dir 
88 /sbin/ldconfig
89
90 %preun
91 if [ "$1" = "0" ]; then
92         /sbin/install-info --delete %{_infodir}/as.info.gz /etc/info-dir
93         /sbin/install-info --delete %{_infodir}/bfd.info.gz /etc/info-dir
94         /sbin/install-info --delete %{_infodir}/binutils.info.gz /etc/info-dir
95         /sbin/install-info --delete %{_infodir}/ld.info.gz /etc/info-dir
96         /sbin/install-info --delete %{_infodir}/gasp.info.gz /etc/info-dir
97         /sbin/install-info --delete %{_infodir}/gprof.info.gz /etc/info-dir
98 fi
99
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc *.gz
105
106 %attr(755,root,root) %{_bindir}/*
107 %attr(755,root,root) %{_libdir}/*.so
108
109 %{_libdir}/ldscripts
110 %{_includedir}/*.h
111
112 %{_infodir}/*.gz
113
114 %{_libdir}/libiberty.a
115 %{_mandir}/man1/*
116
117 %files static
118 %defattr(644,root,root,755)
119
120 %{_libdir}/libbfd.a
121 %{_libdir}/libopcodes.a
122
123 %changelog
124 * Mon May 17 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
125  [2.9.1.0.24-2]
126 - removed c++filt -- provides by egcs (at now...) 
127 - used some macros,
128 - FHS-2.0 changes.
129
130 * Thu Apr 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
131   [2.9.1.0.23-2]
132 - recompiles on new rpm.
133
134 * Wed Apr  7 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
135   [2.9.1.0.23-1]
136 - standarized {un}registering info pages (added binutils-info.patch).
137
138 * Thu Feb 18 1999 Micha³ Kuratczyk <kura@wroclaw.art.pl>
139   [2.9.1.0.19-5d]
140 - gzipping instead bzipping
141 - added LDFLAGS=-s
142 - minor changes
143
144 * Mon Jan 18 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
145   [2.9.1.0.19-4d]
146 - fixed %preun && %post,
147 - commpresed %doc,
148 - added Group(pl),
149 - added Prereq: /sbin/ldconfig,
150 - added URL,
151
152   by Maciek W. Ró¿ycki <macro@ds2.pg.gda.pl>    
153
154 - fixed the binary BFD to correctly output sections,
155 - modified gas so it recognizes single-argument aad and aam,
156 - modified gas so iret generates a non-prefixed opcode
157   regardless of the current argument size.
158 - added support for new Pentium II instructions (see "Addendum
159   -- Intel Architecture Software Developer's Manual, Volume 2:
160   Instruction Set Reference", order number 243689-001),
161 - fixed a problem with relative branch distance overflow checking,
162 - added a fix for 16-bit PC-relative relocations on i386.
163
164 * Sun Dec 20 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
165   [2.9.1.0.19-2d]
166 - removed static subpackages,
167 - cosmetic changes,
168 - final build for Tornado.
169
170 * Wed Dec  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
171   [2.9.1.0.17-2] 
172 - added using sparc32 for run ./configure script on sparc
173   architecture (thanks DaveM).
174
175 * Fri Oct  9 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
176   [2.9.1.0.15-2]
177 - /usr/lib/libiberty.a moved to main.
178
179 * Sat Oct 03 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
180   [2.9.1.0.15-1d]
181 - fixed pl translation,
182 - updated to 2.9.1.0.15.
183
184 * Sun Sep 13 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
185   [2.9.1.0.12-1d]
186 - updated to 2.9.1.0.12.
187 - install -d instead mkdir -p,
188 - restricted ELF binaries permissions.
189
190 * Tue Sep 07 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
191   [2.9.1.0.11-1d]
192 - updated to 2.9.1.0.11,
193 - build without $RPM_OPT_FLAGS - some problems with egcs & -O6 ...
194 - added a static package,
195 - build from non root's account.
196
197 * Sat Aug 22 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
198   [2.9.1.0.10-3]
199 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
200 - added using %%{name} and %%{version} in Source,
201 - added static subpackage,
202 - removed /usr/lib/lib*.la files,
203 - added using $RPM_OPT_FLAGS during building package.
204
205 * Fri Jun 12 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
206   [2.9.1.0.6-2]
207 - build against GNU libc-2.1.
208
209 * Fri May 29 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
210 - Replaced binutils to binutils-2.9.1.0.6,
211 - start at RH spec file.
This page took 0.057479 seconds and 2 git commands to generate.