]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- release 2
[packages/binutils.git] / binutils.spec
1 # TODO: PR/26302 <https://sourceware.org/bugzilla/show_bug.cgi?id=26302> (breaks kernel-tools build)
2 #
3 # Conditional build:
4 %bcond_with     allarchs        # enable all targets
5 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
6                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
7 %bcond_with     pax             # without PaX flags (for upstream bugreports)
8 %bcond_without  gold            # don't build gold (no C++ dependencies)
9 %bcond_without  default_bfd     # default ld.bfd instead of gold
10 %bcond_without  debuginfod      # debuginfo lokups with debuginfod
11 %bcond_without  gprofng         # gprofng
12 %bcond_without  jansson         # Package Metadata embedding support
13 %bcond_without  msgpack         # msgpack support
14 %bcond_with     tests           # check target
15
16 %ifnarch %{ix86} %{x8664} x32 aarch64 %{arm}
17 %undefine       with_gold
18 %endif
19 %ifnarch %{ix86} %{x8664} aarch64
20 %undefine       with_gprofng    1
21 %endif
22
23 Summary:        GNU Binary Utility Development Utilities
24 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
25 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
26 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
27 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
28 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
29 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
30 Summary(tr.UTF-8):      GNU geliştirme araçları
31 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
32 Name:           binutils
33 Version:        2.40
34 Release:        2
35 Epoch:          4
36 License:        GPL v3+
37 Group:          Development/Tools
38 Source0:        https://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
39 # Source0-md5:  be3411283c27eb0984104a2fda12e102
40 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
42 Patch1:         %{name}-info.patch
43 Patch2:         %{name}-libtool-relink.patch
44 Patch3:         %{name}-pt_pax_flags.patch
45
46 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
47 Patch7:         %{name}-libtool-m.patch
48 Patch9:         %{name}-tooldir.patch
49 Patch10:        %{name}-sanity-check.patch
50 URL:            http://www.sourceware.org/binutils/
51 BuildRequires:  autoconf >= 2.69
52 BuildRequires:  automake >= 1:1.11
53 BuildRequires:  bison
54 %{?with_debuginfod:BuildRequires:       elfutils-debuginfod-devel >= 0.179}
55 BuildRequires:  flex
56 BuildRequires:  gettext-tools
57 %{?with_jansson:BuildRequires:  jansson-devel}
58 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
59 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
60 BuildRequires:  lzip
61 %{?with_msgpack:BuildRequires:  msgpack-devel}
62 BuildRequires:  perl-tools-pod
63 BuildRequires:  pkgconfig
64 BuildRequires:  rpmbuild(macros) >= 1.527
65 %ifarch sparc sparc32
66 BuildRequires:  sparc32
67 %endif
68 BuildRequires:  tar >= 1:1.22
69 BuildRequires:  texinfo >= 6.3
70 BuildRequires:  zlib-devel
71 %{?with_tests:BuildRequires:    zlib-static}
72 BuildRequires:  zstd-devel
73 %{?with_debuginfod:Requires:    elfutils-debuginfod-libs >= 0.179}
74 Conflicts:      gcc-c++ < 5:3.3
75 Conflicts:      modutils < 2.4.17
76 Conflicts:      rpmbuild(macros) < 1.660
77 Obsoletes:      binutils-gold < 3:2.21.51.0.7-2
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Binutils is a collection of binary utilities, including:
82 - ar - create, modify and extract from archives,
83 - nm - lists symbols from object files,
84 - objcopy - copy and translate object files,
85 - objdump - display information from object files,
86 - ranlib - generate an index for the contents of an archive,
87 - size - list the section sizes of an object or archive file,
88 - strings - list printable strings from files,
89 - strip - discard symbols,
90 - addr2line - convert addresses to file and line.
91
92 %description -l es.UTF-8
93 Binutils es una colección de utilitarios necesarios para compilar
94 programas. Incluye assembler y linker, así como varios otros programas
95 para trabajar con formatos que se puedan ejecutar.
96
97 %description -l pl.UTF-8
98 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
99 programów. Znajdują się tutaj między innymi assembler, konsolidator
100 (linker), a także inne narzędzia do manipulowania binarnymi plikami
101 programów i bibliotek.
102
103 %description -l pt_BR.UTF-8
104 binutils é uma coletânea de utilitários necessários para compilar
105 programas. Inclui assembler e linker, assim como vários outros
106 programas para trabalhar com formatos executáveis.
107
108 %description -l ru.UTF-8
109 binutils - это набор инструментов, необходимых для компилляции
110 программ. Включает ассемблер, компоновщик и набор других программ для
111 работы с исполняемыми файлами разнообразных форматов.
112
113 %description -l uk.UTF-8
114 binutils - це набір інструментів, необхідних для компіляції програм.
115 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
116 виконуваними файлами різних форматів.
117
118 %package libs
119 Summary:        GNU binutils shared libraries
120 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
121 Group:          Libraries
122 Conflicts:      binutils < 3:2.17.50.0.8-3
123
124 %description libs
125 GNU binutils shared libraries (libbfd, libopcodes).
126
127 %description libs -l pl.UTF-8
128 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
129
130 %package devel
131 Summary:        Development files for GNU binutils libraries
132 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
133 Group:          Development/Libraries
134 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
135
136 %description devel
137 Development files for GNU binutils libraries (libbfd, libopcodes) and
138 static libiberty library.
139
140 %description devel -l pl.UTF-8
141 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
142 statyczna biblioteka libiberty.
143
144 %package static
145 Summary:        GNU binutils static libraries
146 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
149 #Requires:      zlib-static
150
151 %description static
152 Static GNU binutils libraries (libbfd, libopcodes).
153
154 %description static -l pl.UTF-8
155 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
156
157 %prep
158 %setup -q
159 %patch1 -p1
160 %patch2 -p1
161 %{?with_pax:%patch3 -p1}
162
163 %patch6 -p1
164 %patch7 -p1
165 %patch9 -p1
166 %patch10 -p1
167
168 %{__sed} -i -e '1s,.*env perl,#!%{__perl},' gprofng/gp-display-html/gp-display-html.in
169
170 # file contains hacks for ac 2.69 only
171 %{__rm} config/override.m4
172
173 %build
174 %{__aclocal}
175 %{__autoconf}
176
177 # non-standard regeneration
178 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
179 for dir in gas bfd; do
180         cd $dir || exit 1
181         %{__aclocal} -I .. -I ../config -I ../bfd
182         %{__automake} Makefile
183         test -f doc/Makefile.am && %{__automake} doc/Makefile
184         %{__autoconf}
185         cd ..
186 done
187 cd libctf
188 %{__aclocal} -I.. -I../config -I../bfd
189 %{__autoconf}
190 %{__autoheader}
191 %{__automake}
192 cd ..
193
194 # More targets
195 TARGETS=
196 %ifarch ia64
197 TARGETS=i686-linux
198 %endif
199 # uhm?
200 %ifarch %{ix86}
201 TARGETS=x86_64-linux
202 %endif
203 %ifarch sparc
204 TARGETS=sparc64-linux
205 %endif
206 %ifarch %{x8664}
207 TARGETS="x86_64-pep"
208 %endif
209 %ifarch x32
210 TARGETS="x86_64-linux,x86_64-pep"
211 %endif
212 %{?addtargets:TARGETS="%{addtargets}"}
213
214 cp -f /usr/share/automake/config.* .
215 CFLAGS="%{rpmcflags}"; export CFLAGS
216 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
217 CC="%{__cc}"; export CC
218 CXX="%{__cxx}"; export CXX
219 %ifarch sparc
220 sparc32 \
221 %endif
222 ./configure %{_target_platform} \
223         --prefix=%{_prefix} \
224         --libdir=%{_libdir} \
225         --infodir=%{_infodir} \
226         --mandir=%{_mandir} \
227         --sysconfdir=%{_sysconfdir} \
228         --disable-debug \
229         --disable-silent-rules \
230         --disable-werror \
231 %ifarch sparc
232         --enable-64-bit-bfd \
233 %else
234         %{?with_allarchs:--enable-64-bit-bfd} \
235 %endif
236         --enable-build-warnings=,-Wno-missing-prototypes \
237         --enable-install-libiberty \
238         --enable-lto \
239         --enable-plugins \
240         --enable-shared \
241         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
242         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
243         --with-tooldir=%{_prefix} \
244         --with-system-zlib \
245 %if %{with gold}
246         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
247 %endif
248         %{__with_without msgpack} \
249         %{__enable_disable jansson} \
250         %{__with_without debuginfod}
251
252 %{__make}
253
254 %{?with_tests:%{__make} -j1 check}
255
256 %install
257 rm -rf $RPM_BUILD_ROOT
258 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
259
260 %{__make} -j1 install \
261         DESTDIR=$RPM_BUILD_ROOT
262
263 # remove these man pages unless we cross-build for win*/netware platforms.
264 # however, this should be done in Makefiles.
265 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
266
267 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
268
269 # overwrite libiberty.a with PIC version
270 cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
271
272 # remove evil -L pointing inside builder's home
273 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
274
275 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
276
277 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
278
279 %if %{with gold}
280 install -d gold-doc
281 cp -p gold/{README,ChangeLog,TODO} gold-doc
282 %endif
283
284 %find_lang bfd
285 %find_lang binutils
286 %find_lang gas
287 %find_lang gprof
288 touch ld.lang gold.lang
289 %find_lang ld
290 %if %{with gold}
291 %find_lang gold
292 %endif
293 %find_lang opcodes
294 cat bfd.lang opcodes.lang > %{name}-libs.lang
295 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
296
297 %clean
298 rm -rf $RPM_BUILD_ROOT
299
300 %post   -p /sbin/postshell
301 -/usr/sbin/fix-info-dir -c %{_infodir}
302
303 %postun -p /sbin/postshell
304 -/usr/sbin/fix-info-dir -c %{_infodir}
305
306 %post   libs -p /sbin/ldconfig
307 %postun libs -p /sbin/ldconfig
308
309 %post   devel -p /sbin/postshell
310 -/usr/sbin/fix-info-dir -c %{_infodir}
311
312 %postun devel -p /sbin/postshell
313 -/usr/sbin/fix-info-dir -c %{_infodir}
314
315 %files -f %{name}.lang
316 %defattr(644,root,root,755)
317 %doc README
318 %{?with_gold:%doc gold-doc}
319 %{?with_gprofng:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gprofng.rc}
320 %attr(755,root,root) %{_bindir}/addr2line
321 %attr(755,root,root) %{_bindir}/ar
322 %attr(755,root,root) %{_bindir}/as
323 %attr(755,root,root) %{_bindir}/c++filt
324 %attr(755,root,root) %{_bindir}/elfedit
325 %if %{with gprofng}
326 %attr(755,root,root) %{_bindir}/gp-archive
327 %attr(755,root,root) %{_bindir}/gp-collect-app
328 %attr(755,root,root) %{_bindir}/gp-display-html
329 %attr(755,root,root) %{_bindir}/gp-display-src
330 %attr(755,root,root) %{_bindir}/gp-display-text
331 %attr(755,root,root) %{_bindir}/gprofng
332 %endif
333 %attr(755,root,root) %{_bindir}/gprof
334 %attr(755,root,root) %{_bindir}/ld
335 %attr(755,root,root) %{_bindir}/ld.bfd
336 %if %{with gold}
337 %attr(755,root,root) %{_bindir}/ld.gold
338 %attr(755,root,root) %{_bindir}/dwp
339 %endif
340 %attr(755,root,root) %{_bindir}/nm
341 %attr(755,root,root) %{_bindir}/objcopy
342 %attr(755,root,root) %{_bindir}/objdump
343 %attr(755,root,root) %{_bindir}/ranlib
344 %attr(755,root,root) %{_bindir}/readelf
345 %attr(755,root,root) %{_bindir}/size
346 %attr(755,root,root) %{_bindir}/strings
347 %attr(755,root,root) %{_bindir}/strip
348 %if %{with gprofng}
349 %dir %{_libdir}/gprofng
350 %attr(755,root,root) %{_libdir}/gprofng/libgp-collector.so
351 %attr(755,root,root) %{_libdir}/gprofng/libgp-collectorAPI.so
352 %attr(755,root,root) %{_libdir}/gprofng/libgp-heap.so
353 %attr(755,root,root) %{_libdir}/gprofng/libgp-iotrace.so
354 %attr(755,root,root) %{_libdir}/gprofng/libgp-sync.so
355 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so.*.*.*
356 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so.0
357 %endif
358 %{_prefix}/lib/ldscripts
359 %{_infodir}/as.info*
360 %{_infodir}/binutils.info*
361 %{_infodir}/ctf-spec.info*
362 %{_infodir}/gprof.info*
363 %{?with_gprofng:%{_infodir}/gprofng.info*}
364 %{_infodir}/ld.info*
365 %{_infodir}/sframe-spec.info*
366 %{_mandir}/man1/addr2line.1*
367 %{_mandir}/man1/ar.1*
368 %{_mandir}/man1/as.1*
369 %{_mandir}/man1/c++filt.1*
370 %{_mandir}/man1/elfedit.1*
371 %if %{with gprofng}
372 %{_mandir}/man1/gp-archive.*
373 %{_mandir}/man1/gp-collect-app.*
374 %{_mandir}/man1/gp-display-html.*
375 %{_mandir}/man1/gp-display-src.*
376 %{_mandir}/man1/gp-display-text.*
377 %{_mandir}/man1/gprofng.1*
378 %endif
379 %{_mandir}/man1/gprof.1*
380 %{_mandir}/man1/ld.1*
381 %{_mandir}/man1/nm.1*
382 %{_mandir}/man1/objcopy.1*
383 %{_mandir}/man1/objdump.1*
384 %{_mandir}/man1/ranlib.1*
385 %{_mandir}/man1/readelf.1*
386 %{_mandir}/man1/size.1*
387 %{_mandir}/man1/strings.1*
388 %{_mandir}/man1/strip.1*
389 %lang(cs) %{_mandir}/cs/man1/*
390 %lang(de) %{_mandir}/de/man1/*
391 %lang(es) %{_mandir}/es/man1/*
392 %lang(fi) %{_mandir}/fi/man1/*
393 %lang(fr) %{_mandir}/fr/man1/*
394 %lang(hu) %{_mandir}/hu/man1/*
395 %lang(ja) %{_mandir}/ja/man1/*
396 %lang(pl) %{_mandir}/pl/man1/*
397
398 %files libs -f %{name}-libs.lang
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/libbfd-%{version}.so
401 %attr(755,root,root) %{_libdir}/libctf.so.*.*
402 %attr(755,root,root) %ghost %{_libdir}/libctf.so.0
403 %attr(755,root,root) %{_libdir}/libctf-nobfd.so.*.*
404 %attr(755,root,root) %ghost %{_libdir}/libctf-nobfd.so.0
405 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
406 %attr(755,root,root) %{_libdir}/libsframe.so.*.*
407 %attr(755,root,root) %ghost %{_libdir}/libsframe.so.0
408 %dir %{_libdir}/bfd-plugins
409 %attr(755,root,root) %{_libdir}/bfd-plugins/libdep.so
410
411 %files devel
412 %defattr(644,root,root,755)
413 %attr(755,root,root) %{_libdir}/libbfd.so
414 %attr(755,root,root) %{_libdir}/libctf.so
415 %attr(755,root,root) %{_libdir}/libctf-nobfd.so
416 %attr(755,root,root) %{_libdir}/libopcodes.so
417 %attr(755,root,root) %{_libdir}/libsframe.so
418 %{?with_gprofng:%attr(755,root,root) %{_libdir}/gprofng/libgprofng.so}
419 %{_libdir}/libbfd.la
420 %{_libdir}/libctf.la
421 %{_libdir}/libctf-nobfd.la
422 %{_libdir}/libopcodes.la
423 %{_libdir}/libiberty.a
424 %{_libdir}/libsframe.la
425 %{_includedir}/ansidecl.h
426 %{_includedir}/bfd.h
427 %{_includedir}/bfdlink.h
428 %{_includedir}/ctf-api.h
429 %{_includedir}/ctf.h
430 %{_includedir}/diagnostics.h
431 %{_includedir}/dis-asm.h
432 %{_includedir}/plugin-api.h
433 %{_includedir}/sframe-api.h
434 %{_includedir}/sframe.h
435 %{_includedir}/symcat.h
436 %{_includedir}/libiberty
437 %if %{with gprofng}
438 %{_includedir}/collectorAPI.h
439 %{_includedir}/libcollector.h
440 %{_includedir}/libfcollector.h
441 %endif
442 %{_infodir}/bfd.info*
443
444 %files static
445 %defattr(644,root,root,755)
446 %{_libdir}/libbfd.a
447 %{_libdir}/libctf.a
448 %{_libdir}/libctf-nobfd.a
449 %{_libdir}/libopcodes.a
450 %{_libdir}/libsframe.a
This page took 0.072746 seconds and 3 git commands to generate.