]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
165e87d2fb37a4bf97baa7c89a8bdcb3ed69eba6
[packages/binutils.git] / binutils.spec
1 # TODO: PR/26302 <https://sourceware.org/bugzilla/show_bug.cgi?id=26302> (breaks kernel-tools build)
2 #
3 # Conditional build:
4 %bcond_with     allarchs        # enable all targets
5 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
6                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
7 %bcond_with     pax             # without PaX flags (for upstream bugreports)
8 %bcond_without  gold            # don't build gold (no C++ dependencies)
9 %bcond_without  default_bfd     # default ld.bfd instead of gold
10 %bcond_without  debuginfod      # debuginfo lokups with debuginfod
11 %bcond_without  gprofng         # gprofng
12 %bcond_without  jansson         # Package Metadata embedding support
13 %bcond_without  msgpack         # msgpack support
14 %bcond_with     tests           # check target
15
16 %ifnarch %{ix86} %{x8664} x32 aarch64 %{arm}
17 %undefine       with_gold
18 %endif
19 %ifnarch %{ix86} %{x8664} aarch64
20 %undefine       with_gprofng    1
21 %endif
22
23 Summary:        GNU Binary Utility Development Utilities
24 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
25 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
26 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
27 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
28 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
29 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
30 Summary(tr.UTF-8):      GNU geliştirme araçları
31 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
32 Name:           binutils
33 Version:        2.40
34 Release:        3
35 Epoch:          4
36 License:        GPL v3+
37 Group:          Development/Tools
38 Source0:        https://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
39 # Source0-md5:  be3411283c27eb0984104a2fda12e102
40 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
42 Patch1:         %{name}-info.patch
43 Patch2:         %{name}-libtool-relink.patch
44 Patch3:         %{name}-pt_pax_flags.patch
45
46 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
47 Patch7:         %{name}-libtool-m.patch
48 Patch9:         %{name}-tooldir.patch
49 Patch10:        %{name}-sanity-check.patch
50 URL:            http://www.sourceware.org/binutils/
51 BuildRequires:  autoconf >= 2.69
52 BuildRequires:  automake >= 1:1.11
53 BuildRequires:  bison
54 %{?with_debuginfod:BuildRequires:       elfutils-debuginfod-devel >= 0.179}
55 BuildRequires:  flex
56 BuildRequires:  gettext-tools
57 %{?with_jansson:BuildRequires:  jansson-devel}
58 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
59 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
60 BuildRequires:  lzip
61 %{?with_msgpack:BuildRequires:  msgpack-devel}
62 BuildRequires:  perl-tools-pod
63 BuildRequires:  pkgconfig
64 BuildRequires:  rpmbuild(macros) >= 1.527
65 %ifarch sparc sparc32
66 BuildRequires:  sparc32
67 %endif
68 BuildRequires:  tar >= 1:1.22
69 BuildRequires:  texinfo >= 6.3
70 BuildRequires:  zlib-devel
71 %{?with_tests:BuildRequires:    zlib-static}
72 BuildRequires:  zstd-devel
73 %{?with_debuginfod:Requires:    elfutils-debuginfod-libs >= 0.179}
74 Conflicts:      gcc-c++ < 5:3.3
75 Conflicts:      modutils < 2.4.17
76 Conflicts:      rpmbuild(macros) < 1.660
77 Obsoletes:      binutils-gold < 3:2.21.51.0.7-2
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Binutils is a collection of binary utilities, including:
82 - ar - create, modify and extract from archives,
83 - nm - lists symbols from object files,
84 - objcopy - copy and translate object files,
85 - objdump - display information from object files,
86 - ranlib - generate an index for the contents of an archive,
87 - size - list the section sizes of an object or archive file,
88 - strings - list printable strings from files,
89 - strip - discard symbols,
90 - addr2line - convert addresses to file and line.
91
92 %description -l es.UTF-8
93 Binutils es una colección de utilitarios necesarios para compilar
94 programas. Incluye assembler y linker, así como varios otros programas
95 para trabajar con formatos que se puedan ejecutar.
96
97 %description -l pl.UTF-8
98 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
99 programów. Znajdują się tutaj między innymi assembler, konsolidator
100 (linker), a także inne narzędzia do manipulowania binarnymi plikami
101 programów i bibliotek.
102
103 %description -l pt_BR.UTF-8
104 binutils é uma coletânea de utilitários necessários para compilar
105 programas. Inclui assembler e linker, assim como vários outros
106 programas para trabalhar com formatos executáveis.
107
108 %description -l ru.UTF-8
109 binutils - это набор инструментов, необходимых для компилляции
110 программ. Включает ассемблер, компоновщик и набор других программ для
111 работы с исполняемыми файлами разнообразных форматов.
112
113 %description -l uk.UTF-8
114 binutils - це набір інструментів, необхідних для компіляції програм.
115 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
116 виконуваними файлами різних форматів.
117
118 %package libs
119 Summary:        GNU binutils shared libraries
120 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
121 Group:          Libraries
122 Conflicts:      binutils < 3:2.17.50.0.8-3
123
124 %description libs
125 GNU binutils shared libraries (libbfd, libopcodes).
126
127 %description libs -l pl.UTF-8
128 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
129
130 %package devel
131 Summary:        Development files for GNU binutils libraries
132 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
133 Group:          Development/Libraries
134 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
135
136 %description devel
137 Development files for GNU binutils libraries (libbfd, libopcodes) and
138 static libiberty library.
139
140 %description devel -l pl.UTF-8
141 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
142 statyczna biblioteka libiberty.
143
144 %package static
145 Summary:        GNU binutils static libraries
146 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
149 #Requires:      zlib-static
150
151 %description static
152 Static GNU binutils libraries (libbfd, libopcodes).
153
154 %description static -l pl.UTF-8
155 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
156
157 %package gprofng
158 Summary:        GNU Next Generation profiler
159 Summary(pl.UTF-8):      Narzędzie profilujące GNU Next Generation
160 Group:          Development/Tools
161 Requires:       %{name} = %{epoch}:%{version}-%{release}
162 Requires:       coreutils
163 Requires:       hostname
164 Requires:       perl-base >= 1:5.10.0
165 Requires:       which
166
167 %description gprofng
168 Gprofng is the GNU Next Generation profiler for analyzing the
169 performance of Linux applications. Gprofng allows you to:
170 - Profile C / C++ / Java / Scala applications without needing to
171   recompile
172 - Profile multi-threaded applications
173 - Analyze and compare multiple experiments
174 - Use time-based sampling and / or hardware event counters
175
176 %description gprofng -l pl.UTF-8
177 Gprofng jest narzędziem profilującym GNU Next Generation do analizy
178 wydajności aplikacji w systemie Linux. Gprofng pozwala na:
179 - Profilowanie aplikacji C / C++ / Java / Scala bez potrzeby ponownej
180   kompilacji
181 - Profilowanie aplikacji wielowątkowych
182 - Analizę i porównanie wielu eksperymentów
183 - Użycie próbkowania w dziedzinie czasu i/lub sprzętowych liczników
184   zdarzeń
185
186 %prep
187 %setup -q
188 %patch1 -p1
189 %patch2 -p1
190 %{?with_pax:%patch3 -p1}
191
192 %patch6 -p1
193 %patch7 -p1
194 %patch9 -p1
195 %patch10 -p1
196
197 %{__sed} -i -e '1s,.*env perl,#!%{__perl},' gprofng/gp-display-html/gp-display-html.in
198
199 # file contains hacks for ac 2.69 only
200 %{__rm} config/override.m4
201
202 %build
203 %{__aclocal}
204 %{__autoconf}
205
206 # non-standard regeneration
207 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
208 for dir in gas bfd; do
209         cd $dir || exit 1
210         %{__aclocal} -I .. -I ../config -I ../bfd
211         %{__automake} Makefile
212         test -f doc/Makefile.am && %{__automake} doc/Makefile
213         %{__autoconf}
214         cd ..
215 done
216 cd libctf
217 %{__aclocal} -I.. -I../config -I../bfd
218 %{__autoconf}
219 %{__autoheader}
220 %{__automake}
221 cd ..
222
223 # More targets
224 TARGETS=
225 %ifarch ia64
226 TARGETS=i686-linux
227 %endif
228 # uhm?
229 %ifarch %{ix86}
230 TARGETS=x86_64-linux
231 %endif
232 %ifarch sparc
233 TARGETS=sparc64-linux
234 %endif
235 %ifarch %{x8664}
236 TARGETS="x86_64-pep"
237 %endif
238 %ifarch x32
239 TARGETS="x86_64-linux,x86_64-pep"
240 %endif
241 %{?addtargets:TARGETS="%{addtargets}"}
242
243 cp -f /usr/share/automake/config.* .
244 CFLAGS="%{rpmcflags}"; export CFLAGS
245 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
246 CC="%{__cc}"; export CC
247 CXX="%{__cxx}"; export CXX
248 %ifarch sparc
249 sparc32 \
250 %endif
251 ./configure %{_target_platform} \
252         --prefix=%{_prefix} \
253         --libdir=%{_libdir} \
254         --infodir=%{_infodir} \
255         --mandir=%{_mandir} \
256         --sysconfdir=%{_sysconfdir} \
257         --disable-debug \
258         --disable-silent-rules \
259         --disable-werror \
260 %ifarch sparc
261         --enable-64-bit-bfd \
262 %else
263         %{?with_allarchs:--enable-64-bit-bfd} \
264 %endif
265         --enable-build-warnings=,-Wno-missing-prototypes \
266         --enable-install-libiberty \
267         --enable-lto \
268         --enable-plugins \
269         --enable-shared \
270         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
271         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
272         --with-tooldir=%{_prefix} \
273         --with-system-zlib \
274 %if %{with gold}
275         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
276 %endif
277         %{__with_without msgpack} \
278         %{__enable_disable jansson} \
279         %{__with_without debuginfod}
280
281 %{__make}
282
283 %{?with_tests:%{__make} -j1 check}
284
285 %install
286 rm -rf $RPM_BUILD_ROOT
287 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
288
289 %{__make} -j1 install \
290         DESTDIR=$RPM_BUILD_ROOT
291
292 # remove these man pages unless we cross-build for win*/netware platforms.
293 # however, this should be done in Makefiles.
294 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
295
296 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
297
298 # overwrite libiberty.a with PIC version
299 cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
300
301 # remove evil -L pointing inside builder's home
302 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
303
304 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
305
306 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
307
308 %if %{with gold}
309 install -d gold-doc
310 cp -p gold/{README,ChangeLog,TODO} gold-doc
311 %endif
312
313 %find_lang bfd
314 %find_lang binutils
315 %find_lang gas
316 %find_lang gprof
317 touch ld.lang gold.lang
318 %find_lang ld
319 %if %{with gold}
320 %find_lang gold
321 %endif
322 %find_lang opcodes
323 cat bfd.lang opcodes.lang > %{name}-libs.lang
324 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
325
326 %clean
327 rm -rf $RPM_BUILD_ROOT
328
329 %post   -p /sbin/postshell
330 -/usr/sbin/fix-info-dir -c %{_infodir}
331
332 %postun -p /sbin/postshell
333 -/usr/sbin/fix-info-dir -c %{_infodir}
334
335 %post   libs -p /sbin/ldconfig
336 %postun libs -p /sbin/ldconfig
337
338 %post   devel -p /sbin/postshell
339 -/usr/sbin/fix-info-dir -c %{_infodir}
340
341 %postun devel -p /sbin/postshell
342 -/usr/sbin/fix-info-dir -c %{_infodir}
343
344 %post   gprofng -p /sbin/postshell
345 -/usr/sbin/fix-info-dir -c %{_infodir}
346
347 %postun gprofng -p /sbin/postshell
348 -/usr/sbin/fix-info-dir -c %{_infodir}
349
350 %files -f %{name}.lang
351 %defattr(644,root,root,755)
352 %doc README
353 %{?with_gold:%doc gold-doc}
354 %attr(755,root,root) %{_bindir}/addr2line
355 %attr(755,root,root) %{_bindir}/ar
356 %attr(755,root,root) %{_bindir}/as
357 %attr(755,root,root) %{_bindir}/c++filt
358 %attr(755,root,root) %{_bindir}/elfedit
359 %attr(755,root,root) %{_bindir}/gprof
360 %attr(755,root,root) %{_bindir}/ld
361 %attr(755,root,root) %{_bindir}/ld.bfd
362 %if %{with gold}
363 %attr(755,root,root) %{_bindir}/ld.gold
364 %attr(755,root,root) %{_bindir}/dwp
365 %endif
366 %attr(755,root,root) %{_bindir}/nm
367 %attr(755,root,root) %{_bindir}/objcopy
368 %attr(755,root,root) %{_bindir}/objdump
369 %attr(755,root,root) %{_bindir}/ranlib
370 %attr(755,root,root) %{_bindir}/readelf
371 %attr(755,root,root) %{_bindir}/size
372 %attr(755,root,root) %{_bindir}/strings
373 %attr(755,root,root) %{_bindir}/strip
374 %{_prefix}/lib/ldscripts
375 %{_infodir}/as.info*
376 %{_infodir}/binutils.info*
377 %{_infodir}/ctf-spec.info*
378 %{_infodir}/gprof.info*
379 %{_infodir}/ld.info*
380 %{_infodir}/sframe-spec.info*
381 %{_mandir}/man1/addr2line.1*
382 %{_mandir}/man1/ar.1*
383 %{_mandir}/man1/as.1*
384 %{_mandir}/man1/c++filt.1*
385 %{_mandir}/man1/elfedit.1*
386 %{_mandir}/man1/gprof.1*
387 %{_mandir}/man1/ld.1*
388 %{_mandir}/man1/nm.1*
389 %{_mandir}/man1/objcopy.1*
390 %{_mandir}/man1/objdump.1*
391 %{_mandir}/man1/ranlib.1*
392 %{_mandir}/man1/readelf.1*
393 %{_mandir}/man1/size.1*
394 %{_mandir}/man1/strings.1*
395 %{_mandir}/man1/strip.1*
396 %lang(cs) %{_mandir}/cs/man1/*
397 %lang(de) %{_mandir}/de/man1/*
398 %lang(es) %{_mandir}/es/man1/*
399 %lang(fi) %{_mandir}/fi/man1/*
400 %lang(fr) %{_mandir}/fr/man1/*
401 %lang(hu) %{_mandir}/hu/man1/*
402 %lang(ja) %{_mandir}/ja/man1/*
403 %lang(pl) %{_mandir}/pl/man1/*
404
405 %files libs -f %{name}-libs.lang
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/libbfd-%{version}.so
408 %attr(755,root,root) %{_libdir}/libctf.so.*.*
409 %attr(755,root,root) %ghost %{_libdir}/libctf.so.0
410 %attr(755,root,root) %{_libdir}/libctf-nobfd.so.*.*
411 %attr(755,root,root) %ghost %{_libdir}/libctf-nobfd.so.0
412 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
413 %attr(755,root,root) %{_libdir}/libsframe.so.*.*
414 %attr(755,root,root) %ghost %{_libdir}/libsframe.so.0
415 %dir %{_libdir}/bfd-plugins
416 %attr(755,root,root) %{_libdir}/bfd-plugins/libdep.so
417
418 %files devel
419 %defattr(644,root,root,755)
420 %attr(755,root,root) %{_libdir}/libbfd.so
421 %attr(755,root,root) %{_libdir}/libctf.so
422 %attr(755,root,root) %{_libdir}/libctf-nobfd.so
423 %attr(755,root,root) %{_libdir}/libopcodes.so
424 %attr(755,root,root) %{_libdir}/libsframe.so
425 %{_libdir}/libbfd.la
426 %{_libdir}/libctf.la
427 %{_libdir}/libctf-nobfd.la
428 %{_libdir}/libopcodes.la
429 %{_libdir}/libiberty.a
430 %{_libdir}/libsframe.la
431 %{_includedir}/ansidecl.h
432 %{_includedir}/bfd.h
433 %{_includedir}/bfdlink.h
434 %{_includedir}/ctf-api.h
435 %{_includedir}/ctf.h
436 %{_includedir}/diagnostics.h
437 %{_includedir}/dis-asm.h
438 %{_includedir}/plugin-api.h
439 %{_includedir}/sframe-api.h
440 %{_includedir}/sframe.h
441 %{_includedir}/symcat.h
442 %{_includedir}/libiberty
443 %{_infodir}/bfd.info*
444
445 %files static
446 %defattr(644,root,root,755)
447 %{_libdir}/libbfd.a
448 %{_libdir}/libctf.a
449 %{_libdir}/libctf-nobfd.a
450 %{_libdir}/libopcodes.a
451 %{_libdir}/libsframe.a
452
453 %if %{with gprofng}
454 %files gprofng
455 %defattr(644,root,root,755)
456 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gprofng.rc
457 %attr(755,root,root) %{_bindir}/gp-archive
458 %attr(755,root,root) %{_bindir}/gp-collect-app
459 %attr(755,root,root) %{_bindir}/gp-display-html
460 %attr(755,root,root) %{_bindir}/gp-display-src
461 %attr(755,root,root) %{_bindir}/gp-display-text
462 %attr(755,root,root) %{_bindir}/gprofng
463 %dir %{_libdir}/gprofng
464 %attr(755,root,root) %{_libdir}/gprofng/libgp-collector.so
465 %attr(755,root,root) %{_libdir}/gprofng/libgp-collectorAPI.so
466 %attr(755,root,root) %{_libdir}/gprofng/libgp-heap.so
467 %attr(755,root,root) %{_libdir}/gprofng/libgp-iotrace.so
468 %attr(755,root,root) %{_libdir}/gprofng/libgp-sync.so
469 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so.*.*.*
470 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so.0
471 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so
472 %{_infodir}/gprofng.info*
473 %{_mandir}/man1/gp-archive.*
474 %{_mandir}/man1/gp-collect-app.*
475 %{_mandir}/man1/gp-display-html.*
476 %{_mandir}/man1/gp-display-src.*
477 %{_mandir}/man1/gp-display-text.*
478 %{_mandir}/man1/gprofng.1*
479 %{_includedir}/collectorAPI.h
480 %{_includedir}/libcollector.h
481 %{_includedir}/libfcollector.h
482 %endif
This page took 0.255835 seconds and 3 git commands to generate.