]> git.pld-linux.org Git - packages/bcg729.git/blob - bcg729.spec
- rediff patch, rel 3
[packages/bcg729.git] / bcg729.spec
1 #
2 # Conditional build:
3 %bcond_without  mediastreamer   # mediastreamer plugin
4
5 Summary:        ITU G729 Annex A speech codec library
6 Summary(pl.UTF-8):      Biblioteka kodeka mowy ITU G729 Annex A
7 Name:           bcg729
8 Version:        1.0.2
9 Release:        3
10 License:        GPL v2+, ITU G729 patent license may be required
11 Group:          Libraries
12 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/plugins/sources/%{name}-%{version}.tar.gz
13 # Source0-md5:  2a3d9b422912024f97a41e56e9e3d357
14 Patch0:         %{name}-lib.patch
15 URL:            http://www.linphone.org/eng/documentation/dev/bcg729.html
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake
18 BuildRequires:  libtool >= 2:2
19 %{?with_mediastreamer:BuildRequires:    mediastreamer-devel >= 2.9.0}
20 %{?with_mediastreamer:BuildRequires:    ortp-devel >= 0.21.0}
21 BuildRequires:  pkgconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 bcg729 is an opensource implementation of both encoder and decoder of
26 the ITU G729 Annex A speech codec. The library written in C99 is fully
27 portable and can be executed on many platforms including both ARM
28 processor and x86. libbcg729 supports concurrent channels
29 encoding/decoding for multi call application such conferencing. This
30 project was initially developed as part of Mediastreamer2, the
31 Linphone's media processing engine. So there is also available the
32 glue to be integrated in Linphone/Mediastreamer2.
33
34 %description -l pl.UTF-8
35 bcg729 to implementacja o otwartych źródłach kodera oraz dekorera
36 kodeka mowy ITU G729 Annex A. Biblioteka napisana w dialekcie C99 jest
37 w pełni przenośna i może być uruchamiana na wielu platformach, w tym
38 procesorach ARM i x86. libbcg729 obsługuje jednoczesne
39 kodowanie/dekodowanie wielu kanałów dla zastosowań z wieloma
40 rozmowami,takich jak konferencje. Ten projekt początkowo był częścią
41 Mediastreamera2 - silnika przetwarzania multimediów programu Linphone.
42 Dlatego jest też dostępny kod łączący z Linphonem/Mediastreamerem2.
43
44 %package devel
45 Summary:        Header files for bcg729 library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki bcg729
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for bcg729 library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki bcg729.
55
56 %package static
57 Summary:        Static bcg729 library
58 Summary(pl.UTF-8):      Statyczna biblioteka bcg729
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static bcg729 library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka bcg729.
67
68 %package -n mediastreamer-plugin-msbcg729
69 Summary:        ITU G729 Annex A speech codec for mediastreamer
70 Summary(pl.UTF-8):      Kodek mowy ITU G729 Annex A dla mediastreamera
71 Group:          Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       mediastreamer >= 2.9.0
74
75 %description -n mediastreamer-plugin-msbcg729
76 This package supplies the mediastreamer plugin for the ITU G729 Annex
77 A speech codec.
78
79 %description -n mediastreamer-plugin-msbcg729 -l pl.UTF-8
80 Ten pakiet udostępnia wtyczkę mediastreamera do kodeka mowy ITU G729
81 Annex A.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         %{!?with_mediastreamer:--disable-msplugin} \
95         --disable-silent-rules
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 # dlopened plugin
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins/libmsbcg729.{la,a}
107 # obsoleted by pkg-config
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbcg729.la
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS README
119 %attr(755,root,root) %{_libdir}/libbcg729.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libbcg729.so.0
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libbcg729.so
125 %{_includedir}/bcg729
126 %{_pkgconfigdir}/libbcg729.pc
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libbcg729.a
131
132 %if %{with mediastreamer}
133 %files -n mediastreamer-plugin-msbcg729
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/mediastreamer/plugins/libmsbcg729.so*
136 %endif
This page took 0.305829 seconds and 4 git commands to generate.