]> git.pld-linux.org Git - packages/baculafs.git/blob - baculafs.spec
- release 2 (by relup.sh)
[packages/baculafs.git] / baculafs.spec
1 %define         pypi_name       BaculaFS
2 Summary:        Exposes the Bacula catalog and storage as a Filesystem in USErspace
3 Name:           baculafs
4 Version:        0.1.7
5 Release:        2
6 License:        GPL v3+
7 Group:          Networking/Utilities
8 Source0:        https://pypi.python.org/packages/source/B/BaculaFS/%{pypi_name}-%{version}.tar.gz
9 # Source0-md5:  50dcca4d11eeaa98fe0382dfd58243db
10 URL:            https://code.google.com/p/baculafs/
11 BuildRequires:  rpmbuild(macros) >= 1.710
12 BuildRequires:  python >= 1:2.6.6
13 BuildRequires:  python-fuse >= 0.2.1
14 BuildRequires:  python-pexpect >= 2.3
15 Requires:       attr >= 2.4.44
16 Requires:       bacula-sd
17 Requires:       libfuse >= 2.8.4
18 Requires:       python >= 1:2.6.6
19 Requires:       python-MySQLdb >= 1.2.2
20 Requires:       python-fuse >= 0.2.1
21 Requires:       python-pexpect >= 2.3-7
22 Requires:       python-psycopg2 >= 2.0.13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 BaculaFS is a tool, developed independently of Bacula, that represents
28 the Bacula catalog and backup storage media as a read-only filesystem
29 in userspace.
30
31 BaculaFS is specifically designed to cater for the following
32 use-cases:
33 - maintaining a remote snapshot of the files in the backup storage
34   using rsync or duplicity
35 - auditing the contents of backup jobs, without resorting to SQL
36   queries
37 - comparing backup jobs (using several mount points)
38
39 Note that BaculaFS is a maintenance tool - its operation may interfere
40 with the normal operation of a live Bacula setup.
41
42 %prep
43 %setup -q -n %{pypi_name}-%{version}
44
45 # Remove bundled egg-info
46 %{__rm} -r %{pypi_name}.egg-info
47
48 %build
49 %py_build
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %py_install
54
55 %py_postclean
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README.rst
63 %attr(755,root,root) %{_bindir}/baculafs
64 %dir %{py_sitescriptdir}/baculafs
65 %{py_sitescriptdir}/baculafs/*.py[co]
66 %{py_sitescriptdir}/BaculaFS-%{version}-py*.egg-info
This page took 0.056846 seconds and 3 git commands to generate.