]> git.pld-linux.org Git - packages/autopano-sift-C.git/blob - autopano-sift-C.spec
- new
[packages/autopano-sift-C.git] / autopano-sift-C.spec
1 Summary:        SIFT Feature Detection implementation
2 Summary(pl.UTF-8):      Implementacja algorytmu SIFT do wykrywania cech obrazu
3 Name:           autopano-sift-C
4 Version:        2.5.0
5 Release:        1
6 License:        GPL v2, but SIFT algorithm may require license in some countries
7 Group:          Applications/Graphics
8 Source0:        http://dl.sourceforge.net/hugin/%{name}-%{version}.tar.gz
9 # Source0-md5:  d4e6bfab53fe227a36eec4c94c0bbfe6
10 URL:            http://wiki.panotools.org/Autopano-sift-C
11 BuildRequires:  cmake
12 BuildRequires:  libjpeg-devel
13 BuildRequires:  libpano13-devel
14 BuildRequires:  libpng-devel
15 BuildRequires:  libtiff-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libxml2-devel >= 2.0
18 BuildRequires:  pkgconfig
19 BuildRequires:  sed >= 4.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The SIFT algorithm provides the capability to identify key feature
24 points within arbitrary images. It further extracts highly distinct
25 information for each such point and allows to characterize the point
26 invariant to a number of modifications to the image. It is invariant
27 to contrast/brightness changes, to rotation, scaling and partially
28 invariant to other kinds of transformations. The algorithm can be
29 flexibly used to create input data for image matching, object
30 identification and other computer vision related algorithms.
31
32 autopano-sift-C is a C port of the C# software autopano-sift. It is
33 somewhat faster and doesn't require a C# runtime. Additionally,
34 autopano-sift-C has experimental modifications to perform feature
35 identification in conformal image space, this helps with wide angle or
36 fisheye Projection photographs.
37
38 %description -l pl.UTF-8
39 Algorytm SIFT daje możliwość określenia kluczowych punktów
40 charakterystycznych na dowolnych zdjęciach. Następnie wydobywa
41 informacje wyodrębniające dla każdego takiego punktu i pozwala
42 scharakteryzować ten punkt niezależnie od liczby modyfikacji obrazu.
43 Jest niezależny od zmian kontrastu/jasności, obrotów, skalowania i
44 częściowo niezależny od innych rodzajów przekształceń. Algorytm może
45 być elastycznie używany do tworzenia danych wejściowych do
46 dopasowywania obrazów, identyfikowania obiektów i innych algorytmów
47 związanych z grafiką komputerową.
48
49 autopano-sift-C to port C programu autopano-sift napisanego w C#.
50 Jest nieco szybszy i nie wymaga środowiska uruchomieniowego C#.
51 Ponadto zawiera nieco eksperymentalnych modyfikacji w celu
52 przeprowadzania identyfikacji punktów w wiernokątnej przestrzeni
53 obrazu, co pomaga przy zdjęciach obiektywami szerokokątnymi lub
54 "rybim okiem".
55
56 %prep
57 %setup -q 
58
59 # don't override our optflags with cmake-predefined values
60 sed -i 's/NOT CMAKE_BUILD_TYPE/GFY/' CMakeLists.txt
61
62 %build
63 install -d build
64 cd build
65 # CMAKE_AR is a hack, cmake is unable to find it otherwise :/
66 %cmake .. \
67         -DCMAKE_AR=/usr/bin/ar \
68         %{?debug:-DCMAKE_BUILD_TYPE=Debug} \
69         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
70         -DCMAKE_VERBOSE_MAKEFILE=ON \
71 %if "%{_lib}" == "64"
72         -DLIB_PREFIX=64
73 %endif
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # resolve conflict with autopano-sift
84 mv $RPM_BUILD_ROOT%{_mandir}/man1/autopano{,-c}.1
85 mv $RPM_BUILD_ROOT%{_mandir}/man1/generatekeys{,-c}.1
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc ChangeLog README README.1ST
93 %attr(755,root,root) %{_bindir}/autopano
94 %attr(755,root,root) %{_bindir}/autopano-c-complete.sh
95 %attr(755,root,root) %{_bindir}/autopano-sift-c
96 %attr(755,root,root) %{_bindir}/generatekeys
97 %{_mandir}/man1/autopano-c.1*
98 %{_mandir}/man1/autopano-c-complete.1*
99 %{_mandir}/man1/generatekeys-c.1*
100 %{_mandir}/man7/autopano-sift-c.7*
This page took 0.08247 seconds and 4 git commands to generate.