]> git.pld-linux.org Git - packages/apache1-mod_vhost_limit.git/blob - apache1-mod_vhost_limit.spec
- mv apache{,1}-*
[packages/apache1-mod_vhost_limit.git] / apache1-mod_vhost_limit.spec
1 %define         mod_name        vhost_limit
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: vhost_limit limits
4 Summary(pl):    Modu³ do apache: limity pasma dla serwerów wirtualnych
5 Name:           apache1-mod_%{mod_name}
6 Version:        0.4
7 Release:        1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://www.nowhere-land.org/programs/mod_vhost_limit/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  bae36a7174e184804b91356ef67d0b5d
12 URL:            http://www.nowhere-land.org/programs/mod_vhost_limit/
13 BuildRequires:  apache1-devel
14 Requires(post,preun):   %{apxs}
15 Requires(post,preun):   grep
16 Requires(preun):        fileutils
17 Requires:       apache1
18 Requires:       crondaemon
19 Requires:       procps
20 Obsoletes:      apache-mod_%{mod_name} <= %{version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24 %define         _sysconfdir     /etc/apache
25
26 %description
27 This is the module for Apache Web Server to restrict the number of
28 simultaneous connections per a virtual host.
29
30 %description -l pl
31 Ten pakiet zawiera modu³ dla serwera WWW Apache s³u¿±cy do
32 ograniczania liczby jednoczesnych po³±czeñ dla serwerów wirtualnych.
33
34 %prep
35 %setup -q -n mod_%{mod_name}-%{version}
36
37 %build
38 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
43
44 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51 if [ -f /var/lock/subsys/apache ]; then
52         /etc/rc.d/init.d/apache restart 1>&2
53 fi
54
55 %preun
56 if [ "$1" = "0" ]; then
57         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
58         if [ -f /var/lock/subsys/apache ]; then
59                 /etc/rc.d/init.d/apache restart 1>&2
60         fi
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc */*html
66 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.080498 seconds and 4 git commands to generate.