]> git.pld-linux.org Git - packages/apache1-mod_snake.git/blob - apache1-mod_snake.spec
e5a55af7ef341a2f8387e22f4622c085c8f72a34
[packages/apache1-mod_snake.git] / apache1-mod_snake.spec
1 # NOTE
2 # - This project is RIP since Thu May 9 19:00:01 PDT 2002
3 # - and doesn't compile anyway
4 %define         mod_name        snake
5 %define         apxs            /usr/sbin/apxs1
6 Summary:        An Apache module to allow for Python plugins and control
7 Summary(pl):    Modu³ do Apache pozwalaj±cy na kontrolê i wtyczki Pythona
8 Name:           apache1-mod_%{mod_name}
9 Version:        0.5.0
10 Release:        1.2
11 License:        GPL
12 Group:          Networking/Daemons
13 Source0:        http://dl.sourceforge.net/mod%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  7c043871a66a8579c6fec561c5d6cb84
15 Patch0:         %{name}-dumb_acam.patch
16 URL:            http://modsnake.sourceforge.net/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache1-devel >= 1.3.33-2
19 BuildRequires:  python-devel >= 1.5
20 Requires:       apache1 >= 1.3.33-2
21 Obsoletes:      apache-mod_%{mod_name} <= %{version}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
26
27 %description
28 mod_snake is an Apache module which allows for execution of Python
29 code directly within the Apache server process. By including an
30 interpreter in the Apache process, Python CGIs are accelerated, Python
31 can be embedded within HTML and Python written modules can control the
32 internals of the webserver.
33
34 %description -l pl
35 mod_snake to modu³ Apache pozwalaj±cy na wykonywanie kodu Pythona
36 bezpo¶rednio w procesie serwera Apache. W³±czaj±c interpreter do
37 procesu Apache skrypty CGI w Pythonie s± znacznie przyspieszone.
38 Python mo¿e byæ umieszczany w HTML-u oraz modu³y Pythona mog±
39 kontrolowaæ wewnêtrzne sprawy serwera WWW.
40
41 %prep
42 %setup -q -n mod_%{mod_name}-%{version}
43 %patch0 -p0
44
45 %build
46 %configure2_13 \
47         --with-apxs=%{apxs} \
48         --enable-dso
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
54
55 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
56
57 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
58         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 if [ -f /var/lock/subsys/apache ]; then
65         /etc/rc.d/init.d/apache restart 1>&2
66 fi
67
68 %postun
69 if [ "$1" = "0" ]; then
70         if [ -f /var/lock/subsys/apache ]; then
71                 /etc/rc.d/init.d/apache restart 1>&2
72         fi
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
78 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.069653 seconds and 2 git commands to generate.