]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blob - apache1-mod_auth_pgsql.spec
- restart apache in %postun rather in %preun as the config file, loading module
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es):    Autenticación vía PostgreSQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it):    Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja):    PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(nb):    Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl):    Modu³ uwierzytelnienia PostgreSQL dla Apache
13 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
14 Summary(sv):    Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache1-mod_%{mod_name}
16 Version:        0.9.12
17 Release:        2
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
21 # Source0-md5:  7be403b7487c13cdb023cc526ee2e13a
22 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache1-devel >= 1.3.33-2
25 BuildRequires:  postgresql-devel >= 7
26 Requires(triggerpostun):        %{apxs}
27 Requires:       apache1 >= 1.3.33-2
28 Obsoletes:      apache-mod_%{mod_name} <= %{version}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
33
34 %description
35 This is an authentication module for Apache that allows you to
36 authenticate HTTP clients using PostgreSQL RDBMS.
37
38 %description -l cs
39 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
40 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
41 PostgreSQL.
42
43 %description -l de
44 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
45 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
46 einer Tabelle in einer PostgresQL-Datenbank prüft.
47
48 %description -l es
49 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
50 servidos desde un servidor web verificando datos en una base de datos
51 PostgreSQL.
52
53 %description -l fr
54 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
55 servis par un serveur Web en vérifiant des champs dans une table d'une
56 base de données PostgresQL.
57
58 %description -l it
59 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
60 serviti da un server Web controllando i campi di una tabella in un
61 database PostgresQL.
62
63 %description -l ja
64 Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
65 ¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
66 À©¸Â¤Ç¤­¤Þ¤¹¡£
67
68 %description -l pl
69 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
70 uwierzytelnianie klientów HTTP z u¿yciem bazy danych PostgreSQL.
71
72 %description -l pt_BR
73 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
74 PostgreSQL.
75
76 %description -l sv
77 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
78 servade av en webbserver genom att kontrollera data i en
79 PostgreSQL-databas.
80
81 %prep
82 %setup -q -n mod_%{mod_name}-%{version}
83
84 %build
85 %{apxs} \
86         -I%{_includedir}/postgresql \
87         -lpq \
88         -c mod_%{mod_name}.c \
89         -o mod_%{mod_name}.so
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
94
95 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
96
97 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
98         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 if [ -f /var/lock/subsys/apache ]; then
105         /etc/rc.d/init.d/apache restart 1>&2
106 fi
107
108 %postun
109 if [ "$1" = "0" ]; then
110         if [ -f /var/lock/subsys/apache ]; then
111                 /etc/rc.d/init.d/apache restart 1>&2
112         fi
113 fi
114
115 %triggerpostun -- apache1-mod_%{mod_name} < 0.9.12-1.1
116 # check that they're not using old apache.conf
117 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
118         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
119 fi
120
121 %files
122 %defattr(644,root,root,755)
123 %doc *.html
124 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
125 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.051627 seconds and 3 git commands to generate.