]> git.pld-linux.org Git - packages/apache-mod_auth_pgsql.git/blob - apache-mod_auth_pgsql.spec
- up to 2.0.3, fixes CVE-2005-3656
[packages/apache-mod_auth_pgsql.git] / apache-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es):    Autenticación vía PostgreSQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it):    Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja):    PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(nb):    Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl):    Modu³ uwierzytelnienia PostgreSQL dla Apache
13 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
14 Summary(sv):    Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        2.0.3
17 Release:        1
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://www.giuseppetanzilli.it/mod_auth_pgsql2/dist/mod_%{mod_name}-%{version}.tar.gz
21 # Source0-md5:  d44074b3b9bdb0a5eb9702814872ad43
22 Source1:        apache-mod_auth_pgsql.conf
23 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql2/
24 BuildRequires:  %{apxs}
25 BuildRequires:  apache-devel >= 2.0.52-2
26 BuildRequires:  postgresql-devel
27 BuildRequires:  rpmbuild(macros) >= 1.268
28 Requires:       apache(modules-api) = %apache_modules_api
29 Obsoletes:      mod_auth_pgsql
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
33 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
34
35 %description
36 This is an authentication module for Apache that allows you to
37 authenticate HTTP clients using PostgreSQL RDBMS.
38
39 %description -l cs
40 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
41 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
42 PostgreSQL.
43
44 %description -l de
45 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
46 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
47 einer Tabelle in einer PostgresQL-Datenbank prüft.
48
49 %description -l es
50 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
51 servidos desde un servidor web verificando datos en una base de datos
52 PostgreSQL.
53
54 %description -l fr
55 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
56 servis par un serveur Web en vérifiant des champs dans une table d'une
57 base de données PostgresQL.
58
59 %description -l it
60 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
61 serviti da un server Web controllando i campi di una tabella in un
62 database PostgresQL.
63
64 %description -l ja
65 Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
66 ¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
67 À©¸Â¤Ç¤­¤Þ¤¹¡£
68
69 %description -l pl
70 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
71 uwierzytelnianie klientów HTTP z u¿yciem bazy danych PostgreSQL.
72
73 %description -l pt_BR
74 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
75 PostgreSQL.
76
77 %description -l sv
78 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
79 servade av en webbserver genom att kontrollera data i en
80 PostgreSQL-databas.
81
82 %prep
83 %setup -q -n mod_%{mod_name}-%{version}
84
85 %build
86 %{apxs} \
87         -I%{_includedir}/postgresql \
88         -lpq \
89         -c mod_%{mod_name}.c \
90         -o mod_%{mod_name}.la
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
95
96 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
97 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/52_mod_auth_pgsql.conf
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 %service -q httpd restart
104
105 %preun
106 if [ "$1" = "0" ]; then
107         %service -q httpd restart
108 fi
109
110 %files
111 %defattr(644,root,root,755)
112 %doc *.html
113 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_auth_pgsql.conf
114 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.125343 seconds and 3 git commands to generate.