]> git.pld-linux.org Git - packages/alsa-patch-bay.git/blob - alsa-patch-bay.spec
09e67f5af8d175c6bab36865e86f68102650a706
[packages/alsa-patch-bay.git] / alsa-patch-bay.spec
1 #
2 # Conditional build:
3 %bcond_without  fltk    # without FLTK UI
4 %bcond_without  gtkmm   # without gtkmm UI
5 %bcond_without  ladcca  # with ladcca support
6 #
7 Summary:        Graphical patch bay for the ALSA sequencer and JACK
8 Summary(pl):    Graficzny interfejs dla sekwencera ALSY i JACK-a
9 Name:           alsa-patch-bay
10 Version:        1.0.0
11 Release:        3
12 License:        GPL
13 Group:          X11/Applications/Sound
14 Source0:        http://pkl.net/~node/software/%{name}-%{version}.tar.gz
15 # Source0-md5:  3aa458f6bee8b83b2cf7330707d72430
16 Patch0:         %{name}-Makefile.patch
17 Patch1:         %{name}-desktop_pl.patch
18 Patch2:         %{name}-missing_m4.patch
19 Patch3:         %{name}-pic.patch
20 URL:            http://pkl.net/~node/alsa-patch-bay.html
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 %{?with_fltk:BuildRequires:     fltk-devel >= 1.1}
24 %{?with_gtkmm:BuildRequires:    gtkmm22-devel}
25 BuildRequires:  jack-audio-connection-kit-devel >= 0.80.0
26 %{?with_ladcca:BuildRequires:   ladcca-devel}
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 Requires:       %{name}-ui = %{version}-%{release}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 ALSA Patch Bay is a GUI patchbay for the ALSA sequencer and
34 the JACK audio subsystems. In easy way connects ports of MIDI and
35 audio devices like sequencer, external keyboard, soft synth and
36 many others.
37
38 %description -l pl
39 ALSA Patch Bay to graficzny interfejs dla podsystemów sequencera
40 ALSY oraz d¼wiêkowego JACK-a. W ³atwy sposób ³±czy porty urz±dzeñ
41 MIDI i audio jak sekwencer, zewnêtrzne klawisze, synteza programowa
42 i wiele innych.
43
44 %package driver-alsa
45 Summary:        ALSA audio driver for ALSA Patch Bay
46 Summary(pl):    Sterownik d¼wiêku ALSA dla ALSA Patch Bay
47 Group:          X11/Applications/Sound
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       %{name}-ui = %{version}-%{release}
50
51 %description driver-alsa
52 ALSA audio driver for ALSA Patch Bay.
53
54 %description driver-alsa -l pl
55 Sterownik d¼wiêku ALSA dla ALSA Patch Bay.
56
57 %package driver-jack
58 Summary:        JACK audio driver for ALSA Patch Bay
59 Summary(pl):    Sterownik d¼wiêku JACK-a dla ALSA Patch Bay
60 Group:          X11/Applications/Sound
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       %{name}-driver-alsa = %{version}-%{release}
63 Requires:       %{name}-ui = %{version}-%{release}
64 Provides:       jack-patch-bay
65
66 %description driver-jack
67 JACK audio driver for ALSA Patch Bay.
68
69 %description driver-jack -l pl
70 Sterownik d¼wiêku JACK-a dla ALSA Patch Bay.
71
72 %package ui-fltk
73 Summary:        FLTK-based GUI for ALSA Patch Bay
74 Summary(pl):    Oparte na FLTK GUI do ALSA Patch Bay
75 Group:          X11/Applications/Sound
76 Requires:       %{name} = %{version}-%{release}
77 Provides:       %{name}-ui = %{version}-%{release}
78
79 %description ui-fltk
80 FLTK-based graphical user interface for ALSA Patch Bay.
81
82 %description ui-fltk -l pl
83 Oparty na FLTK graficzny interfejs u¿ytkownika do ALSA Patch Bay.
84
85 %package ui-gtkmm
86 Summary:        GTKmm-based GUI for ALSA Patch Bay
87 Summary(pl):    Oparte na GTKmm GUI do ALSA Patch Bay
88 Group:          X11/Applications/Sound
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       gtkmm22
91 Provides:       %{name}-ui = %{version}-%{release}
92
93 %description ui-gtkmm
94 GTKmm-based GUI for ALSA Patch Bay.
95
96 %description ui-gtkmm -l pl
97 Oparte na GTKmm GUI do ALSA Patch Bay.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105
106 %build
107 %{__libtoolize}
108 %{__autoheader}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__automake}
112 %configure \
113         %{!?with_fltk:--disable-fltk --disable-fltk-test} \
114         %{!?with_gtkmm:--disable-gtkmm} \
115         %{!?with_ladcca:--disable-ladcca} \
116         --disable-static
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/ui/*.la
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %doc NEWS AUTHORS README
134 %dir %{_libdir}/%{name}
135 %dir %{_libdir}/%{name}/driver
136 %dir %{_libdir}/%{name}/ui
137 %{_pixmapsdir}/*.png
138
139 %files driver-alsa
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/alsa-patch-bay
142 %attr(755,root,root) %{_libdir}/%{name}/driver/alsa.so
143 %{_desktopdir}/alsa-patch-bay.desktop
144
145 %files driver-jack
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/jack-patch-bay
148 %attr(755,root,root) %{_libdir}/%{name}/driver/jack.so
149 %{_desktopdir}/jack-patch-bay.desktop
150
151 %if %{with fltk}
152 %files ui-fltk
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/%{name}/ui/fltk.so
155 %endif
156
157 %if %{with gtkmm}
158 %files ui-gtkmm
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/%{name}/ui/gtkmm.so
161 %endif
This page took 0.090678 seconds and 2 git commands to generate.