]> git.pld-linux.org Git - packages/acx.git/blob - acx.spec
- set Name to acx100, kernel-net-acx100 as subpackage
[packages/acx.git] / acx.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 #
5 Summary:        Linux driver for WLAN card base on ACX100
6 Summary(pl):    Sterownik dla Linuksa do kart bezprzewodowych na uk³adzie ACX100
7 Name:           acx100
8 Version:        0.2.0pre8_plus_fixes_18
9 %define _rel    2
10 Release:        %{_rel}
11 License:        MPL or GPL
12 Group:          Base/Kernel
13 Source0:        http://rhlx01.fht-esslingen.de/~andi/acx100/%{name}-%{version}.tar.bz2
14 #Source0-MD5:   430aa98bc3cc3e7ee0cb0e0c170f4f8c
15 URL:            http://acx100.sourcefroge.net/index.html
16 %{?with_dist_kernel:BuildRequires:      kernel-headers >= 2.4.0}
17 BuildRequires:  %{kgcc_package}
18 BuildRequires:  rpmbuild(macros) >= 1.118
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is driver for WLAN card based on ACX100 for Linux.
23
24 %description -l pl
25 Sterownik dla Linuksa do kart WLAN opartych o uk³ad ACX100.
26
27 %package -n kernel-net-acx100
28 Summary:        Linux driver for WLAN card base on ACX100
29 Summary(pl):    Sterownik dla Linuksa do kart bezprzewodowych na uk³adzie ACX100
30 Release:        %{_rel}@%{_kernel_ver_str}
31 Group:          Base/Kernel
32 %{?with_dist_kernel:%requires_releq_kernel_up}
33 Requires(post,postun):  /sbin/depmod
34
35 %description -n kernel-net-acx100
36 This is driver for WLAN card based on ACX100 for Linux.
37
38 %description -n kernel-net-acx100 -l pl
39 Sterownik dla Linuksa do kart WLAN opartych o uk³ad ACX100.
40
41 %package -n kernel-smp-net-acx100
42 Summary:        Linux SMP driver for WLAN card base on ACX100
43 Summary(pl):    Sterownik dla Linuksa SMP do kart bezprzewodowych na uk³adzie ACX100
44 Release:        %{_rel}@%{_kernel_ver_str}
45 Group:          Base/Kernel
46 %{?with_dist_kernel:%requires_releq_kernel_smp}
47 Requires(post,postun):  /sbin/depmod
48
49 %description -n kernel-smp-net-acx100
50 Linux SMP driver for WLAN card base on ACX100.
51
52 %description -n kernel-smp-net-acx100 -l pl
53 Sterownik dla Linuksa SMP do kart bezprzewodowych na uk³adzie ACX100.
54
55 %prep
56 %setup -q
57
58 %build
59 cat > config.mk <<EOF
60 KERNEL_BUILD=%{_kernelsrcdir}
61 VERSION_CODE=`grep LINUX_VERSION_CODE %{_kernelsrcdir}/include/linux/version.h | sed -e 's/[^0-9]//g'`
62 EOF
63 %{__make} \
64         CC="%{kgcc}" \
65         CPPFLAGS="-D__KERNEL__ -DMODULE -DACX_DEBUG=1 -DWLAN_HOSTIF=WLAN_PCI -I%{_kernelsrcdir}/include -I../include" \
66         CFLAGS="%{rpmcflags} -fno-strict-aliasing -fno-common -fomit-frame-pointer -Wall -Wstrict-prototypes -Wno-trigraphs -mpreferred-stack-boundary=4 -pipe -DACX_IO_WIDTH=32"
67
68 mv -f src/acx_pci.o acx_pci-up.o
69 mv -f src/acx_usb.o acx_usb-up.o
70
71 %{__make} clean -C src
72 %{__make} \
73         CC="%{kgcc}" \
74         CPPFLAGS="-D__KERNEL__ -D__KERNEL_SMP -DMODULE -DACX_DEBUG=1 -DWLAN_HOSTIF=WLAN_PCI -I%{_kernelsrcdir}/include -I../include" \
75         CFLAGS="%{rpmcflags} -fno-strict-aliasing -fno-common -fomit-frame-pointer -Wall -Wstrict-prototypes -Wno-trigraphs -mpreferred-stack-boundary=4 -pipe -DACX_IO_WIDTH=32"
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
80
81 install acx_pci-up.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/acx_pci.o
82 install acx_usb-up.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/acx_usb.o
83 install src/acx_pci.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/acx_pci.o
84 install src/acx_usb.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/acx_usb.o
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -n kernel-net-acx100
90 %depmod %{_kernel_ver}
91
92 %postun -n kernel-net-acx100
93 %depmod %{_kernel_ver}
94
95 %post   -n kernel-smp-net-acx100
96 %depmod %{_kernel_ver}smp
97
98 %postun -n kernel-smp-net-acx100
99 %depmod %{_kernel_ver}smp
100
101 %files -n kernel-net-acx100
102 %defattr(644,root,root,755)
103 %doc ChangeLog README TODO doc/*
104 /lib/modules/%{_kernel_ver}/misc/*.o*
105
106 %files -n kernel-smp-net-acx100
107 %defattr(644,root,root,755)
108 %doc ChangeLog README TODO doc/*
109 /lib/modules/%{_kernel_ver}smp/misc/*.o*
This page took 0.035312 seconds and 4 git commands to generate.