]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
- rel 2; keep custom install-sh
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl.UTF-8):      Polecenie i biblioteka do manipulacji listami kontroli dostępu (ACL)
3 Name:           acl
4 Version:        2.2.47
5 Release:        2
6 License:        LGPL v2+ (library), GPL v2 (utilities)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}_%{version}-1.tar.gz
9 # Source0-md5:  a11e4571a54a0b1ae83010d1e68a64c2
10 Patch0:         %{name}-miscfix.patch
11 Patch1:         %{name}-lt.patch
12 Patch2:         %{name}-LDFLAGS.patch
13 Patch3:         %{name}-pl.po-update.patch
14 URL:            http://oss.sgi.com/projects/xfs/
15 BuildRequires:  attr-devel >= 2.4.16-3
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gettext-devel
19 BuildRequires:  libtool
20 Requires:       attr >= 2.4.15
21 Obsoletes:      libacl
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _bindir         /bin
25 %define         _libdir         /%{_lib}
26 %define         _libexecdir     /usr/%{_lib}
27
28 %description
29 A command (chacl) and a library (libacl) to manipulate POSIX access
30 control lists under Linux.
31
32 %description -l pl.UTF-8
33 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
34 POSIX listami kontroli dostępu (ACL) pod Linuksem.
35
36 %package devel
37 Summary:        Header files for acl library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki acl
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       attr-devel >= 2.4.16-3
42
43 %description devel
44 Header files to develop software which manipulate access control
45 lists.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe potrzebne do rozwoju oprogramowania manipulującego
49 listami kontroli dostępu (ACL).
50
51 %package static
52 Summary:        Static acl library
53 Summary(pl.UTF-8):      Statyczna biblioteka acl
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static acl library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka acl.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69
70 rm -f aclocal.m4
71
72 %build
73 mv install-sh install-custom-sh
74 %{__libtoolize}
75 %{__aclocal} -I m4
76 %{__autoconf}
77 mv install-custom-sh install-sh
78 %configure \
79         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
80         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
81
82 %{__make} \
83         LLDFLAGS="%{rpmldflags}" \
84         top_builddir="../"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
89
90 export DIST_ROOT=$RPM_BUILD_ROOT
91 P=$(pwd)
92 DIST_INSTALL=$P/install.manifest
93 DIST_INSTALL_DEV=$P/install-dev.manifest
94 DIST_INSTALL_LIB=$P/install-lib.manifest
95
96 %{__make} install \
97         DIST_MANIFEST=$DIST_INSTALL \
98         top_builddir="../"
99 %{__make} install-dev \
100         DIST_MANIFEST=$DIST_INSTALL_DEV \
101         top_builddir="../"
102 %{__make} install-lib \
103         DIST_MANIFEST=$DIST_INSTALL_LIB \
104         top_builddir="../"
105
106 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
107 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
108 echo ".so acl_copy_ext.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
109 echo ".so acl_get_fd.3"         > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
110 echo ".so acl_get_file.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
111 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
112 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
113
114 #rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
115 ln -snf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libacl.so.*.*.*) \
116         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
117 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
118         $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
119
120 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
121
122 # already in /usr
123 rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.{so,la,a}
124
125 %find_lang %{name}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc README doc/{CHANGES,TODO}
136 %attr(755,root,root) %{_bindir}/chacl
137 %attr(755,root,root) %{_bindir}/getfacl
138 %attr(755,root,root) %{_bindir}/setfacl
139 %attr(755,root,root) %{_libdir}/libacl.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libacl.so.1
141 %{_mandir}/man1/chacl.1*
142 %{_mandir}/man1/getfacl.1*
143 %{_mandir}/man1/setfacl.1*
144 %{_mandir}/man5/acl.5*
145
146 %files devel
147 %defattr(644,root,root,755)
148 %doc doc/{extensions.txt,libacl.txt}
149 %attr(755,root,root) %{_libexecdir}/libacl.so
150 %{_libexecdir}/libacl.la
151 %{_includedir}/acl
152 %{_includedir}/sys/acl.h
153 %{_mandir}/man3/acl_*.3*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libexecdir}/libacl.a
This page took 0.056735 seconds and 3 git commands to generate.