]> git.pld-linux.org Git - packages/accelio.git/commitdiff
- updated to 1.7 auto/th/accelio-1.7-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Dec 2016 23:18:00 +0000 (00:18 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Dec 2016 23:18:00 +0000 (00:18 +0100)
- updated fio patch to fix build with fio 2.14+

accelio-fio.patch
accelio.spec

index ce5f59436e3c6a8f211d2fd51a5572919a150f0c..f56f650c10153e0030afc1d676e698da35679e66 100644 (file)
  libraio_fio_la_LIBADD = -lraio -lxio $(libxio_rdma_ldflags) -lrt -ldl -lpthread  \\r
                        -L$(top_builddir)/src/usr/ -L$(top_builddir)/examples/raio/\r
  \r
+--- accelio-1.7/examples/raio/usr/fio/libraio.c.orig   2016-12-24 13:09:13.375548622 +0100
++++ accelio-1.7/examples/raio/usr/fio/libraio.c        2016-12-25 00:04:40.251766246 +0100
+@@ -107,7 +107,7 @@
+ static struct io_u *fio_libraio_event(struct thread_data *td, int event)
+ {
+-      struct libraio_data *ld = td->io_ops->data;
++      struct libraio_data *ld = td->io_ops_data;
+       struct raio_event *ev;
+       struct io_u *io_u;
+@@ -129,7 +129,7 @@
+ static int fio_libraio_getevents(struct thread_data *td, unsigned int min,
+                                unsigned int max, const struct timespec *t)
+ {
+-      struct libraio_data *ld = td->io_ops->data;
++      struct libraio_data *ld = td->io_ops_data;
+       unsigned actual_min = td->o.iodepth_batch_complete_min == 0 ? 0 : min;
+       int r, events = 0;
+@@ -152,7 +152,7 @@
+ static int fio_libraio_queue(struct thread_data *td, struct io_u *io_u)
+ {
+-      struct libraio_data *ld = td->io_ops->data;
++      struct libraio_data *ld = td->io_ops_data;
+       struct libraio_engine_data *engine_data = io_u->engine_data;
+       fio_ro_check(td, io_u);
+@@ -188,7 +188,7 @@
+ static int fio_libraio_commit(struct thread_data *td)
+ {
+-      struct libraio_data     *ld = td->io_ops->data;
++      struct libraio_data     *ld = td->io_ops_data;
+       struct raio_iocb        **iocbs;
+       struct io_u             **io_us;
+       int                     ret;
+@@ -221,7 +221,7 @@
+ static int fio_libraio_cancel(struct thread_data *td, struct io_u *io_u)
+ {
+-      struct libraio_data *ld = td->io_ops->data;
++      struct libraio_data *ld = td->io_ops_data;
+       struct libraio_engine_data *engine_data = io_u->engine_data;
+       return raio_cancel(ld->raio_ctx, &engine_data->iocb, ld->raio_events);
+@@ -357,7 +357,7 @@
+       char                    path[256];
+       char                    host[256];
+       uint32_t                port;
+-      struct libraio_data     *ld = td->io_ops->data;
++      struct libraio_data     *ld = td->io_ops_data;
+       dprint(FD_FILE, "fd open %s\n", f->file_name);
+@@ -436,7 +436,7 @@
+ static int fio_libraio_open_file(struct thread_data *td, struct fio_file *f)
+ {
+       int                     ret;
+-      struct libraio_data     *ld = td->io_ops->data;
++      struct libraio_data     *ld = td->io_ops_data;
+       if (ld->fd != -1) {
+               f->fd = ld->fd;
+@@ -475,7 +475,7 @@
+ static int fio_libraio_close_file(struct thread_data *td, struct fio_file *f)
+ {
+       int                     ret;
+-      struct libraio_data     *ld = td->io_ops->data;
++      struct libraio_data     *ld = td->io_ops_data;
+       /* don't close the file until cleanup */
+       if (ld->force_close == 0) {
+@@ -512,7 +512,7 @@
+               return 0;
+       }
+-      td->io_ops->data = &dummy_ld;
++      td->io_ops_data = &dummy_ld;
+       ret = fio_libraio_open(td, f);
+       if (ret != 0) {
+@@ -570,7 +570,7 @@
+       ld->iocbs_nr = 0;
+       ld->fd = -1;
+-      td->io_ops->data = ld;
++      td->io_ops_data = ld;
+       f.file_name = td->o.filename;
+       ret = fio_libraio_open_file(td, &f);
+@@ -597,7 +597,7 @@
+ static void fio_libraio_cleanup(struct thread_data *td)
+ {
+-      struct libraio_data             *ld = td->io_ops->data;
++      struct libraio_data             *ld = td->io_ops_data;
+       struct libraio_engine_data      *engine_data;
+       struct io_u                     *io_u;
+       int                             i;
+@@ -619,7 +619,7 @@
+               free(ld->io_us);
+               free(ld->engine_datas);
+               free(ld);
+-              td->io_ops->data = NULL;
++              td->io_ops_data = NULL;
+       }
+ }
index ead0e1d6c2bf814cf02fd9a77f0975f8637a5f02..b93043d7e67ddccb369cbd96faa2713c430d0487 100644 (file)
@@ -9,18 +9,19 @@
 Summary:       Open Source I/O, Message and RPC Acceleration library
 Summary(pl.UTF-8):     Mająca otwarte źródła biblioteka przyspieszająca we/wy, komunikaty i RPC
 Name:          accelio
-Version:       1.6
+Version:       1.7
 Release:       1
 License:       BSD
 Group:         Libraries
+#Source0Download: https://github.com/accelio/accelio/releases
 Source0:       https://github.com/accelio/accelio/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 0f6634e03ff1bf2e9b83e554202d093f
+# Source0-md5: b363e15ea8f7dac2179a610c1393a624
 Patch0:                %{name}-fio.patch
 Patch1:                %{name}-sse.patch
 URL:           http://www.accelio.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake >= 1:1.11
-%{?with_fio:BuildRequires:     fio-devel >= 2.8}
+%{?with_fio:BuildRequires:     fio-devel >= 2.14}
 BuildRequires: libaio-devel
 BuildRequires: libevent-devel >= 2
 BuildRequires: libibverbs-devel
This page took 0.065656 seconds and 4 git commands to generate.