]> git.pld-linux.org Git - packages/Zope-PlacelessTranslationService.git/blob - Zope-PlacelessTranslationService.spec
- moved PTS for separate package (needed by Silva)
[packages/Zope-PlacelessTranslationService.git] / Zope-PlacelessTranslationService.spec
1 %define         zope_subname    PlacelessTranslationService
2 Summary:        PTS is, a translation service for Zope
3 Summary(pl):    PTS jest serwisem, pomagaj±cym lokalizowaæ serwisy Zope
4 Name:           Zope-%{zope_subname}
5 Version:        1.0.1
6 Release:        1
7 License:        GPL v2
8 Group:          Development/Tools
9 Source0:        http://dl.sourceforge.net/collective/PlacelessTranslationService-%{version}.tar.gz
10 # Source0-md5:  755fa9cbc95dbd5cb1a609a09dca5f68
11 URL:            http://plone.org/products/pts/
12 BuildRequires:  python
13 %pyrequires_eq  python-modules
14 Requires:       Zope
15 Requires(post,postun):  /usr/sbin/installzopeproduct
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Conflicts:      Zope-CMFPlone <= 2.0.5-4
19
20 %description
21 PTS is, a translation service. It's a zope-wide service, which reads
22 "PO" format files containing translations for messages, and provides
23 these translations to Zope software when requested.
24
25 %description -l pl
26 PTS jest serwisem, pomagaj±cym lokalizowaæ serwisy Zope. Czyta pliki 
27 formatu "PO" zawieraj±ce t³umaczenia i udostêpnia te t³umaczenia, 
28 kiedy odpowiedni produkt o to poprosi.
29
30 %prep
31 %setup -q -c
32
33 %build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
38 cp -af %{zope_subname}/{i18n,tests,www,*.py,version.txt} $RPM_BUILD_ROOT%{_datadir}/%{name}
39
40 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
41 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
42
43 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
50 if [ -f /var/lock/subsys/zope ]; then
51         /etc/rc.d/init.d/zope restart >&2
52 fi
53
54 %postun
55 if [ "$1" = "0" ]; then
56         /usr/sbin/installzopeproduct -d %{zope_subname}
57         if [ -f /var/lock/subsys/zope ]; then
58                 /etc/rc.d/init.d/zope restart >&2
59         fi
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc %{zope_subname}/doc/readme.txt %{zope_subname}/NEWS.txt
65 %{_datadir}/%{name}
This page took 0.086644 seconds and 3 git commands to generate.