]> git.pld-linux.org Git - packages/Zope-CMFQuickInstallerTool.git/blob - Zope-CMFQuickInstallerTool.spec
- install into %{_datadir}/%{name}
[packages/Zope-CMFQuickInstallerTool.git] / Zope-CMFQuickInstallerTool.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CMFQuickInstallerTool
3 Summary:        CMFQuickInstallerTool - a Zope product independent from the former CMFQuickInstaller
4 Summary(pl):    CMFQuickInstallerTool - dodatek do Zope niezale¿ny od poprzedniego CMFQuickInstallera
5 Name:           Zope-%{zope_subname}
6 Version:        1.3
7 Release:        3
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://dl.sourceforge.net/collective/%{zope_subname}_%{version}.tgz
11 # Source0-md5:  60fff6fd03d1ab586479940561d17985
12 URL:            http://cvs.bluedynamics.org/viewcvs/CMFQuickInstallerTool/
13 %pyrequires_eq  python-modules
14 Requires:       Zope-CMF
15 Requires:       Zope
16 Requires(post,postun):  /usr/sbin/installzopeproduct
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      CMF
20
21 %define         product_dir     /usr/lib/zope/Products
22
23 %description
24 CMFQuickInstallerTool is a Zope product independent from the former
25 CMFQuickInstaller. The main difference to CMFQuickInstaller the
26 tracking of what a product creates during install.
27
28 %description -l pl
29 CMFQuickInstallerTool jest dodatkiem do Zope niezale¿nym od
30 poprzedniego CMFQuickInstallera. G³ówna ró¿nica w stosunku do
31 CMFQuickInstallera to mo¿liwo¶æ ¶ledzenia, co tworzy dany produkt w
32 czasie instalacji.
33
34 %prep
35 %setup -q -n %{zope_subname}
36
37 rm -rf {forms,interfaces}/CVS
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
42
43 cp -af {forms,interfaces,*.py,*.gif} $RPM_BUILD_ROOT%{_datadir}/%{name}
44
45 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
46 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
47
48 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
55 if [ -f /var/lock/subsys/zope ]; then
56         /etc/rc.d/init.d/zope restart >&2
57 fi
58
59 %postun
60 if [ "$1" = "0" ]; then
61         /usr/sbin/installzopeproduct -d %{zope_subname}
62         if [ -f /var/lock/subsys/zope ]; then
63                 /etc/rc.d/init.d/zope restart >&2
64         fi
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc AUTHORS README.txt
70 %{_datadir}/%{name}
This page took 0.076575 seconds and 4 git commands to generate.