]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- fixed doubled products (PTS, ExternalEditor)
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1
2 %define         zope_subname    CMFPlone
3 Summary:        Free and open source Content Management System based on Zope and CMF
4 Summary(pl):    Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
5 Name:           Zope-%{zope_subname}
6 Version:        2.0.5
7 # %%define              sub_ver RC6
8 Release:        6
9 License:        Zope Public License (ZPL), GPL
10 Group:          Networking/Daemons
11 Source0:        http://dl.sourceforge.net/plone/Plone-%{version}.tar.gz
12 # Source0-md5:  fe8ce932877c53bb22b1f88d2b4c9211
13 URL:            http://www.plone.org/
14 BuildRequires:  python
15 %pyrequires_eq  python-modules
16 Requires:       i18ndude
17 Requires:       Zope-archetypes >= 1.2.5
18 Requires:       Zope-CMF = 1:1.4.7
19 Requires:       Zope >= 2.6.2
20 Requires:       Zope-BTreeFolder2
21 Requires:       Zope-CMFQuickInstallerTool >= 1.5.1
22 Requires:       Zope-Epoz >= 0.8.2
23 Requires:       Zope-ExternalEditor
24 Requires:       Zope-Formulator >= 1.6.2
25 Requires:       Zope-GroupUserFolder >= 2.0.1
26 Requires:       Zope-PlacelessTranslationService
27 Requires(post,postun):  /usr/sbin/installzopeproduct
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30 Obsoletes:      Plone
31 Obsoletes:      Zope-PortalTransforms
32 #Conflicts:     Zope-CMF = 1.5.0
33 Conflicts:      CMF
34
35 %description
36 Plone is a free, open source Content Management System. The focus of
37 Plone is to provide value at every level of an organization. It comes
38 with a workflow engine, pre-configured security and roles, a set of
39 content types and multi-lingual support. There are many developers,
40 writers and testers from all over the world, contributing to Plone
41 everyday. Plone is based on the Content Management Framework.
42
43 %description -l pl
44 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
45 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
46 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
47 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
48 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
49 Pythonem.
50
51 %prep
52 %setup -q -n Plone-%{version}
53 # remove dirs - additional packages!
54 # ExternalEditor
55 rm -rf {BTreeFolder2,CMFQuickInstallerTool,Formulator,GroupUserFolder,Archetypes,generator,validation}
56 rm -rf {CMFCalendar,CMFCore,CMFDefault,CMFTopic,DCWorkflow,PortalTransforms,Epoz}
57 rm -rf {ExternalEditor,PlacelessTranslationService}
58 find . -type d -name debian | xargs rm -rf
59
60 %build
61 mkdir docs docs/CMFPlone docs/CMFFormController docs/PloneErrorReporting
62 mv -f CMFPlone/{CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,UPGRADE.txt,LICENSE.txt} docs/CMFPlone
63 # mv -f CMFPlone/docs/* docs/CMFPlone
64 rm -rf CMFPlone/LICENSE.GPL
65 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
66 rm -rf CMFPlone/docs
67 mv -f PloneErrorReporting/{ChangeLog,README.txt} docs/PloneErrorReporting
68 rm -rf PloneErrorReporting/LICENSE.txt
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
73 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
74
75 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
76 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
77
78 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post
84 for p in CMFPlone CMFActionIcons CMFFormController PloneErrorReporting; do
85         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
86 done
87 if [ -f /var/lock/subsys/zope ]; then
88         /etc/rc.d/init.d/zope restart >&2
89 fi
90
91 %postun
92 if [ "$1" = "0" ]; then
93         for p in CMFPlone CMFActionIcons CMFFormController PloneErrorReporting; do
94                 /usr/sbin/installzopeproduct -d $p
95         done
96         if [ -f /var/lock/subsys/zope ]; then
97                 /etc/rc.d/init.d/zope restart >&2
98         fi
99 fi
100
101 %files
102 %defattr(644,root,root,755)
103 %doc docs/*
104 %{_datadir}/%{name}
This page took 0.068254 seconds and 3 git commands to generate.