]> git.pld-linux.org Git - packages/Yap.git/blob - Yap.spec
- update ac patch
[packages/Yap.git] / Yap.spec
1 Summary:        Prolog Compiler
2 Summary(pl):    Kompilator Prologu
3 Name:           Yap
4 Version:        4.5.4
5 Release:        1
6 License:        Artistic
7 Group:          Development/Languages
8 Source0:        http://dl.sourceforge.net/yap/%{name}-%{version}.tar.gz
9 # Source0-md5:  a31c469361e2e7893d04338444e52802
10 Patch0:         %{name}-acdirs.patch
11 URL:            http://www.ncc.up.pt/~vsc/Yap/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  readline-devel
15 BuildRequires:  indent
16 BuildRequires:  gmp-devel
17 ExcludeArch:    alpha
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 A high-performance Prolog compiler developed at LIACC, Universidade do
22 Porto. The Prolog engine is based in the WAM (Warren Abstract
23 Machine), with several optimizations for better performance. YAP
24 follows the Edinburgh tradition, and is largely compatible with the
25 ISO-Prolog standard and with Quintus and SICStus Prolog.
26
27 %description -l pl
28 Wydajny kompilator Prologu stworzony w LIACC, Universidade do
29 Porto. Silnik Prologu bazuje na WAM (Warren Abstract Machine), z
30 ró¿nymi optymalizacjami dla lepszej wydajno¶ci. Zgodnie z tradycj±
31 Edinburgh jest on wysoce kompatybilny ze standardem ISO-Prolog oraz
32 z Prologiem Quintus i SICStus.
33
34 %package static
35 Summary:        Static library for YAP Prolog
36 Summary(pl):    Statyczna biblioteka dla kompilatora Prologu YAP
37 Group:          Development/Languages
38 Requires:       %{name} = %{version}
39
40 %description static
41 Static library for YAP prolog.
42
43 %description static -l pl
44 Statyczna biblioteka dla kompilatora prologu YAP.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51 cp -f /usr/share/automake/config.sub .
52 %{__aclocal}
53 %{__autoconf}
54 %configure \
55         --enable-coroutining \
56         --enable-depth-limit \
57         --enable-low-level-tracer \
58         --enable-depth-limit
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{_infodir},%{_examplesdir}/%{name}-%{version},%{_libdir}/%{name}}
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 install docs/*info* $RPM_BUILD_ROOT%{_infodir}
70
71 for d in chr clpqr; do
72         mv -f $RPM_BUILD_ROOT%{_datadir}/Yap/$d/examples \
73                 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$d
74 done
75
76 %post
77 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
78 /sbin/ldconfig
79
80 %postun
81 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
82 /sbin/ldconfig
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc README* INSTALL changes4.3.html docs/yap.tex
90 %attr(755,root,root) %{_bindir}/yap
91 %dir %{_libdir}/%{name}
92 %attr(755,root,root) %{_libdir}/%{name}/*.so
93 %attr(755,root,root) %{_libdir}/%{name}/startup
94 %{_datadir}/%{name}
95 %{_includedir}/%{name}
96 %{_infodir}/*info*
97 %{_examplesdir}/%{name}-%{version}
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libYap.a
This page took 0.43276 seconds and 4 git commands to generate.