]> git.pld-linux.org Git - packages/XFree86-glx.git/blob - XFree86-glx.spec
- spaces->tabs
[packages/XFree86-glx.git] / XFree86-glx.spec
1 %define mesaversion     3.2.1
2 %define glx_ver latest
3
4 Summary:        OpenGL 1.2 compatible 3D graphics library
5 Summary(pl):    Biblioteka grafiki 3D kompatybilna z OpenGL 1.2
6 Name:           XFree86-glx
7 Version:        4.2.0
8 Release:        0.2
9 License:        LGPL
10 Vendor:         Brian Paul <brian_paul@mesa3d.org>
11 Group:          X11/Libraries
12 Source0:        http://dl.sourceforge.net/mesa3d/MesaLib-%{mesaversion}.tar.bz2
13 # Source0-md5:  dcd5a6aa77b3bdb400c8179419473e58
14 Source1:        http://dl.sourceforge.net/mesa3d/MesaDemos-%{mesaversion}.tar.bz2
15 # Source1-md5:  621bd95ed9f93467f4dfa615e2f27c16
16 Source2:        http://snow.ashlu.bc.ca/glx/snapshots/utah-glx-src-%{glx_ver}.tar.gz
17 # Source2-md5:  654ae59e0603d71c18a88737e9f954c6
18 URL:            http://www.mesa3d.org/
19 BuildRequires:  tcl
20 Provides:       OpenGL
21 Conflicts:      XFree86 =< 4.1.0
22 Obsoletes:      Mesa
23 Obsoletes:      XFree86-OpenGL-core
24 Obsoletes:      XFree86-OpenGL-libs
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/X11R6
28 %define         _sysconfdir     /etc/X11
29
30 %description
31 This is an implementation of the Mesa 3D library and GLX with support
32 for hardware acceleration. GLX was developed by SGI as an extension to
33 the X window system to integrate OpenGL rendering functions. This
34 allows the Mesa 3D library to perform its 3D rendering functions
35 within the X server's process, rather than within the X client
36 program. This offers potential performance benefits, because the
37 rendered image does not have to be moved from the X client program to
38 the X server. (Only the commands required to render the image are
39 sent.) It also makes 3-D hardware acceleration much more practical
40 (and fast). This package includes a accelerated hardware drivers for
41 video card based on NVIDIA Riva series and ATI Rage Pro chipsets.
42
43 The Mesa 3D graphics library is a powerful and generic toolset for
44 creating hardware assisted computer graphics. To the extent that Mesa
45 utilizes the OpenGL command syntax or state machine, it is being used
46 with authorization from Silicon Graphics, Inc. However, the author
47 (Brian Paul) makes no claim that Mesa is in any way a compatible
48 replacement for OpenGL or associated with Silicon Graphics, Inc. Those
49 who want a licensed implementation of OpenGL should contact a licensed
50 vendor. However, Mesa is very similar to OpenGL, and you might find
51 Mesa to be a valid alternative to OpenGL.
52
53 This package is based on Mesa %{mesaver} and utah-glx-%{glxver}.
54
55 please see http://utah-glx.sourceforge.net/ for more information.
56
57 %description -l pl
58 To jest implementacja biblioteki Mesa 3D oraz GLX z obs³ug± sprzêtowej
59 akceleracji. GLX zosta³ stworzony przez SGI jako rozszerzenie systemu
60 X Window w celu integracji funkcji renderuj±cych OpenGL. Pozwala to
61 bibliotece Mesa 3D na wykonywanie funkcji renderujacych 3D wewn±trz
62 procesu X serwera zamiast po stronie X klienta. Daje to potencjalne
63 zyski wydajno¶ci, poniewa¿ wyrenderowany obraz nie musi byæ przesy³any
64 z programu X klienta do X serwera (przesy³ane s± tylko polecenia
65 potrzebne do renderowania). Daje to tak¿e mo¿liwo¶æ u¿ycia sprzêtowej
66 akceleracji 3D. Ten pakiet zawiera sterowniki wykorzystuj±ce
67 akceleracjê dla kart graficznych opartych na uk³adach z serii NVIDIA
68 Riva i ATI Rage Pro.
69
70 Biblioteka graficzna Mesa 3D jest potê¿nym i ogólnym zestawem narzêdzi
71 do tworzenia grafiki komputerowej przy wsparciu sprzêtu. Mesa u¿ywa
72 sk³adni poleceñ i maszyny stanów OpenGL za zgod± Silicon Graphics,
73 Inc. Nie jest to jednak licencjonowana implementacja OpenGL.
74
75 Ten pakiet bazuje na Mesie %{mesaver} oraz utah-glx-%{glxver}.
76
77 Wiêcej informacji na stronie http://utah-glx.sourceforge.net/.
78
79 %package devel
80 Summary:        Development files for Mesa (OpenGL compatible 3D lib)
81 Summary(pl):    Pliki nag³ówkowe dla Mesy (biblioteki 3D zgodnej z OpenGL)
82 Group:          X11/Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 Provides:       OpenGL-devel
85 Obsoletes:      Mesa-devel
86 Obsoletes:      XFree86-OpenGL-devel
87
88 %description devel
89 Mesa is an OpenGL 1.2 compatible 3D graphics library. This package
90 contains the header files needed to compile Mesa programs.
91
92 %description devel -l pl
93 Mesa jest bibliotek± 3D zgodn± z OpenGL 1.2. Ten pakiet zawiera pliki
94 nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych Mesy.
95
96 %prep
97 %setup -q -n Mesa-%{mesaversion} -b1 -a2
98 [ -d glx-xf4 ] && ln -s glx-xf4 glx;
99
100 perl -pi -e "s/-O3/%{rpmcflags}/" Make-config
101
102 %build
103 RPM_OPT_FLAGS="%{rpmcflags}"; export RPM_OPT_FLAGS
104 %ifarch i386 i486
105 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" \
106 ./configure \
107         --prefix=%{_prefix} \
108         --sysconfdir=%{_sysconfdir} \
109         --disable-mmx \
110         --disable-3dnow \
111         --without-ggi \
112         --enable-mga=no \
113         --enable-mach64=no \
114         --enable-tnt=yes \
115         --enable-i810=no \
116         --enable-s3virge=no \
117         --enable-s3savage=no \
118         --enable-sis6326=no
119
120 %endif
121 %ifarch i586 i686 k6 athlon
122 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" \
123 ./configure \
124         --prefix=%{_prefix} \
125         --sysconfdir=%{_sysconfdir} \
126         --with-glide=/usr \
127         --without-ggi \
128         --enable-mga=no \
129         --enable-mach64=no \
130         --enable-tnt=yes \
131         --enable-i810=no \
132         --enable-s3virge=no \
133         --enable-s3savage=no \
134         --enable-sis6326=no
135 %endif
136 %ifnarch %{ix86}
137 ./configure \
138         --prefix=%{_prefix} \
139         --sysconfdir=%{_sysconfdir} \
140         --disable-3dnow \
141         --without-ggi \
142         --enable-mga=no \
143         --enable-mach64=no \
144         --enable-tnt=yes \
145         --enable-i810=no \
146         --enable-s3virge=no \
147         --enable-s3savage=no \
148         --enable-sis6326=no
149 %endif
150
151 %{__make}
152
153 %ifarch alpha sparc sparc64 ppc # Skip utah_glx for alpha - (fg) also skip it for
154                                 # sparc - (jb) also added skip for ppc
155         echo 'utah_glx skipped for alpha, powerpc and sparcs'
156 %else
157 cd glx
158 cp -fv ../config.sub .
159
160 CFLAGS="%{rpmcflags}" \
161 ./autogen.sh \
162         --with-chipset=both \
163         --with-mesa=../ \
164         --enable-extra \
165         --disable-mtrr \
166         --disable-agp \
167         --disable-glut \
168         --disable-GLU \
169         --prefix=%{_prefix} \
170         --sysconfdir=%{_sysconfdir} \
171         --without-x86-asm \
172         --without-mmx-asm \
173         --without-3dnow-asm \
174         --enable-mga=no \
175         --enable-mach64=no \
176         --enable-tnt=yes \
177         --enable-i810=no \
178         --enable-s3virge=no \
179         --enable-s3savage=no \
180         --enable-sis6326=no
181
182 # Arg docs sux ((Dadou) "are not OK", it's better ;)
183 cd docs
184 cat <<EOF > config.cache
185 ac_cv_path_install=${ac_cv_path_install='/usr/bin/install -c'}
186 ac_cv_prog_CP=${ac_cv_prog_CP='cp -f'}
187 ac_cv_prog_LN_S=${ac_cv_prog_LN_S='ln -s'}
188 ac_cv_prog_MKDIR=${ac_cv_prog_MKDIR='mkdir -p'}
189 ac_cv_prog_MV=${ac_cv_prog_MV='mv -f'}
190 ac_cv_prog_RM=${ac_cv_prog_RM='rm -f'}
191 ac_cv_prog_have_dvips=${ac_cv_prog_have_dvips=no}
192 ac_cv_prog_have_jade=${ac_cv_prog_have_jade=no}
193 ac_cv_prog_have_jadetex=${ac_cv_prog_have_jadetex=no}
194 ac_cv_prog_have_lynx=${ac_cv_prog_have_lynx=no}
195 ac_cv_prog_have_ps2pdf=${ac_cv_prog_have_ps2pdf=no}
196 ac_cv_prog_make_make_set=${ac_cv_prog_make_make_set=yes}
197 EOF
198
199 ./configure \
200         --enable-text \
201         --enable-html \
202         --enable-ps \
203         --enable-pdf
204 cd ..
205
206 %{__make}
207 cd ..
208 %endif # Skip glx for Alpha
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212 install -d $RPM_BUILD_ROOT{%{_includedir}/GL,%{_sysconfdir},/usr/bin} \
213         $RPM_BUILD_ROOT%{_libdir}/modules
214
215 %{__make} install \
216         DESTDIR=$RPM_BUILD_ROOT
217
218 install include/GL/svgamesa.h $RPM_BUILD_ROOT%{_includedir}/GL
219 install glx/servGL/libglx.so $RPM_BUILD_ROOT%{_libdir}/modules
220
221 %ifarch alpha sparc sparc64 ppc
222 echo 'Skipping utah_glx'
223 %else
224 cat > $RPM_BUILD_ROOT/usr/bin/glx <<EOF
225 #!/bin/sh
226 LD_PRELOAD=%{_libdir}/libGL.so.1.0 "\$@"
227 EOF
228
229 ## glx
230 cd glx
231 %{__make} install \
232         DESTDIR=$RPM_BUILD_ROOT \
233         sysconfdir=%{_sysconfdir}
234 cd ..
235 %endif # glx
236
237 cd $RPM_BUILD_ROOT%{_libdir}
238 ln -sf libGL.so.1 libGL.so
239 ln -sf libGLU.so.1 libGLU.so
240 ln -sf libGLU.so.1 libGLU.so.3
241 ln -sf libglut.so.3 libglut.so
242
243 # (gc) add Mesa symlinks for compatibility
244 ln -sf libGL.so libMesaGL.so
245 ln -sf libGL.so.1 libMesaGL.so.1
246 ln -sf libGL.so.1.0 libMesaGL.so.1.0
247 ln -sf libGLU.so libMesaGLU.so
248 ln -sf libGLU.so.1 libMesaGLU.so.1
249
250 %clean
251 rm -rf $RPM_BUILD_ROOT
252
253 %post   -p /sbin/ldconfig
254 %postun -p /sbin/ldconfig
255
256 %files
257 %defattr(644,root,root,755)
258 %doc docs/{COPYRIGHT,README*,DEVINFO,CONFORM,VERSIONS} glx/docs/README.*
259 %attr(755,root,root) /usr/bin/glx
260 %{_libdir}/*.so.*
261 %config %{_sysconfdir}/mesa.conf
262 %ifarch %{ix86}
263 %{_libdir}/modules/extensions/*.so
264 %config %{_sysconfdir}/glx.conf
265 %endif
266
267 %files devel
268 %defattr(644,root,root,755)
269 %attr(755,root,root) %{_libdir}/lib*.so
270 %{_libdir}/lib*.la
271 %dir %{_includedir}/GL
272 %{_includedir}/GL/gl*.h
273 %{_includedir}/GL/o*.h
274 %{_includedir}/GL/x*.h
275 %ifarch %{ix86}
276 %{_includedir}/GL/svgamesa.h
277 %endif
This page took 0.134962 seconds and 3 git commands to generate.