]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
b02547ee6928e84138a87092e7f585b675ff75c1
[packages/QtCurve.git] / QtCurve.spec
1 #
2 # ToDo:
3 #  - include /usr/share/themes/QtCurve/mozilla somewhere
4 #
5 # Conditional build:
6 %bcond_with     gtk     # build GTK styles
7 %bcond_without  gtk2    # don't build GTK+2 styles
8 #
9 %define         kde_ver         0.45.2
10 %define         gtk2_ver        0.45.3
11 %define         gtk1_ver        0.42.2
12 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
13 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
14 Name:           QtCurve
15 Version:        0.45
16 Release:        1
17 License:        GPL
18 Group:          Themes
19 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.gz
20 # Source0-md5:  be84b6d28bf88510952f1cf866647162
21 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.gz
22 # Source1-md5:  877c3a85c358689bd30af78951710d83
23 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
24 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
25 Patch0:         %{name}-amd64.patch
26 URL:            http://www.kde-look.org/content/show.php?content=40492
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 %{?with_gtk:BuildRequires:      gtk+-devel}
30 %{?with_gtk2:BuildRequires:     gtk+2-devel}
31 BuildRequires:  kdelibs-devel >= 3.1
32 BuildRequires:  libtool
33 BuildRequires:  pkgconfig
34 BuildRequires:  sed > 4.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A free and corrected port of Red Hat's GTK+/Qt theme.
39
40 %description -l pl
41 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
42
43 %package -n kde-style-QtCurve
44 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
45 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
46 Group:          Themes
47 Requires:       kdelibs >= 3.1
48
49 %description -n kde-style-QtCurve
50 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
51
52 %description -n kde-style-QtCurve -l pl
53 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
54 Wersja pod KDE.
55
56 %package -n gtk-theme-QtCurve
57 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
58 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
59 Group:          Themes
60 Requires:       theme-QtCurve-common = %{version}-%{release}
61
62 %description -n gtk-theme-QtCurve
63 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
64
65 %description -n gtk-theme-QtCurve -l pl
66 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
67 Wersja pod GTK+.
68
69 %package -n gtk2-theme-QtCurve
70 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
71 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
72 Group:          Themes
73 Requires:       theme-QtCurve-common = %{version}-%{release}
74
75 %description -n gtk2-theme-QtCurve
76 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
77
78 %description -n gtk2-theme-QtCurve -l pl
79 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
80 Wersja pod GTK+2.
81
82 %package -n theme-QtCurve-common
83 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
84 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
85 Group:          Themes
86 Obsoletes:      theme-bluecurve-common
87 Obsoletes:      gtk2-theme-bluecurve
88 Obsoletes:      gtk-theme-bluecurve
89 Obsoletes:      kde-style-bluecurve
90 Obsoletes:      kde-theme-bluecurve
91
92 %description -n theme-QtCurve-common
93 A free and corrected port of Red Hat's GTK+/Qt theme.
94 Documentation and common files package.
95
96 %description -n theme-QtCurve-common -l pl
97 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
98 Pakiet z dokumentacja i plikami wspó³dzielonymi.
99
100 %prep
101 %setup -q -c -a1 -a2
102 %patch0 -p1
103
104 %build
105 cd %{name}-KDE3-%{kde_ver}
106 cp /usr/share/automake/config.sub admin
107
108 %{__make} -f admin/Makefile.common cvs
109 %configure \
110         --with-qt-libraries=%{_libdir}
111
112 %{__make}
113 cd -
114
115 %if %{with gtk}
116 cd %{name}-Gtk1-%{gtk1_ver}
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 %configure
123 %{__make}
124 cd -
125 %endif
126
127 %if %{with gtk2}
128 cd %{name}-Gtk2-%{gtk2_ver}
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure
135 %{__make}
136 cd -
137 %endif
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} -C %{name}-KDE3-%{kde_ver} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %if %{with gtk}
146 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
147         DESTDIR=$RPM_BUILD_ROOT
148 %endif
149
150 %if %{with gtk2}
151 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
152         DESTDIR=$RPM_BUILD_ROOT
153 %endif
154
155 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %files -n kde-style-QtCurve
161 %defattr(644,root,root,755)
162 %{_libdir}/kde3/kstyle_qtcurve_config.la
163 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
164 %{_libdir}/kde3/plugins/styles/*.la
165 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
166 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
167 %{_datadir}/apps/qtcurve
168
169 %if %{with gtk}
170 %files -n gtk-theme-QtCurve
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
173 %{_datadir}/themes/QtCurve/gtk
174 %endif
175
176 %if %{with gtk2}
177 %files -n gtk2-theme-QtCurve
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
180 %{_datadir}/themes/QtCurve/gtk-2.0
181 %endif
182
183 %files -n theme-QtCurve-common
184 %defattr(644,root,root,755)
185 %doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
186 %dir %{_datadir}/themes/QtCurve
This page took 0.557108 seconds and 2 git commands to generate.