]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
745b0c481fd384d9860d150879f3c211ee2d1cb6
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA support
4 %bcond_with     arts    # with aRts support
5 %bcond_without  doc     # don't build HTML documentation (from SGML source)
6 %bcond_without  esd     # without esd support
7 %bcond_with     mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
8                         # Currently broken.
9 #
10 # TODO:
11 # - remove zip BR?
12 #
13
14 %define _branch Linux_Spec1-0
15
16 Summary:        Open Audio Library
17 Summary(pl):    Otwarta Biblioteka D¼wiêku
18 Name:           OpenAL
19 Version:        0.0.8
20 %define snap    20051015
21 Release:        0.%{snap}.1
22 License:        LGPL
23 Group:          Libraries
24 # from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
25 # (without all Win and Mac stuff and demos)
26 Source0:        %{name}-%{_branch}-%{snap}.tar.bz2
27 # Source0-md5:  013a571cf588bec1d3a5628b5ed527ea
28 Patch0:         %{name}-prefix.patch
29 Patch1:         %{name}-info.patch
30 URL:            http://www.openal.org/
31 BuildRequires:  SDL-devel
32 %{?with_alsa:BuildRequires:     alsa-lib-devel}
33 %{?with_arts:BuildRequires:     artsc-devel}
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 %{?with_doc:BuildRequires:      docbook-utils}
37 %{?with_esd:BuildRequires:      esound-devel}
38 %{?with_doc:BuildRequires:      gnome-doc-tools}
39 BuildRequires:  libvorbis-devel
40 %{?with_mmx:BuildRequires:      nasm}
41 BuildRequires:  smpeg-devel
42 BuildRequires:  texinfo
43 BuildRequires:  zip
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 OpenAL, the Open Audio Library, is a joint effort to create an open,
48 vendor-neutral, cross-platform API for interactive, primarily
49 spatialized audio. OpenAL's primary audience are application
50 developers and desktop users that rely on portable standards like
51 OpenGL, for games and other multimedia applications. OpenAL is already
52 supported by a number of hardware vendors and developers.
53
54 %description -l pl
55 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
56 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
57 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
58 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
59 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
60 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
61 dostarczycieli sprzêtu i programistów.
62
63 %package devel
64 Summary:        Headers for OpenAL
65 Summary(pl):    Pliki nag³ówkowe do OpenAL
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description devel
70 Header files for OpenAL-based programs.
71
72 %description devel -l pl
73 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
74 OpenAL.
75
76 %package static
77 Summary:        OpenAL static library
78 Summary(pl):    Statyczna biblioteka OpenAL
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 OpenAL static library.
84
85 %description static -l pl
86 Biblioteka OpenAL do konsolidacji statycznej.
87
88 %prep
89 %setup -q -n %{name}-%{_branch}-%{snap}
90 %patch0 -p1
91 %patch1 -p1
92
93 cp CREDITS docs
94
95 %build
96 cd linux
97 cp -f /usr/share/automake/config.sub .
98 %{__aclocal}
99 %{__autoconf}
100 %{__autoheader}
101 %configure \
102         %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
103         %{?with_arts:--enable-arts --enable-arts-dlopen} \
104         %{?with_esd:--enable-esd --enable-esd-dlopen} \
105         --enable-sdl \
106         --enable-vorbis \
107         --enable-smpeg \
108         --enable-capture \
109         --with-gcc=%{__cc}
110
111 %{__make}
112
113 cd ../docs/spec1-0
114 %{?with_doc:%{__make} full-html}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT%{_infodir}
119
120 %{__make} -C linux install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %post devel
132 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
133
134 %postun devel
135 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
136
137 %files
138 %defattr(644,root,root,755)
139 %doc linux/{CREDITS,ChangeLog,NOTES,TODO}
140 %attr(755,root,root) %{_libdir}/lib*.so.*.*
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc linux/doc/LOKI* %{?with_doc:docs/spec1-0/oalspecs-full docs/spec1-1/OpenAL1-1Spec.pdf}
145 %attr(755,root,root) %{_libdir}/lib*.so
146 %attr(755,root,root) %{_bindir}/*-config
147 %{_pkgconfigdir}/*
148 %{_includedir}/AL
149 %{_infodir}/openal.info*
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/*.a
This page took 0.072022 seconds and 2 git commands to generate.