]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- outdated
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 # _without_alsa         - without ALSA support
4 # _without_doc          - don't build HTML documentation (from SGML source)
5 # _without_esd          - without esd support
6 # _with_mmx             - use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
7 #
8 # TODO:
9 # - remove zip BR?
10 #
11 %ifarch athlon
12 %define         _with_mmx       1
13 %endif
14
15 Summary:        Open Audio Library
16 Summary(pl):    Otwarta Biblioteka D¼wiêku
17 Name:           OpenAL
18 Version:        0.0.6
19 %define snap    20040416
20 Release:        1.%{snap}.1
21 License:        LGPL
22 Group:          Libraries
23 # from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
24 # (without all Win and Mac stuff and demos)
25 Source0:        %{name}-linuxonly-%{snap}.tar.bz2
26 # Source0-md5:  4f42f20484858452bfc30caa8976415d
27 Patch0:         %{name}-prefix.patch
28 Patch1:         %{name}-info.patch
29 URL:            http://www.openal.org/
30 BuildRequires:  SDL-devel
31 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 %{!?_without_doc:BuildRequires: docbook-utils}
35 %{!?_without_esd:BuildRequires: esound-devel}
36 %{!?_without_doc:BuildRequires: gnome-doc-tools}
37 BuildRequires:  libvorbis-devel
38 %{?_with_mmx:BuildRequires:     nasm}
39 BuildRequires:  smpeg-devel
40 BuildRequires:  texinfo
41 BuildRequires:  zip
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 OpenAL, the Open Audio Library, is a joint effort to create an open,
46 vendor-neutral, cross-platform API for interactive, primarily
47 spatialized audio. OpenAL's primary audience are application
48 developers and desktop users that rely on portable standards like
49 OpenGL, for games and other multimedia applications. OpenAL is already
50 supported by a number of hardware vendors and developers.
51
52 %description -l pl
53 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
54 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
55 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
56 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
57 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
58 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
59 dostarczycieli sprzêtu i programistów.
60
61 %package devel
62 Summary:        Headers for OpenAL
63 Summary(pl):    Pliki nag³ówkowe do OpenAL
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}
66
67 %description devel
68 Header files for OpenAL-based programs.
69
70 %description devel -l pl
71 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
72 OpenAL.
73
74 %package static
75 Summary:        OpenAL static library
76 Summary(pl):    Statyczna biblioteka OpenAL
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}
79
80 %description static
81 OpenAL static library.
82
83 %description static -l pl
84 Biblioteka OpenAL do konsolidacji statycznej.
85
86 %prep
87 %setup -q -n openal
88 %patch0 -p1
89 %patch1 -p1
90
91 echo 'AC_DEFUN([AC_HAS_MMX],[$%{?_with_mmx:1}%{!?_with_mmx:2}])' >> linux/acinclude.m4
92
93 %build
94 cd linux
95 cp /usr/share/automake/config.sub .
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %configure \
100         %{!?debug:--enable-optimization} \
101         %{?_with_mmx:--enable-arch-asm} \
102         %{!?_without_alsa:--enable-alsa} \
103         %{!?_without_esd:--enable-esd} \
104         --enable-sdl \
105         --enable-vorbis \
106         --enable-smpeg \
107         --enable-capture \
108         --with-gcc=%{__cc}
109
110 %{__make}
111
112 cd ../docs
113 %{!?_without_doc:%{__make} full-html}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_infodir}
118
119 cd linux
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install doc/openal.info $RPM_BUILD_ROOT%{_infodir}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %post devel
132 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
133
134 %postun devel
135 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
136
137 %files
138 %defattr(644,root,root,755)
139 %doc linux/{CREDITS,ChangeLog,NOTES,TODO}
140 %attr(755,root,root) %{_libdir}/lib*.so.*.*
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc linux/doc/LOKI* %{!?_without_doc:docs/oalspecs-full}
145 %attr(755,root,root) %{_libdir}/lib*.so
146 %{_includedir}/AL
147 %{_infodir}/openal.info*
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/*.a
This page took 0.102669 seconds and 3 git commands to generate.