]> git.pld-linux.org Git - packages/NetworkManager.git/commitdiff
- up to next stable 0.9.6.0; updated pld patch auto/th/NetworkManager-0.9.6.0-1
authorBartlomiej Zimon <uzi18@o2.pl>
Thu, 23 Aug 2012 20:28:57 +0000 (22:28 +0200)
committerBartlomiej Zimon <uzi18@o2.pl>
Thu, 23 Aug 2012 20:28:57 +0000 (22:28 +0200)
Signed-off-by: Bartlomiej Zimon <uzi18@o2.pl>
NetworkManager-nmcli.patch [deleted file]
NetworkManager-pld.patch
NetworkManager.spec

diff --git a/NetworkManager-nmcli.patch b/NetworkManager-nmcli.patch
deleted file mode 100644 (file)
index 40153f4..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-From 8a2267ab6b37948a70c10f0af781be4822a54c6b Mon Sep 17 00:00:00 2001
-From: Dan Winship <danw@gnome.org>
-Date: Thu, 05 Apr 2012 17:30:09 +0000
-Subject: Fix a few misc issues noticed by Coverity
-
----
-diff --git a/cli/src/settings.c b/cli/src/settings.c
-index bf42292..3e17891 100644
---- a/cli/src/settings.c
-+++ b/cli/src/settings.c
-@@ -607,10 +607,11 @@ vlan_priorities_to_string (NMSettingVlan *s_vlan, NMVlanPriorityMap map)
-       for (i = 0; i < nm_setting_vlan_get_num_priorities (s_vlan, map); i++) {
-               guint32 from, to;
--              nm_setting_vlan_get_priority (s_vlan, map, i, &from, &to);
--              g_string_append_printf (priorities, "%d:%d,", from, to);
-+              if (nm_setting_vlan_get_priority (s_vlan, map, i, &from, &to))
-+                      g_string_append_printf (priorities, "%d:%d,", from, to);
-       }
--      g_string_truncate (priorities, priorities->len-1);  /* chop off trailing ',' */
-+      if (priorities->len)
-+              g_string_truncate (priorities, priorities->len-1);  /* chop off trailing ',' */
-       return g_string_free (priorities, FALSE);
- }
-diff --git a/libnm-util/nm-setting-vlan.c b/libnm-util/nm-setting-vlan.c
-index 71760dc..f87ad92 100644
---- a/libnm-util/nm-setting-vlan.c
-+++ b/libnm-util/nm-setting-vlan.c
-@@ -460,7 +460,7 @@ verify (NMSetting *setting, GSList *all_settings, GError **error)
-               return FALSE;
-       }
--      if (priv->flags & !(NM_VLAN_FLAG_REORDER_HEADERS |
-+      if (priv->flags & ~(NM_VLAN_FLAG_REORDER_HEADERS |
-                           NM_VLAN_FLAG_GVRP |
-                           NM_VLAN_FLAG_LOOSE_BINDING)) {
-               g_set_error (error,
-diff --git a/src/nm-device-vlan.c b/src/nm-device-vlan.c
-index 14be849..b9c9323 100644
---- a/src/nm-device-vlan.c
-+++ b/src/nm-device-vlan.c
-@@ -643,17 +643,17 @@ nm_device_vlan_new (const char *udi, const char *iface, NMDevice *parent)
-                       g_object_unref (device);
-                       return NULL;
-               }
--              priv->vlan_id = vlan_id;
-               if (   parent_ifindex < 0
-                   || parent_ifindex != nm_device_get_ip_ifindex (parent)
--                  || priv->vlan_id < 0) {
-+                  || vlan_id < 0) {
-                       nm_log_warn (LOGD_DEVICE, "(%s): VLAN parent ifindex (%d) or VLAN ID (%d) invalid.",
-                                    iface, parent_ifindex, priv->vlan_id);
-                       g_object_unref (device);
-                       return NULL;
-               }
-+              priv->vlan_id = vlan_id;
-               priv->parent = g_object_ref (parent);
-               priv->parent_state_id = g_signal_connect (priv->parent,
-                                                         "state-changed",
---
-cgit v0.9.0.2-2-gbebe
index 018cf0b0a0d4e7bb03eeb9d501e9701fb6090532..752ae9f464c8ede988f8248e683874a59dfd1e52 100644 (file)
@@ -1,29 +1,24 @@
 diff -urN NetworkManager-0.9.4.0/configure.ac NetworkManager-0.9.4.0.new/configure.ac
 --- NetworkManager-0.9.4.0/configure.ac        2012-03-23 21:11:15.000000000 +0100
 +++ NetworkManager-0.9.4.0.new/configure.ac    2012-03-24 11:29:26.057723008 +0100
-@@ -107,7 +107,7 @@
+@@ -107,9 +107,10 @@
  dnl
  AC_C_BIGENDIAN
  
--AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, suse, gentoo, debian, arch, slackware, paldo, mandriva, pardus, linexa or exherbo]))
-+AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, suse, gentoo, debian, arch, slackware, paldo, mandriva, pardus, linexa, exherbo or pld]))
+-AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, suse, gentoo, debian, arch, slackware, paldo, mandriva, pardus, linexa, exherbo or lfs]))
++AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, suse, gentoo, debian, arch, slackware, paldo, mandriva, pardus, linexa, exherbo, lfs or pld]))
  if test "z$with_distro" = "z"; then
        AC_CHECK_FILE(/etc/redhat-release,with_distro="redhat")
-       AC_CHECK_FILE(/etc/SuSE-release,with_distro="suse")
-@@ -121,6 +121,7 @@
-       AC_CHECK_FILE(/etc/pardus-release,with_distro="pardus")
-       AC_CHECK_FILE(/etc/linexa-release,with_distro="linexa")
-       AC_CHECK_FILE(/etc/exherbo-release,with_distro="exherbo")
 +      AC_CHECK_FILE(/etc/pld-release,with_distro="pld")
-       if test "z$with_distro" = "z"; then
-               with_distro=`lsb_release -is`
-       fi
-@@ -132,7 +133,7 @@
+       AC_CHECK_FILE(/etc/SuSE-release,with_distro="suse")
+       AC_CHECK_FILE(/etc/fedora-release,with_distro="redhat")
+       AC_CHECK_FILE(/etc/gentoo-release,with_distro="gentoo")
+@@ -133,7 +134,7 @@
        exit 1
  else
        case $with_distro in
--              redhat|suse|gentoo|debian|slackware|arch|paldo|frugalware|mandriva|pardus|linexa|exherbo|generic) ;;
-+              redhat|suse|gentoo|debian|slackware|arch|paldo|frugalware|mandriva|pardus|linexa|exherbo|generic|pld) ;;
+-              redhat|suse|gentoo|debian|slackware|arch|paldo|frugalware|mandriva|pardus|linexa|exherbo|lfs|generic) ;;
++              redhat|suse|gentoo|debian|slackware|arch|paldo|frugalware|mandriva|pardus|linexa|exherbo|lfs|pld|generic) ;;
                *)
                        echo "Your distribution (${with_distro}) is not yet supported!  (patches welcome)"
                        exit 1
index 32ae778ff53e832069edb97c004209187269c06e..f76a595ca81f7c8b0659fb0b961dd0a0289df26d 100644 (file)
@@ -6,13 +6,13 @@
 Summary:       Network Manager for GNOME
 Summary(pl.UTF-8):     ZarzÄ…dca sieci dla GNOME
 Name:          NetworkManager
-Version:       0.9.4.0
-Release:       6
+Version:       0.9.6.0
+Release:       1
 Epoch:         2
 License:       GPL v2+
 Group:         Networking/Admin
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/NetworkManager/0.9/%{name}-%{version}.tar.xz
-# Source0-md5: 66a54b51a4998c484613911b72a7e6ff
+# Source0-md5: 85f9ed7fe08533a33c5117488f81e7ac
 Source1:       %{name}.conf
 Source2:       %{name}.upstart
 Source3:       %{name}.tmpfiles
@@ -21,7 +21,6 @@ Patch1:               ifcfg-path.patch
 Patch2:                systemd-fallback.patch
 Patch3:                llh340.patch
 Patch4:                11-initialize-nm-remote-settings.patch
-Patch5:            %{name}-nmcli.patch
 URL:           http://projects.gnome.org/NetworkManager/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.10
@@ -142,7 +141,6 @@ Statyczne biblioteki Network Managera.
 %{?with_systemd:%patch2 -p1}
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 
 %build
 %{__gtkdocize}
This page took 0.191458 seconds and 4 git commands to generate.