]> git.pld-linux.org Git - packages/Maverik.git/blob - Maverik.spec
- spec adapterized.
[packages/Maverik.git] / Maverik.spec
1 Summary:        A vr micro-Kernel
2 Summary(pl):    VR micro-J±dro
3 Name:           Maverik
4 Version:        5.2
5 Release:        1
6 License:        GPL
7 Group:          Development/Libraries
8 Group(de):      Entwicklung/Libraries
9 Group(fr):      Development/Librairies
10 Group(pl):      Programowanie/Biblioteki
11 Source0:        ftp://aig.cs.man.ac.uk/pub/aig/Maverik/%{name}-%{version}.tar.gz
12 Source1:        ftp://aig.cs.man.ac.uk/pub/aig/Maverik/%{name}Demos-%{version}.tar.gz
13 Source2:        %{name}-5.1-1.rpm-extras.tgz
14 Patch0:         %{name}-5.1-1-linux.patch
15 URL:            http://hegel.cs.man.ac.uk/systems/Maverik/
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 GNU Maverik is a framework and library for developing VR applications
20 (it is not an end-user application). It provides optimised management
21 of graphics and peripheral driving capabilities for a single user. A
22 novel feature of GNU MAVERIK is its direct use of the applications own
23 data structures. This means significant performance benefits can be
24 achieved through application specific optmisations.
25
26 %description -l pl
27 GNU Maverik jest ¶rodowiskiem przeznaczonym do rozwoju aplikacji VR.
28 Dostarcza zoptymalizowane zarz±dzanie grafik± itp. Nowacj± w GNY
29 Mavericu jest bezpo¶rednie u¿ywanie struktur danych aplikacji przez co
30 mo¿lie jest znaczne przyspieszenie dzia³ania przez optymalizajê
31 aplikacji u¿ywaj±cej Maverika.
32
33 %package demos
34 Summary:        Maverik Demos
35 Summary(pl):    Dema Maverika
36 Group:          Development/Libraries
37 Group(de):      Entwicklung/Libraries
38 Group(fr):      Development/Librairies
39 Group(pl):      Programowanie/Biblioteki
40 Requires:       %{name} = %{version}
41
42 %description demos
43 Maverik demos. AIGLab, EscapeCity and LegibleCity.
44
45 %description -l pl demos
46 Dema Maverika. AIGLab, EscapeCity i LegibleCity.
47
48 %prep
49 %setup -q
50 %setup -q -T -D -b 1
51 %setup -q -T -D -a 2
52 %patch -p 1
53
54 for i in doc/MFS/man3/*; do
55         if [ -L $i ]; then
56                 echo ".so `ls -l $i | awk '{print $11}'; rm -f $i`" > $i
57         fi
58 done
59
60 %build
61 #export OS_TYPE="Linux"
62 #export MAV_HOME=`pwd`
63 #source setup_env
64 ( ./setup --VRML97 --MESAPATH=%{_prefix}/X11R6 ; make ; make clean)
65
66 #export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${RPM_BUILD_DIR}/Maverik-3.0b4/lib/Linux
67 #(cd examples; make)
68
69 # dont make examples they need incl and lib paths setting, and those
70 # are different between our build and the installed build. Fix that
71 # one day. For now a useful test for the user to try.
72 #(cd examples ; make ; make clean)
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 install -d $RPM_BUILD_ROOT/%{_prefix}/src/examples/%{name}-%{version}
78 install -d $RPM_BUILD_ROOT/{%{_libdir},%{_includedir}/Maverik,%{_mandir}/man3}
79
80 install -s lib/*.so $RPM_BUILD_ROOT/%{_libdir}/
81 install incl/* $RPM_BUILD_ROOT/%{_includedir}/Maverik/
82
83 cp -a examples/* $RPM_BUILD_ROOT/%{_prefix}/src/examples/%{name}-%{version}/
84 cp -a demos $RPM_BUILD_ROOT/%{_prefix}/src/examples/%{name}-%{version}/
85
86 find $RPM_BUILD_ROOT/%{_prefix}/src/examples/%{name}-%{version} -type f \
87         -exec strip --strip-unneeded {} \; || :
88
89 # manual
90 install doc/MFS/man3/* $RPM_BUILD_ROOT/%{_mandir}/man3/
91
92 gzip -9nf $RPM_BUILD_ROOT/%{_mandir}/man3/* README.rpm README FAQ VERSIONS \
93         doc/MPG/ps/mpg.ps doc/MFS/ps/mfs.ps
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc {README.rpm,README,FAQ,VERSIONS}.gz
101 %doc doc/MPG/ps/mpg.ps.gz doc/MFS/ps/mfs.ps.gz doc/MFS/html
102 %attr(755, root, root) %{_libdir}/*.so
103 %dir %{_includedir}/Maverik
104 %attr(644, root, root) %{_includedir}/Maverik/*
105 %attr(644, root, root) %{_mandir}/man3/*
106 %dir %{_prefix}/src/examples/%{name}-%{version}
107 %{_prefix}/src/examples/%{name}-%{version}/MPG
108 %{_prefix}/src/examples/%{name}-%{version}/kernel
109 %{_prefix}/src/examples/%{name}-%{version}/misc
110 %{_prefix}/src/examples/%{name}-%{version}/Makefile
111 %{_prefix}/src/examples/%{name}-%{version}/README
112
113 %files demos
114 %defattr(644,root,root,755)
115 %{_prefix}/src/examples/%{name}-%{version}/demos
This page took 0.067501 seconds and 3 git commands to generate.