]> git.pld-linux.org Git - packages/Glide_V3-DRI.git/blob - Glide_V3-DRI.spec
- release 7
[packages/Glide_V3-DRI.git] / Glide_V3-DRI.spec
1 Summary:        Glide runtime for 3Dfx Voodoo Banshee and Voodoo3 boards
2 Name:           Glide_V3-DRI
3 Version:        3.10
4 Release:        7
5 Group:          Libraries
6 Copyright:      3dfx Glide General Public License, 3Dfx Interactive Inc.
7 URL:            http://www.3dfx.com     
8 Source:         Glide3.10.tar.gz
9 Patch:          Glide3.10-CVS-20000616.patch.gz
10 Vendor:         3dfx Interactive Inc.
11 Icon:           3dfx.gif
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description 
15 This library allows the user to use a 3dfx Interactive Voodoo Banshee
16 or Voodoo3 card under Linux with DRI support. The source support DRI
17 or non-DRI versions of Glide.
18
19 %package devel
20 Summary:        Development headers for Glide 3.x
21 Group:          Development/Libraries
22 Requires:       %{name} = %{version}
23
24 %description devel
25 This package includes the headers files, documentation, and test files
26 necessary for developing applications that use the 3Dfx Interactive
27 Voodoo Banshe or Voodoo3 cards.
28
29 %prep
30 %setup -q -c
31 %patch -p1
32 chmod +x swlibs/include/make/ostype
33
34 ln -sf linhwc.c.dri h3/minihwc/linhwc.c
35 ln -sf gsst.c.dri h3/glide3/src/gsst.c
36 ln -sf glfb.c.dri h3/glide3/src/glfb.c
37 ln -sf gglide.c.dri h3/glide3/src/gglide.c
38
39 %build
40 export FX_GLIDE_HW=h3
41 %{__make} -f makefile.linux CNODEBUG="$RPM_OPT_FLAGS -fomit-frame-pointer \
42         -funroll-loops -fexpensive-optimizations -ffast-math -DBIG_OPT"
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_includedir}/glide3,%{_libdir}}
47 install -d $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/{tests,texus/{lib,cmd,examples}}
48
49 install -s h3/lib/libglide3.so.3.10 $RPM_BUILD_ROOT%{_libdir}/libglide3.so.3.10
50 ln -s libglide3.so.3 $RPM_BUILD_ROOT%{_libdir}/libglide3.so
51 ln -s libglide3.so.3 $RPM_BUILD_ROOT%{_libdir}/libglide3x_V3.so
52 ln -s libglide3x_V3.so $RPM_BUILD_ROOT%{_libdir}/libglide3x.so
53
54 install -s swlibs/lib/libtexus.so.1.1 $RPM_BUILD_ROOT%{_libdir}
55 ln -s libtexus.so.1 $RPM_BUILD_ROOT%{_libdir}/libtexus.so
56
57 install swlibs/include/3dfx.h $RPM_BUILD_ROOT%{_includedir}/glide3
58 install h3/include/glide.h $RPM_BUILD_ROOT%{_includedir}/glide3
59 install h3/include/glidesys.h $RPM_BUILD_ROOT%{_includedir}/glide3
60 install h3/include/glideutl.h $RPM_BUILD_ROOT%{_includedir}/glide3
61 install h3/include/sst1vid.h $RPM_BUILD_ROOT%{_includedir}/glide3
62 install swlibs/include/linutil.h $RPM_BUILD_ROOT%{_includedir}/glide3
63 install swlibs/include/texus.h $RPM_BUILD_ROOT%{_includedir}/glide3
64
65 # Install the examples and their source, no binaries
66 install h3/glide3/tests/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests/makefile
67 install h3/glide3/tests/*.3df $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests
68 install h3/glide3/tests/test??.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests
69 install h3/glide3/tests/tldata.inc $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests
70 install h3/glide3/tests/tlib.[ch] $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests
71
72 # Install the texture tools
73 install swlibs/texus/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/texus/makefile
74 install swlibs/texus/lib/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/texus/lib/makefile
75 install swlibs/texus/cmd/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/texus/cmd/makefile
76 install swlibs/texus/examples/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/texus/examples/makefile
77 install swlibs/texus/lib/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/texus/lib
78 install swlibs/texus/lib/texusint.h $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/texus/lib
79 install swlibs/texus/cmd/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/texus/cmd
80 install swlibs/texus/examples/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/texus/examples
81
82 gzip -9nf glide_license.txt
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc glide_license.txt.gz
93 %attr(755,root,root) %{_libdir}/libglide3.so.3.10
94 %attr(755,root,root) %{_libdir}/libglide3.so
95 %attr(755,root,root) %{_libdir}/libglide3x.so
96 %attr(755,root,root) %{_libdir}/libglide3x_V3.so
97 %attr(755,root,root) %{_libdir}/libtexus.so.1.1
98 %attr(755,root,root) %{_libdir}/libtexus.so
99
100 %files devel
101 %defattr(644,root,root,755)
102 %doc docs/*.pdf
103 %{_prefix}/src/examples/glide3
104 %{_includedir}/glide3
This page took 0.102346 seconds and 3 git commands to generate.