]> git.pld-linux.org Git - packages/ElectricFence.git/blob - ElectricFence.spec
- release 4,
[packages/ElectricFence.git] / ElectricFence.spec
1 Summary:        A debugger which detects memory allocation violations
2 Summary(de):    Debugger zum Erkennen von Speicherzugriffsverletzungen
3 Summary(es):    Electric Fence biblioteca de depuración de memoria en C
4 Summary(fr):    Bibliothèque C de débuggage mémoire Electric Fence
5 Summary(pl):    Biblioteka do wykrywania b³edów alokacji pamiêci
6 Summary(pt):    Electric Fence biblioteca de depuração de memória em C
7 Summary(tr):    C için bellek hatasý ayýklama kitaplýðý
8 Name:           ElectricFence
9 Version:        2.2.2
10 Release:        4
11 License:        GPL
12 Group:          Development/Debuggers
13 Group(pl):      Programowanie/Odpluskwiacze
14 Source0:        ftp://ftp.perens.com/pub/ElectricFence/Beta/%{name}-%{version}.tar.gz
15 Patch0:         ElectricFence-longjmp.patch
16 Patch1:         ElectricFence-no_bash.spec
17 Patch2:         ElectricFence-va_arg.patch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 If you know what malloc() violations are, you'll be interested in
22 ElectricFence. ElectricFence is a tool which can be used for C
23 programming and debugging. It uses the virtual memory hardware of your
24 system to detect when software overruns malloc() buffer boundaries,
25 and/or to detect any accesses of memory released by free().
26 ElectricFence will then stop the program on the first instruction that
27 caused a bounds violation and you can use your favorite debugger to
28 display the offending statement.
29
30 %description -l de
31 Wenn Sie wissen, was malloc()-Verletzungen sind, sind Sie
32 wahrscheinlich an ElectricFence interessiert. ElectricFence ist ein
33 Tool, das zur C- Programmierung und zum Debugging benutzt werden kann.
34 Es benutzt virtuelle Speicherhardware, um zu erkennen, wenn Software
35 malloc()-Buffergrenzen übersteigt, und wenn Speicher mit free()
36 freigegeben wird. ElectricFence beendet das Programm bei der
37 Instruktion, die die Speicherverletzung ausgelöst hat, und Sie können
38 Ihren Lieblingsdebugger benutzen, um den Befehl anzuzeigen.
39
40 %description -l es
41 Electric Fence es una biblioteca que puede ser usada para programación
42 y depuración en C. Tu lo "linkas" en tiempo de compilación y te
43 avisará sobre posibles problemas, como liberación de memoria no
44 alocada, etc.
45
46 %description -l fr
47 Electric Fence est une bibliothéque utilisée pour la programmation en
48 C et le débogage. Vous pouvez la lier à la compilation et elle vous
49 avertira des problèmes éventuels de désallocation de mémoire, etc.
50
51 %description -l pl
52 Electric Fence jest bibliotek± pomocn± podczas programowania w jêzyku
53 C i "odpluskwianiu". Pakiet zawiera bibliotekê wspó³dzielon±, która
54 mo¿e byæ za³adowana przez zmienn± LD_PRELOAD w trakcie uruchamiania
55 dowolnego programu dziêki temu nie potrzeba linkowaæ z t± bibliotek±
56 ¶ledzonego programu. Pakiet zawiera tak¿e skrypt pow³oki ef, który
57 ³aduje do pamiêci przez LD_PRELOAD bibliotekê libefence i uruchamia
58 program przekazany do tego skryptu jako parametr.
59
60 %description -l pt
61 Electric Fence é uma biblioteca que pode ser usada para programação e
62 depuração em C. Você o "linka" em tempo de compilação e ele o avisará
63 sobre possíveis problemas como liberação de memória não alocada, etc.
64
65 %description -l tr
66 Electric Fence, C'de programlama ve hata ayýklama için kullanýlabilen
67 bir kitaplýktýr. Derleme esnasýnda programýnýza baðlarsanýz, sizi
68 ortaya çýkabilecek sorunlar (var olmayan bir bellek parçasýnýn serbest
69 býrakýlmasý gibi) konusunda uyarýr.
70
71 %package static
72 Summary:        Satatic Electric Fence library
73 Summary(pl):    Biblioteka statyczna Electric Fence
74 Group:          Development/Debuggers
75 Group(pl):      Programowanie/Odpluskwiacze
76
77 %description static
78 Satatic Electric Fence library.
79
80 %description -l pl static
81 Biblioteka statyczna Electric Fence.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88
89 %build
90 make CFLAGS="$RPM_OPT_FLAGS"
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_prefix}/{bin,lib,share/man/man3}
95
96 make    BIN_INSTALL_DIR=$RPM_BUILD_ROOT%{_bindir} \
97         LIB_INSTALL_DIR=$RPM_BUILD_ROOT%{_libdir} \
98         MAN_INSTALL_DIR=$RPM_BUILD_ROOT%{_mandir}/man3 \
99         install
100
101 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*so.*.*
102
103 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
104         README CHANGES
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc *gz
115 %attr(755,root,root) %{_bindir}/ef
116 %attr(755,root,root) %{_libdir}/lib*.so.*.*
117 %{_mandir}/man3/*
118
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/lib*.a
This page took 0.112421 seconds and 4 git commands to generate.