]> git.pld-linux.org Git - packages/ElectricFence.git/blob - ElectricFence.spec
- added stripping shared library.
[packages/ElectricFence.git] / ElectricFence.spec
1 Summary:        Electric Fence C memory debugging library
2 Summary(de):    Electric Fence C Memory-Debugging-Library
3 Summary(fr):    Bibliothèque C de débuggage mémoire Electric Fence
4 Summary(pl):    Biblioteka Electric Fence
5 Summary(tr):    C için bellek hatasý ayýklama kitaplýðý
6 Name:           ElectricFence
7 Version:        2.2.0
8 Release:        1
9 Excludearch:    alpha
10 Copyright:      GPL
11 Group:          Development/Debuggers
12 Group(pl):      Programowanie/Odpluskwiacze
13 Source:         ftp://perens.com/pub/ElectricFence/%{name}-%{version}.tar.gz
14 Patch0:         ElectricFence-longjmp.patch
15 BuildRoot:      /tmp/%{name}-%{version}-root
16
17 %description
18 Electric Fence is a libary that can be used for C programming and debugging.
19 Package contain shared library libefence which can be loaded by LD_PRELOAD
20 without relinking debuged program. Package contain also ef shell script
21 which preloads libefence and runs program passed as parameter.
22
23 %description -l de
24 Electric Fence ist eine Library, die für das Programmieren in C und für
25 Debugging-Zwecke benutzt werden kann. Sie wird beim Kompilieren gelinkt und
26 warnt vor möglichen Probleme, etwa vor der Freigabe von nicht existierendem
27 Speicher und ähnlichem.
28
29 %description -l fr
30 Electric Fence est une bibliothéque utilisée pour la programmation en C et
31 le débogage. Vous pouvez la lier à la compilation et elle vous avertira des
32 problèmes éventuels de désallocation de mémoire, etc.
33
34 %description -l pl
35 Electric Fence jest bibliotek± pomocn± podczas programowania w
36 jêzyku C i "odpluskwianiu".
37 Pakiet zawiera bibliotekê wspó³dzielon± która mo¿e byæ za³adowana przez
38 zmienn± LD_PRELOAD w trakcie uruchamiania dowolnego programu dziêki temu nie
39 potrzeba linkowaæ z t± bibliotek± ¶ledzonego programu. Pakiet zawiera tak¿e
40 skrypt shellowy ef, któremu mo¿na ³aduje do pamiêci przez LD_PRELOAD
41 libliotekê libefence i uruchamia program przekazyny do tego skryptu jako
42 parametr.
43
44 %description -l tr
45 Electric Fence, C'de programlama ve hata ayýklama için kullanýlabilen bir
46 kitaplýktýr. Derleme esnasýnda programýnýza baðlarsanýz, sizi ortaya
47 çýkabilecek sorunlar (var olmayan bir bellek parçasýnýn serbest býrakýlmasý
48 gibi) konusunda uyarýr.
49
50 %package static
51 Summary:        Satatic Electric Fence library
52 Summary(pl):    Biblioteka statyczna Electric Fence
53 Group:          Development/Debuggers
54 Group(pl):      Programowanie/Odpluskwiacze
55
56 %description static
57 Satatic Electric Fence library.
58
59 %description -l pl static
60 Biblioteka statyczna Electric Fence.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65
66 %build
67 make CFLAGS="$RPM_OPT_FLAGS"
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib,man/man3}
72
73 make    BIN_INSTALL_DIR=$RPM_BUILD_ROOT/usr/bin \
74         LIB_INSTALL_DIR=$RPM_BUILD_ROOT/usr/lib \
75         MAN_INSTALL_DIR=$RPM_BUILD_ROOT/usr/man/man3 \
76         install
77
78 echo .so libefence.3 > $RPM_BUILD_ROOT/usr/man/man3/efence.3
79
80 strip --strip-unneeded $RPM_BUILD_ROOT/usr/lib/lib*so.*.*
81
82 gzip -9nf $RPM_BUILD_ROOT/usr/man/man3/* \
83         README CHANGES
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc *gz
91 %attr(755,root,root) /usr/bin/ef
92 %attr(755,root,root) /usr/lib/lib*.so.*.*
93 /usr/man/man3/*
94
95 %files static
96 %defattr(644,root,root,755)
97 /usr/lib/lib*.a
98
99 %changelog
100 * Mon Apr 12 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
101   [2.2-1]
102 - added static subpackage; main package contains now shared library which
103   can be preloaded for any executable without relinking,
104 - added static subpackage.
105
106 * Sun Apr 11 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
107   [2.1-1]
108 - added Group(pl),
109 - gzipping %doc.
110
111 * Wed Dec 30 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
112   [2.0.5-11d]
113 - build for PLD, 
114 - major changes.
115
116 * Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
117 - create efence.3 (problem #830)
118
119 * Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
120 - build root
121
122 * Mon Jun 01 1998 Prospector System <bugs@redhat.com>
123 - translations modified for de
124
125 * Mon Jun 01 1998 Prospector System <bugs@redhat.com>
126 - need to use sigsetjmp() and siglongjmp() for proper testing
127
128 * Fri May 01 1998 Prospector System <bugs@redhat.com>
129 - translations modified for de, fr, tr
130
131 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
132 - use ExcludeArch instead of Exclude
133
134 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
135 - built against glibc
This page took 0.094263 seconds and 4 git commands to generate.