]> git.pld-linux.org Git - packages/DevIL.git/blob - DevIL.spec
7087a7119b20a5c6e31effb6d6f8e2f6a81ba2f3
[packages/DevIL.git] / DevIL.spec
1 #
2 # Conditional build:
3 %bcond_with     sse     # use SSE extension
4 %bcond_with     sse2    # use SSE2 extension
5 %bcond_with     sse3    # use SSE3 extension
6 #
7 %ifarch pentium3 pentium4 %{x8664}
8 %define with_sse        1
9 %endif
10 %ifarch pentium4 %{x8664}
11 %define with_sse2       1
12 %endif
13 %define         manual_version  1.5.5
14 Summary:        Full featured image library
15 Summary(pl.UTF-8):      Biblioteka obsługi obrazów z mnóstwem funkcji
16 Name:           DevIL
17 Version:        1.7.8
18 Release:        17
19 License:        LGPL v2.1
20 Group:          Libraries
21 Source0:        http://downloads.sourceforge.net/openil/%{name}-%{version}.tar.gz
22 # Source0-md5:  7918f215524589435e5ec2e8736d5e1d
23 Source1:        http://downloads.sourceforge.net/openil/%{name}-Manual-%{manual_version}.zip
24 # Source1-md5:  6bb2ddfcbe09930c48ef84b8f99479fe
25 Source2:        http://downloads.sourceforge.net/openil/%{name}-docs.tar.gz
26 # Source2-md5:  eec6ae7a028a3f058bab1a6918428ed5
27 Patch0:         libpng14.patch
28 Patch1:         %{name}-squish.patch
29 Patch2:         %{name}-as-needed.patch
30 Patch3:         gcc5.patch
31 Patch4:         jasper2.patch
32 URL:            http://openil.sourceforge.net/
33 BuildRequires:  OpenEXR-devel
34 BuildRequires:  OpenGL-GLU-devel
35 BuildRequires:  SDL-devel >= 1.2.5
36 BuildRequires:  allegro-devel >= 4.1.16
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 BuildRequires:  jasper-devel
40 BuildRequires:  lcms-devel
41 BuildRequires:  libjpeg-devel
42 BuildRequires:  libmng-devel
43 BuildRequires:  libpng-devel
44 BuildRequires:  libtiff-devel
45 BuildRequires:  libtool >= 2:1.5
46 BuildRequires:  pkgconfig
47 BuildRequires:  rpmbuild(macros) >= 1.533
48 BuildRequires:  squish-devel
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  unzip
51 BuildRequires:  xorg-lib-libXext-devel
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
55
56 %description
57 Developer's Image Library (DevIL) is a programmer's library to develop
58 applications with very powerful image loading capabilities, yet is
59 easy for a developer to learn and use. Ultimate control of images is
60 left to the developer, so unnecessary conversions, etc. are not
61 performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can
62 load, save, convert, manipulate, filter and display a wide variety of
63 image formats.
64
65 Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .icns,
66 .jp2, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic,
67 .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif files.
68
69 Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm,
70 .pcx, .pgm, .png, .ppm, .raw, .sgi, .tga and .tif.
71
72 %description -l pl.UTF-8
73 Developer's Image Library (DevIL) jest biblioteką programisty
74 pozwalającą tworzyć aplikacje z potężnymi możliwościami ładowania
75 obrazów. Pozostaje przy tym łatwa w użyciu i prosta do nauczenia się.
76 Ostateczna kontrola nad obrazami jest zostawiona programiście, nie
77 wprowadza się niepotrzebnych konwersji, itp. DevIL używa prostej, lecz
78 potężnej składni poleceń, wzorowanej na OpenGL-u. DevIL potrafi
79 ładować, zapisywać, konwertować, manipulować, filtrować szeroki
80 wachlarz formatów plików graficznych.
81
82 W chwili obecnej DevIL odczytuje pliki z rozszerzeniami bmp, cut, dds,
83 doom, gif, icns, ico, jp2, jpg, lbm, mdl, mng, pal, pbm, pcd, pcx,
84 pgm, pic, png, ppm, psd, psp, raw, sgi, tga i tif.
85
86 Obsługiwane jest zapisywanie do plików bmp, dds, h, jpg, pal, pbm,
87 pcx, pgm, png, ppm, raw, sgi, tga i tif.
88
89 %package devel
90 Summary:        DevIL development files
91 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DevIL
92 Group:          Development/Libraries
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       OpenEXR-devel
95 Requires:       jasper-devel
96 Requires:       lcms-devel
97 Requires:       libjpeg-devel
98 Requires:       libmng-devel
99 Requires:       libpng-devel
100 Requires:       libtiff-devel
101 Requires:       squish-devel
102
103 %description devel
104 DevIL development files (for IL and ILU libraries).
105
106 %description devel -l pl.UTF-8
107 Pliki nagłówkowe bibliotek DevIL (IL i ILU).
108
109 %package static
110 Summary:        Static DevIL libraries
111 Summary(pl.UTF-8):      Statyczne biblioteki DevIL
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114
115 %description static
116 Static DevIL libraries (IL and ILU).
117
118 %description static -l pl.UTF-8
119 Statyczne biblioteki DevIL (IL i ILU).
120
121 %package ILUT
122 Summary:        DevIL ILUT library
123 Summary(pl.UTF-8):      Biblioteka DevIL ILUT
124 Group:          Libraries
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       SDL >= 1.2.5
127 Requires:       allegro >= 4.1.16
128
129 %description ILUT
130 DevIL ILUT library - connection to higher level libraries.
131
132 %description ILUT -l pl.UTF-8
133 Biblioteka DevIL ILUT - łącznik z bibliotekami wyższego poziomu.
134
135 %package ILUT-devel
136 Summary:        Development files for DevIL ILUT library
137 Summary(pl.UTF-8):      Pliki programistyczne biblioteki DevIL ILUT
138 Group:          Development/Libraries
139 Requires:       %{name}-ILUT = %{version}-%{release}
140 Requires:       %{name}-devel = %{version}-%{release}
141 Requires:       OpenGL-GLU-devel
142 Requires:       SDL-devel >= 1.2.5
143 Requires:       allegro-devel >= 4.1.16
144 Requires:       xorg-lib-libXext-devel
145
146 %description ILUT-devel
147 Development files for DevIL ILUT library.
148
149 %description ILUT-devel -l pl.UTF-8
150 Pliki programistyczne biblioteki DevIL ILUT.
151
152 %package ILUT-static
153 Summary:        Static DevIL ILUT library
154 Summary(pl.UTF-8):      Statyczna biblioteka DevIL ILUT
155 Group:          Development/Libraries
156 Requires:       %{name}-ILUT-devel = %{version}-%{release}
157
158 %description ILUT-static
159 Static DevIL ILUT library.
160
161 %description ILUT-static -l pl.UTF-8
162 Statyczna biblioteka DevIL ILUT.
163
164 %package doc
165 Summary:        DevIL documentation
166 Summary(pl.UTF-8):      Dokumentacja DevIL
167 Group:          Documentation
168
169 %description doc
170 DevIL documentation.
171
172 %description doc -l pl.UTF-8
173 Dokumentacja DevIL.
174
175 %prep
176 %setup -q -c -a1 -a2
177 %patch0 -p1
178 %patch1 -p1
179 %patch2 -p1
180 %patch3 -p1
181 %patch4 -p1
182
183 %build
184 cd devil-%{version}
185 %{__libtoolize}
186 %{__aclocal} -I m4
187 %{__autoconf}
188 %{__autoheader}
189 %{__automake}
190 %configure \
191         --enable-ILU \
192         --enable-ILUT \
193         %{?debug:--disable-release} \
194         %{!?with_sse:--disable-sse} \
195         %{!?with_sse2:--disable-sse2} \
196         %{!?with_sse3:--disable-sse3}
197 %{__make}
198
199 %install
200 rm -rf $RPM_BUILD_ROOT
201
202 %{__make} -C devil-%{version} install \
203         DESTDIR=$RPM_BUILD_ROOT
204
205 %clean
206 rm -rf $RPM_BUILD_ROOT
207
208 %post   -p /sbin/ldconfig
209 %postun -p /sbin/ldconfig
210
211 %post   devel -p /sbin/postshell
212 -/usr/sbin/fix-info-dir -c %{_infodir}
213
214 %postun devel -p /sbin/postshell
215 -/usr/sbin/fix-info-dir -c %{_infodir}
216
217 %files
218 %defattr(644,root,root,755)
219 %doc devil-%{version}/{AUTHORS,CREDITS,ChangeLog,README.unix}
220 %attr(755,root,root) %{_bindir}/ilur
221 %attr(755,root,root) %{_libdir}/libIL.so.*.*.*
222 %attr(755,root,root) %ghost %{_libdir}/libIL.so.1
223 %attr(755,root,root) %{_libdir}/libILU.so.*.*.*
224 %attr(755,root,root) %ghost %{_libdir}/libILU.so.1
225
226 %files devel
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/libIL.so
229 %attr(755,root,root) %{_libdir}/libILU.so
230 %{_libdir}/libIL.la
231 %{_libdir}/libILU.la
232 %dir %{_includedir}/IL
233 %{_includedir}/IL/il.h
234 %{_includedir}/IL/ilu.h
235 %{_includedir}/IL/ilu_region.h
236 %{_pkgconfigdir}/IL.pc
237 %{_pkgconfigdir}/ILU.pc
238 %{_infodir}/DevIL_manual.info*
239
240 %files static
241 %defattr(644,root,root,755)
242 %{_libdir}/libIL.a
243 %{_libdir}/libILU.a
244
245 %files ILUT
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/libILUT.so.*.*.*
248 %attr(755,root,root) %ghost %{_libdir}/libILUT.so.1
249
250 %files ILUT-devel
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_libdir}/libILUT.so
253 %{_includedir}/IL/devil_cpp_wrapper.hpp
254 %{_includedir}/IL/ilut.h
255 %{_libdir}/libILUT.la
256 %{_pkgconfigdir}/ILUT.pc
257
258 %files ILUT-static
259 %defattr(644,root,root,755)
260 %{_libdir}/libILUT.a
261
262 %files doc
263 %defattr(644,root,root,755)
264 %doc DevIL*.pdf
This page took 0.059301 seconds and 2 git commands to generate.