]> git.pld-linux.org Git - packages/DevIL.git/blob - DevIL.spec
- start update to 1.7.8
[packages/DevIL.git] / DevIL.spec
1 #
2 # TODO: - check and fix patches if possible
3 #
4 %define         manual_version  1.5.5
5 Summary:        Full featured image library
6 Summary(pl.UTF-8):      Biblioteka obsługi obrazów z mnóstwem funkcji
7 Name:           DevIL
8 Version:        1.7.8
9 Release:        0.1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/openil/%{name}-%{version}.tar.gz
13 # Source0-md5:  7918f215524589435e5ec2e8736d5e1d
14 Source1:        http://downloads.sourceforge.net/openil/%{name}-Manual-%{manual_version}.zip
15 # Source1-md5:  6bb2ddfcbe09930c48ef84b8f99479fe
16 Source2:        http://downloads.sourceforge.net/openil/%{name}-docs.tar.gz
17 # Source2-md5:  eec6ae7a028a3f058bab1a6918428ed5
18 Patch0:         %{name}-c++.patch
19 Patch1:         %{name}-link.patch
20 Patch2:         %{name}-gnu-inline.patch
21 Patch3:         libpng14.patch
22 URL:            http://openil.sourceforge.net/
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  SDL-devel >= 1.2.5
25 BuildRequires:  allegro-devel >= 4.1.16
26 BuildRequires:  autoconf >= 2.52
27 BuildRequires:  automake
28 BuildRequires:  jasper-devel
29 BuildRequires:  lcms-devel
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libmng-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libtiff-devel
34 BuildRequires:  libtool >= 2:1.5
35 BuildRequires:  rpmbuild(macros) >= 1.533
36 BuildRequires:  sed >= 4.0
37 BuildRequires:  unzip
38 BuildRequires:  which
39 Requires:       allegro >= 4.1.16
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
43
44 %description
45 Developer's Image Library (DevIL) is a programmer's library to develop
46 applications with very powerful image loading capabilities, yet is
47 easy for a developer to learn and use. Ultimate control of images is
48 left to the developer, so unnecessary conversions, etc. are not
49 performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can
50 load, save, convert, manipulate, filter and display a wide variety of
51 image formats.
52
53 Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .icns,
54 .jp2, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic,
55 .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif files.
56
57 Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm,
58 .pcx, .pgm, .png, .ppm, .raw, .sgi, .tga and .tif.
59
60 %description -l pl.UTF-8
61 Developer's Image Library (DevIL) jest biblioteką programisty
62 pozwalającą tworzyć aplikacje z potężnymi możliwościami ładowania
63 obrazów. Pozostaje przy tym łatwa w użyciu i prosta do nauczenia się.
64 Ostateczna kontrola nad obrazami jest zostawiona programiście, nie
65 wprowadza się niepotrzebnych konwersji, itp. DevIL używa prostej, lecz
66 potężnej składni poleceń, wzorowanej na OpenGL-u. DevIL potrafi
67 ładować, zapisywać, konwertować, manipulować, filtrować szeroki
68 wachlarz formatów plików graficznych.
69
70 W chwili obecnej DevIL odczytuje pliki z rozszerzeniami bmp, cut, dds,
71 doom, gif, icns, ico, jp2, jpg, lbm, mdl, mng, pal, pbm, pcd, pcx,
72 pgm, pic, png, ppm, psd, psp, raw, sgi, tga i tif.
73
74 Wspierane jest zapisywanie do plików bmp, dds, h, jpg, pal, pbm, pcx,
75 pgm, png, ppm, raw, sgi, tga i tif.
76
77 %package devel
78 Summary:        DevIL devel files
79 Summary(pl.UTF-8):      Nagłówki DevIL
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       jasper-devel
83 Requires:       lcms-devel
84 Requires:       libjpeg-devel
85 Requires:       libmng-devel
86 Requires:       libpng-devel
87 Requires:       libtiff-devel
88 # libILUT additionally: SDL-devel, allegro-devel, OpenGL-GLU-devel
89
90 %description devel
91 DevIL devel files.
92
93 %description devel -l pl.UTF-8
94 Nagłówki DevIL.
95
96 %package doc
97 Summary:        DevIL documentation
98 Summary(pl.UTF-8):      Dokumentacja DevIL
99 Group:          Documentation
100
101 %description doc
102 DevIL documentation.
103
104 %description doc -l pl.UTF-8
105 Dokumentacja DevIL.
106
107 %prep
108 %setup -q -c -a1 -a2
109 #%%patch0 -p1
110 #%%patch1 -p1
111 #%%patch2 -p1
112 #%%undos devil-%{version}/src-IL/src/il_png.c
113 #%%undos devil-%{version}/src-IL/src/il_icon.c
114 %patch3 -p1
115
116 # lpng12 -> lpng
117 %{__sed} -i 's,png12,png,' devil-%{version}/m4/devil-definitions.m4
118
119 # just SDL and messing libtool macros
120 rm -f acinclude.m4
121
122 %build
123 cd devil-%{version}
124 %{__libtoolize}
125 %{__aclocal} -I m4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 # actual exr support missing in sources, only adds undefined symbol
130 CPPFLAGS="%{rpmcppflags} -DIL_NO_EXR"
131 %configure \
132         --enable-ILU=yes \
133         --enable-ILUT=yes \
134         %{?debug:--disable-release}
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} -C devil-%{version} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc devil-%{version}/{AUTHORS,CREDITS,ChangeLog,README.unix}
152 %attr(755,root,root) %{_libdir}/libIL.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libIL.so.1
154 %attr(755,root,root) %{_libdir}/libILU.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libILU.so.1
156 %attr(755,root,root) %{_libdir}/libILUT.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libILUT.so.1
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libIL.so
162 %attr(755,root,root) %{_libdir}/libILU.so
163 %attr(755,root,root) %{_libdir}/libILUT.so
164 %{_libdir}/libIL.la
165 %{_libdir}/libILU.la
166 %{_libdir}/libILUT.la
167 %{_includedir}/IL
168
169 %files doc
170 %defattr(644,root,root,755)
171 %doc DevIL*.pdf
This page took 0.106838 seconds and 3 git commands to generate.