]> git.pld-linux.org Git - packages/CodeIgniter.git/blob - CodeIgniter.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/CodeIgniter.git] / CodeIgniter.spec
1 %define         php_min_version 5.2.4
2 Summary:        A powerful PHP framework with a very small footprint
3 Name:           CodeIgniter
4 Version:        2.2.2
5 Release:        0.1
6 License:        other
7 Group:          Development/Languages/PHP
8 Source0:        https://github.com/bcit-ci/CodeIgniter/archive/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  042f94f7c59b22111c7cf56673769c8b
10 Source1:        INSTALL-PLD.txt
11 Source2:        codeigniter-install
12 Patch0:         pld.patch
13 URL:            http://codeigniter.com/
14 BuildRequires:  rpm-php-pearprov >= 4.3
15 BuildRequires:  rpmbuild(macros) >= 1.461
16 BuildRequires:  sed >= 4.0
17 BuildRequires:  unzip
18 Requires:       php(core) >= %{php_min_version}
19 Requires:       php(ctype)
20 Requires:       php(date)
21 Requires:       php(hash)
22 Requires:       php(mbstring)
23 Requires:       php(mysql)
24 Requires:       php(pcre)
25 Requires:       php(session)
26 Requires:       php(simplexml)
27 Requires:       php(spl)
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _appdir         %{_datadir}/%{name}
32
33 %description
34 CodeIgniter is a powerful PHP framework with a very small footprint,
35 built for PHP coders who need a simple and elegant toolkit to create
36 full-featured web applications. If you're a developer who lives in the
37 real world of shared hosting accounts and clients with deadlines, and
38 if you're tired of ponderously large and thoroughly undocumented
39 frameworks.
40
41 %package doc
42 Summary:        CodeIgniter documentation
43 Group:          Development/Languages/PHP
44
45 %description doc
46 CodeIgniter documentation.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51
52 cp -p %{SOURCE1} user_guide
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir}}
57 cp -r index.php application system $RPM_BUILD_ROOT%{_appdir}
58 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
59
60 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name index.html | xargs rm -v
61 rm -r $RPM_BUILD_ROOT%{_appdir}/application/{cache,core,helpers,hooks,libraries}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %banner -e %{name} <<-EOF
68 Please read INSTALL-PLD.txt to know how can use the users the installed CodeIgniter!
69 EOF
70
71 %files
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_bindir}/codeigniter-install
74
75 %dir %{_appdir}
76 %dir %{_appdir}/application
77 %dir %{_appdir}/application/config
78 %dir %{_appdir}/application/controllers
79 %dir %{_appdir}/application/errors
80 %dir %{_appdir}/application/language
81 %dir %{_appdir}/application/views
82 %dir %{_appdir}/system
83 %dir %{_appdir}/system/core
84 %dir %{_appdir}/system/database
85 %dir %{_appdir}/system/database/drivers
86 %dir %{_appdir}/system/fonts
87 %dir %{_appdir}/system/helpers
88 %dir %{_appdir}/system/language
89 %dir %{_appdir}/system/libraries
90
91 %{_appdir}/index.php
92 %{_appdir}/application/.htaccess
93 %{_appdir}/system/.htaccess
94
95 %{_appdir}/application/config/*
96 %{_appdir}/application/controllers/*
97 %{_appdir}/application/errors/*
98 %{_appdir}/application/language/*
99 %{_appdir}/application/views/*
100
101 %{_appdir}/system/core/*
102 %{_appdir}/system/database/DB*.php
103 %{_appdir}/system/database/drivers/*
104 %{_appdir}/system/fonts/*
105 %{_appdir}/system/helpers/*
106 %{_appdir}/system/language/*
107 %{_appdir}/system/libraries/*
108
109 %files doc
110 %defattr(644,root,root,755)
111 %doc user_guide/*
This page took 0.232678 seconds and 3 git commands to generate.