summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2021-10-28 19:28:45 (GMT)
committerJakub Bogusz2021-10-28 19:28:45 (GMT)
commit3cc4cf6fdbb84687dcc94360549e1ee1c2cd06b2 (patch)
treed05902bd72dcd44a7329a6312c5d2a5b62afbc7b
parent1735b6f499616e6af1c072e8610fee7a650f0fb8 (diff)
downloadxorg-xserver-server-3cc4cf6fdbb84687dcc94360549e1ee1c2cd06b2.zip
xorg-xserver-server-3cc4cf6fdbb84687dcc94360549e1ee1c2cd06b2.tar.gz
- add Xserver.d file missing in distauto/th/xorg-xserver-server-21.1.0-1
-rw-r--r--Xserver.d65
-rw-r--r--xorg-xserver-server.spec6
2 files changed, 71 insertions, 0 deletions
diff --git a/Xserver.d b/Xserver.d
new file mode 100644
index 0000000..4a233e1
--- /dev/null
+++ b/Xserver.d
@@ -0,0 +1,65 @@
+/* Copyright (c) 2005-2006, Oracle and/or its affiliates. All rights reserved.
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a
+ * copy of this software and associated documentation files (the "Software"),
+ * to deal in the Software without restriction, including without limitation
+ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
+ * and/or sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice (including the next
+ * paragraph) shall be included in all copies or substantial portions of the
+ * Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+ * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ * DEALINGS IN THE SOFTWARE.
+ */
+
+/*
+ * Xserver dtrace provider definition
+ */
+#ifdef __APPLE__
+#define string char *
+#define pid_t uint32_t
+#define zoneid_t uint32_t
+#elif defined(__FreeBSD__)
+#define zoneid_t id_t
+#else
+#include <sys/types.h>
+#endif
+
+typedef const uint8_t *const_uint8_p;
+typedef const double *const_double_p;
+
+provider Xserver {
+ /* reqType, data, length, client id, request buffer */
+ probe request__start(string, uint8_t, uint16_t, int, void *);
+ /* reqType, data, sequence, client id, result */
+ probe request__done(string, uint8_t, uint32_t, int, int);
+ /* client id, client fd */
+ probe client__connect(int, int);
+ /* client id, client address, client pid, client zone id */
+ probe client__auth(int, string, pid_t, zoneid_t);
+ /* client id */
+ probe client__disconnect(int);
+ /* resource id, resource type, value, resource type name */
+ probe resource__alloc(uint32_t, uint32_t, void *, string);
+ /* resource id, resource type, value, resource type name */
+ probe resource__free(uint32_t, uint32_t, void *, string);
+ /* client id, event type, event* */
+ probe send__event(int, uint8_t, void *);
+ /* deviceid, type, button/keycode/touchid, flags, nvalues, mask, values */
+ probe input__event(int, int, uint32_t, uint32_t, int8_t, const_uint8_p, const_double_p);
+};
+
+#pragma D attributes Unstable/Unstable/Common provider Xserver provider
+#pragma D attributes Private/Private/Unknown provider Xserver module
+#pragma D attributes Private/Private/Unknown provider Xserver function
+#pragma D attributes Unstable/Unstable/Common provider Xserver name
+#pragma D attributes Unstable/Unstable/Common provider Xserver args
+
diff --git a/xorg-xserver-server.spec b/xorg-xserver-server.spec
index dd01a59..f7d1054 100644
--- a/xorg-xserver-server.spec
+++ b/xorg-xserver-server.spec
@@ -42,6 +42,8 @@ Source0: https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{
# Source0-md5: 1b8306f8f320fbb4c008865f0e36eaab
Source1: 10-quirks.conf
Source2: xserver.pamd
+# missing in dist, taken from https://github.com/freedesktop/xorg-xserver/blob/master/include/Xserver.d
+Source3: Xserver.d
Source10: %{name}-Xvfb.init
Source11: %{name}-Xvfb.sysconfig
Source12: xvfb-run.sh
@@ -419,6 +421,10 @@ Pliki wspólne dla serwerów X.
%patch6 -p1
+# missing file
+[ ! -f include/Xserver.d ] || exit 1
+cp -p %{SOURCE3} include/Xserver.d
+
# xserver uses pixman-1 API/ABI so put that explictly here
sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h