summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2010-10-21 16:57:07 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit85a312de7794fa470e1eccaf48438304c80045b5 (patch)
tree5a62c0134172b1257811d5c3cb6b4e39beadbc1d
parentf7fe37436187614b56f82ba09571d8b058aa561d (diff)
downloadsyncevolution-85a312de7794fa470e1eccaf48438304c80045b5.zip
syncevolution-85a312de7794fa470e1eccaf48438304c80045b5.tar.gz
- rel 2
- fixed unresolved symbols in lib - fixed duplicate files listing Changed files: syncevolution-link.patch -> 1.1 syncevolution.spec -> 1.19
-rw-r--r--syncevolution-link.patch40
-rw-r--r--syncevolution.spec28
2 files changed, 64 insertions, 4 deletions
diff --git a/syncevolution-link.patch b/syncevolution-link.patch
new file mode 100644
index 0000000..858d131
--- /dev/null
+++ b/syncevolution-link.patch
@@ -0,0 +1,40 @@
+--- syncevolution-1.0.1/src/synthesis/src/Makefile.am~ 2010-07-16 22:13:33.000000000 +0200
++++ syncevolution-1.0.1/src/synthesis/src/Makefile.am 2010-10-21 14:26:44.252436380 +0200
+@@ -77,8 +77,8 @@
+ $(LIBICAL_CFLAGS) \
+ $(LIBECAL_CFLAGS)
+ libsynthesis_la_CXXFLAGS = $(libsynthesis_la_CFLAGS)
+-libsynthesis_la_LIBADD = $(PCRE_LIBS) $(SQLITE3_LIBS) $(XMLPARSE_LIBS) $(LIBICAL_LIBS) $(LIBECAL_LIBS) libsmltk.la -lz
+-libsynthesis_la_LDFLAGS = -version-info $(ENGINE_CURRENT):$(ENGINE_REVISION):$(ENGINE_AGE) \
++libsynthesis_la_LIBADD = $(PCRE_LIBS) $(SQLITE3_LIBS) $(XMLPARSE_LIBS) $(LIBICAL_LIBS) $(LIBECAL_LIBS) libsmltk.la -lz -ldl
++libsynthesis_la_LDFLAGS = -pthread -version-info $(ENGINE_CURRENT):$(ENGINE_REVISION):$(ENGINE_AGE) \
+ -Wl,--version-script=$(srcdir)/synthesis-linker.map
+ libsynthesis_la_DEPENDENCIES = $(srcdir)/synthesis-linker.map libsmltk.la
+
+@@ -180,4 +180,4 @@
+ if COND_DOXYGEN
+ all: doxygen
+ clean-local: clean-doxygen
+-endif
+\ No newline at end of file
++endif
+--- syncevolution-1.0.1/src/synthesis/src/Makefile.am.in~ 2010-06-17 14:17:44.000000000 +0200
++++ syncevolution-1.0.1/src/synthesis/src/Makefile.am.in 2010-10-21 14:27:16.069436380 +0200
+@@ -77,8 +77,8 @@
+ $(LIBICAL_CFLAGS) \
+ $(LIBECAL_CFLAGS)
+ libsynthesis_la_CXXFLAGS = $(libsynthesis_la_CFLAGS)
+-libsynthesis_la_LIBADD = $(PCRE_LIBS) $(SQLITE3_LIBS) $(XMLPARSE_LIBS) $(LIBICAL_LIBS) $(LIBECAL_LIBS) libsmltk.la -lz
+-libsynthesis_la_LDFLAGS = -version-info $(ENGINE_CURRENT):$(ENGINE_REVISION):$(ENGINE_AGE) \
++libsynthesis_la_LIBADD = $(PCRE_LIBS) $(SQLITE3_LIBS) $(XMLPARSE_LIBS) $(LIBICAL_LIBS) $(LIBECAL_LIBS) libsmltk.la -lz -ldl
++libsynthesis_la_LDFLAGS = -pthread -version-info $(ENGINE_CURRENT):$(ENGINE_REVISION):$(ENGINE_AGE) \
+ -Wl,--version-script=$(srcdir)/synthesis-linker.map
+ libsynthesis_la_DEPENDENCIES = $(srcdir)/synthesis-linker.map libsmltk.la
+
+@@ -180,4 +180,4 @@
+ if COND_DOXYGEN
+ all: doxygen
+ clean-local: clean-doxygen
+-endif
+\ No newline at end of file
++endif
diff --git a/syncevolution.spec b/syncevolution.spec
index 0231442..9370c19 100644
--- a/syncevolution.spec
+++ b/syncevolution.spec
@@ -3,11 +3,12 @@ Summary: Synchronization for contacts and calendars for Evolution
Summary(pl.UTF-8): Synchronizacja kontaktów i kalendarzy dla Evolution
Name: syncevolution
Version: 1.0.1
-Release: 1
+Release: 2
License: GPL v2+ + OpenSSL exception
Group: Applications
Source0: http://downloads.syncevolution.org/syncevolution/sources/%{name}-%{version}.tar.gz
# Source0-md5: e8cc1293ea3b9beea501333fdba8cb7a
+Patch0: %{name}-link.patch
URL: http://www.estamos.de/projects/SyncML/SyncEvolution.html
BuildRequires: boost-devel >= 1.34
BuildRequires: curl-devel
@@ -75,9 +76,25 @@ Pliki nagłówkowe bibliotek Syncevolution.
%prep
%setup -q
+%patch0 -p1
%build
-%configure --enable-evolution-compatibility
+%{__libtoolize}
+%{__aclocal} -I m4 -I m4-repo
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd src/synthesis
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd ../..
+%configure \
+ --enable-shared \
+ --enable-evolution-compatibility
+
%{__make}
%install
@@ -106,13 +123,16 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_datadir}/syncevolution/templates/servers
%{_datadir}/syncevolution/templates/servers/*
%dir %{_datadir}/syncevolution/xml
-%dir %{_datadir}/syncevolution/xml/*
+%{_datadir}/syncevolution/xml/*.xml
+%attr(755,root,root) %{_datadir}/syncevolution/xml/*.pl
%dir %{_datadir}/syncevolution/xml/datatypes
%{_datadir}/syncevolution/xml/datatypes/*
%dir %{_datadir}/syncevolution/xml/debug
%{_datadir}/syncevolution/xml/debug/*
%dir %{_datadir}/syncevolution/xml/remoterules
-%{_datadir}/syncevolution/xml/remoterules/*
+%{_datadir}/syncevolution/xml/remoterules/*.xml
+%dir %{_datadir}/syncevolution/xml/remoterules/client
+%{_datadir}/syncevolution/xml/remoterules/client/*
%dir %{_datadir}/syncevolution/xml/remoterules/server
%{_datadir}/syncevolution/xml/remoterules/server/*
%dir %{_datadir}/syncevolution/xml/scripting