summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2015-03-01 19:00:26 (GMT)
committerJakub Bogusz2015-03-01 19:00:26 (GMT)
commit5fbf8ca6567d71b4aac29ebd3767b8a1b4b02481 (patch)
treee411b65348775b0cf13e9f3eec643c95dfccabb2
parent7352946bf2e0fea923fb7ea878c87d07b08735f4 (diff)
downloadsnappy-5fbf8ca6567d71b4aac29ebd3767b8a1b4b02481.zip
snappy-5fbf8ca6567d71b4aac29ebd3767b8a1b4b02481.tar.gz
- added gflags patch (update namespace from google:: to gflags::)
-rw-r--r--snappy-gflags.patch11
-rw-r--r--snappy.spec5
2 files changed, 15 insertions, 1 deletions
diff --git a/snappy-gflags.patch b/snappy-gflags.patch
new file mode 100644
index 0000000..4057382
--- /dev/null
+++ b/snappy-gflags.patch
@@ -0,0 +1,11 @@
+--- snappy-1.1.2/snappy-test.h.orig 1980-01-01 00:00:00.000000000 +0100
++++ snappy-1.1.2/snappy-test.h 2015-03-01 19:53:47.391152000 +0100
+@@ -89,7 +89,7 @@
+ // though, so we call it first and hope for the best.
+ #define InitGoogle(argv0, argc, argv, remove_flags) \
+ INIT_GTEST(argc, argv); \
+- google::ParseCommandLineFlags(argc, argv, remove_flags);
++ gflags::ParseCommandLineFlags(argc, argv, remove_flags);
+
+ #else
+
diff --git a/snappy.spec b/snappy.spec
index bfec591..9121cd6 100644
--- a/snappy.spec
+++ b/snappy.spec
@@ -8,13 +8,15 @@ Group: Libraries
# Temporary download link for Snappy 1.1.2: https://drive.google.com/file/d/0B0xs9kK-b5nMOWIxWGJhMXd6aGs/edit?usp=sharing
Source0: %{name}-%{version}.tar.gz
# Source0-md5: c9593f61693ca929777302324721cb94
+Patch0: %{name}-gflags.patch
URL: http://code.google.com/p/snappy/
BuildRequires: autoconf >= 2.50
BuildRequires: automake
+# for tests
+BuildRequires: gflags-devel
BuildRequires: libstdc++-devel
BuildRequires: libtool >= 2:2.0
BuildRequires: pkgconfig
-BuildConflicts: gflags-devel
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%description
@@ -89,6 +91,7 @@ Statyczna biblioteka Snappy.
%prep
%setup -q
+%patch0 -p1
%build
%{__libtoolize}