summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2014-01-22 19:33:50 (GMT)
committerJan Rękorajski2014-01-22 19:33:50 (GMT)
commitb9d7af7e6ed413660e8d490786a4b62460fb7bf9 (patch)
treea8f2f23ee6211f89983cc0ed5e6e016603e560fa
parentffd00be11458c462e1e060e3641e53704cbb5c68 (diff)
downloadsmartcardpp-master.zip
smartcardpp-master.tar.gz
- add missing include unistd.hHEADauto/th/smartcardpp-0.3.0-2master
- build with system getopt - rel 2
-rw-r--r--getopt.patch22
-rw-r--r--sleep.patch10
-rw-r--r--smartcardpp.spec6
3 files changed, 37 insertions, 1 deletions
diff --git a/getopt.patch b/getopt.patch
new file mode 100644
index 0000000..50a34cb
--- /dev/null
+++ b/getopt.patch
@@ -0,0 +1,22 @@
+--- smartcardpp-0.3.0/test.cpp~ 2011-10-12 20:24:16.000000000 +0200
++++ smartcardpp-0.3.0/test.cpp 2014-01-22 20:24:59.232357507 +0100
+@@ -14,7 +14,7 @@
+ #include <string>
+ #include <stdlib.h>
+ #include "smartcardpp.h"
+-#include "compat_getopt.h"
++#include <getopt.h>
+ #include "compat_getpass.h"
+
+ void validateOnPinpad();
+--- smartcardpp-0.3.0/CMakeLists.txt~ 2011-10-12 20:24:16.000000000 +0200
++++ smartcardpp-0.3.0/CMakeLists.txt 2014-01-22 20:25:16.819024046 +0100
+@@ -92,7 +92,7 @@
+ set_target_properties(smartcardpp PROPERTIES VERSION ${SMARTCARDPP_VERSION} SOVERSION 1)
+ install(TARGETS smartcardpp DESTINATION ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+-add_executable(card-test compat_getopt.c compat_getpass.c test.cpp)
++add_executable(card-test compat_getpass.c test.cpp)
+ target_link_libraries(card-test smartcardpp ${CMAKE_DL_LIBS})
+ install(TARGETS card-test DESTINATION ${BIN_INSTALL_DIR})
+
diff --git a/sleep.patch b/sleep.patch
new file mode 100644
index 0000000..115dd24
--- /dev/null
+++ b/sleep.patch
@@ -0,0 +1,10 @@
+--- smartcardpp-0.3.0/CardBase.cpp~ 2011-10-12 20:24:16.000000000 +0200
++++ smartcardpp-0.3.0/CardBase.cpp 2014-01-22 20:15:41.235694879 +0100
+@@ -15,6 +15,7 @@
+ #include "CardBase.h"
+ #include <algorithm>
+ #include <time.h>
++#include <unistd.h>
+ #include "helperMacro.h"
+ #ifdef WIN32
+ #include <Windows.h>
diff --git a/smartcardpp.spec b/smartcardpp.spec
index a735635..cc7ad6c 100644
--- a/smartcardpp.spec
+++ b/smartcardpp.spec
@@ -2,12 +2,14 @@ Summary: Library for accessing smart cards
Summary(pl.UTF-8): Biblioteka do dostępu do kart procesorowych
Name: smartcardpp
Version: 0.3.0
-Release: 1
+Release: 2
License: BSD
Group: Libraries
#Source0Download: http://code.google.com/p/esteid/downloads/list
Source0: http://esteid.googlecode.com/files/%{name}-%{version}.tar.bz2
# Source0-md5: c6172387475982393d02314f389f3513
+Patch0: sleep.patch
+Patch1: getopt.patch
URL: http://code.google.com/p/esteid/
BuildRequires: cmake >= 2.6
BuildRequires: libstdc++-devel
@@ -42,6 +44,8 @@ wykorzystujących bibliotekę smartcardpp.
%prep
%setup -q
+%patch0 -p1
+%patch1 -p1
%build
install -d build