summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2020-02-08 22:18:09 (GMT)
committerJakub Bogusz2020-02-08 22:18:09 (GMT)
commitf0345fc4114595e73001eb144d2a85dc5b87beae (patch)
tree99e7afd7da242d6c54f6f2f0ec823d9e9f0c3c80
parent13e58cc25322fac884034de296ef1792657fc6f2 (diff)
downloadsanlock-f0345fc4114595e73001eb144d2a85dc5b87beae.zip
sanlock-f0345fc4114595e73001eb144d2a85dc5b87beae.tar.gz
- updated to 3.8.0auto/th/sanlock-3.8.0-1
- updated init-pld patch - removed obsolete link patch
-rw-r--r--sanlock-init-pld.patch51
-rw-r--r--sanlock-link.patch11
-rw-r--r--sanlock.spec10
3 files changed, 29 insertions, 43 deletions
diff --git a/sanlock-init-pld.patch b/sanlock-init-pld.patch
index b8f2085..af310a4 100644
--- a/sanlock-init-pld.patch
+++ b/sanlock-init-pld.patch
@@ -1,14 +1,14 @@
---- sanlock-2.5/init.d/sanlock.orig 2012-09-30 10:16:54.308331928 +0200
-+++ sanlock-2.5/init.d/sanlock 2012-09-30 10:51:21.691622171 +0200
+--- sanlock-3.8.0/init.d/sanlock.orig 2020-02-08 22:16:26.415493120 +0100
++++ sanlock-3.8.0/init.d/sanlock 2020-02-08 22:25:28.369223771 +0100
@@ -32,95 +32,86 @@
[ -f /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog
start() {
- [ -x $exec ] || exit 5
-
-- if [ ! -d /var/run/$prog ]; then
-- install -d -o $SANLOCKUSER -g $SANLOCKUSER -m 775 /var/run/$prog
-- [ -x /sbin/restorecon ] && restorecon /var/run/$prog
+- if [ ! -d /run/$prog ]; then
+- install -d -o $SANLOCKUSER -g $SANLOCKUSER -m 775 /run/$prog
+- [ -x /sbin/restorecon ] && restorecon /run/$prog
+ # Check if the service is already running?
+ if [ -f /var/lock/subsys/sanlock ]; then
+ msg_already_running "sanlock"
@@ -132,9 +132,9 @@
esac
-exit $?
+exit $retval
---- sanlock-3.2.4/init.d/wdmd.orig 2015-09-10 17:23:16.258102320 +0200
-+++ sanlock-3.2.4/init.d/wdmd 2015-09-10 17:31:02.341416003 +0200
-@@ -42,114 +42,105 @@
+--- sanlock-3.8.0/init.d/wdmd.orig 2020-02-08 22:16:26.418826435 +0100
++++ sanlock-3.8.0/init.d/wdmd 2020-02-08 22:32:56.383463337 +0100
+@@ -42,114 +42,103 @@
retval=$?
if [ $retval -ne 0 ]; then
@@ -155,22 +155,22 @@
}
start() {
+- watchdog_check
+-
+- [ -x $exec ] || exit 5
+-
+- if [ ! -d /run/$prog ]; then
+- install -d -g $WDMDGROUP -m 775 /run/$prog
+- [ -x /sbin/restorecon ] && restorecon /run/$prog
+ # Check if the service is already running?
+ if [ -f $lockfile ]; then
+ msg_already_running "wdmd"
+ return
-+ fi
-+
- watchdog_check
-
- [ -x $exec ] || exit 5
+ fi
-- if [ ! -d /var/run/$prog ]; then
-- install -d -g $WDMDGROUP -m 775 /var/run/$prog
-- [ -x /sbin/restorecon ] && restorecon /var/run/$prog
-- fi
--
- echo -n $"Starting $prog: "
++ watchdog_check
++
+ msg_starting "wdmd"
daemon $prog $WDMDOPTS
retval=$?
@@ -283,20 +283,19 @@
esac
-exit $?
+exit $retval
---- sanlock-3.2.4/init.d/fence_sanlockd.orig 2015-06-19 18:26:03.000000000 +0200
-+++ sanlock-3.2.4/init.d/fence_sanlockd 2015-09-10 20:58:46.917559578 +0200
+--- sanlock-3.8.0/init.d/fence_sanlockd.orig 2019-06-12 21:07:38.000000000 +0200
++++ sanlock-3.8.0/init.d/fence_sanlockd 2020-02-08 22:34:27.129638389 +0100
@@ -33,42 +33,35 @@
[ -f /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog
start() {
- [ -x $exec ] || exit 5
--
+ # Check if the service is already running?
+ if [ -f /var/lock/subsys/sanlock ]; then
+ msg_already_running "sanlock"
+ return
+ fi
-+
+
# start wdmd and sanlock daemons if they aren't running
+ /etc/rc.d/init.d/wdmd status >/dev/null 2>&1 || /etc/rc.d/init.d/wdmd start
+ /etc/rc.d/init.d/sanlock status >/dev/null 2>&1 || /etc/rc.d/init.d/sanlock start
@@ -305,17 +304,17 @@
-
- service sanlock status > /dev/null 2>&1 || service sanlock start
-
-- [ ! -d /var/run/$prog ] && install -d -m 775 /var/run/$prog
+- [ ! -d /run/$prog ] && install -d -m 775 /run/$prog
-
-- [ ! -d /var/run/$agent ] && install -d -m 775 /var/run/$agent
+- [ ! -d /run/$agent ] && install -d -m 775 /run/$agent
-
- [ -n "$(which restorecon)" ] && \
- [ -x "$(which restorecon)" ] && \
-- restorecon /var/run/$prog
+- restorecon /run/$prog
-
- [ -n "$(which restorecon)" ] && \
- [ -x "$(which restorecon)" ] && \
-- restorecon /var/run/$agent
+- restorecon /run/$agent
-
- echo -n $"Starting $prog: "
+ msg_starting "$prog"
diff --git a/sanlock-link.patch b/sanlock-link.patch
deleted file mode 100644
index 3d657a8..0000000
--- a/sanlock-link.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sanlock-2.0/src/Makefile.orig 2012-03-02 22:13:24.000000000 +0100
-+++ sanlock-2.0/src/Makefile 2012-03-06 20:11:32.466180099 +0100
-@@ -84,7 +84,7 @@
- all: $(LIBSO_ENTIRE_TARGET) $(LIBSO_CLIENT_TARGET) $(CMD_TARGET)
-
- $(LIBSO_ENTIRE_TARGET): $(LIB_ENTIRE_SOURCE)
-- $(CC) $(CFLAGS) $(LIB_ENTIRE_LDFLAGS) -shared -fPIC -o $@ -Wl,-soname=$(LIB_ENTIRE_TARGET).so.$(SOMAJOR) $^
-+ $(CC) $(CFLAGS) $(LIB_ENTIRE_LDFLAGS) -shared -fPIC -o $@ -Wl,-soname=$(LIB_ENTIRE_TARGET).so.$(SOMAJOR) $^ -lblkid -laio -lrt
- ln -sf $(LIBSO_ENTIRE_TARGET) $(LIB_ENTIRE_TARGET).so
- ln -sf $(LIBSO_ENTIRE_TARGET) $(LIB_ENTIRE_TARGET).so.$(SOMAJOR)
-
diff --git a/sanlock.spec b/sanlock.spec
index 5c88258..cfc1b2a 100644
--- a/sanlock.spec
+++ b/sanlock.spec
@@ -1,14 +1,13 @@
Summary: Shared storage lock manager
Summary(pl.UTF-8): Zarządca blokad dla współdzielonego składowania danych
Name: sanlock
-Version: 3.6.0
+Version: 3.8.0
Release: 1
License: LGPL v2+ (libsanlock_client, libwdmd), GPL v2 (libsanlock, utilities)
Group: Networking
-Source0: http://releases.pagure.org/sanlock/%{name}-%{version}.tar.gz
-# Source0-md5: 6544fb7b180f4340c568ca6bd40c97c6
-Patch0: %{name}-link.patch
-Patch1: %{name}-init-pld.patch
+Source0: https://releases.pagure.org/sanlock/%{name}-%{version}.tar.gz
+# Source0-md5: 37975c995300f740fa9d42bc9ae94c75
+Patch0: %{name}-init-pld.patch
URL: https://pagure.io/sanlock
BuildRequires: gcc >= 5:3.4
BuildRequires: libaio-devel
@@ -111,7 +110,6 @@ Wiązanie Pythona do biblioteki sanlock.
%prep
%setup -q
%patch0 -p1
-%patch1 -p1
%build
export CFLAGS="%{rpmcflags}"