summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2015-08-25 12:24:16 (GMT)
committerElan Ruusamäe2015-08-25 12:24:35 (GMT)
commit3b7151f8aca4ceb5cdbce54af9ba2585e971a6c8 (patch)
tree8db28290158bb9b73e5023ff824c59362cb4d296
downloadruby-stud-3b7151f8aca4ceb5cdbce54af9ba2585e971a6c8.zip
ruby-stud-3b7151f8aca4ceb5cdbce54af9ba2585e971a6c8.tar.gz
new, version 0.0.21auto/th/ruby-stud-0.0.21-1
-rw-r--r--ruby-stud.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/ruby-stud.spec b/ruby-stud.spec
new file mode 100644
index 0000000..478446e
--- /dev/null
+++ b/ruby-stud.spec
@@ -0,0 +1,47 @@
+#
+# Conditional build:
+%bcond_without tests # build without tests
+
+%define pkgname stud
+Summary: stud - common code techniques
+Name: ruby-%{pkgname}
+Version: 0.0.21
+Release: 1
+License: GPL v2+ or Ruby
+Group: Development/Languages
+Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
+# Source0-md5: 3439c86e911782f21921ca2fc8c9c268
+URL: https://github.com/jordansissel/ruby-stud
+BuildRequires: rpm-rubyprov
+BuildRequires: rpmbuild(macros) >= 1.656
+%if %{with tests}
+BuildRequires: ruby-insist
+BuildRequires: ruby-rspec
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Small reusable bits of code I'm tired of writing over and over. A
+library form of my software-patterns Github repo.
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+
+%build
+# write .gemspec
+%__gem_helper spec
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
+cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
+cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{ruby_vendorlibdir}/%{pkgname}
+%{ruby_specdir}/%{pkgname}-%{version}.gemspec