summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2015-09-02 09:56:26 (GMT)
committerElan Ruusamäe2015-09-02 09:56:26 (GMT)
commitb8422c7be3b597bce9d1425767aad78bdbca67ca (patch)
tree754985479704e30cb6d91981dd985774e4222594
downloadruby-peach-b8422c7be3b597bce9d1425767aad78bdbca67ca.zip
ruby-peach-b8422c7be3b597bce9d1425767aad78bdbca67ca.tar.gz
-rw-r--r--ruby-peach.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/ruby-peach.spec b/ruby-peach.spec
new file mode 100644
index 0000000..8d1f1b3
--- /dev/null
+++ b/ruby-peach.spec
@@ -0,0 +1,47 @@
+#
+# Conditional build:
+%bcond_with tests # build without tests
+
+%define pkgname peach
+Summary: Parallel Each and other parallel things
+Name: ruby-%{pkgname}
+Version: 0.5.1
+Release: 1
+License: GPL v2+ or Ruby
+Group: Development/Languages
+Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
+# Source0-md5: 32e7ecd314f0b7448a5e2c0cb80cb0dc
+URL: http://peach.rubyforge.org
+BuildRequires: rpm-rubyprov
+BuildRequires: rpmbuild(macros) >= 1.656
+%if %{with tests}
+BuildRequires: ruby-rake
+BuildRequires: ruby-shoulda
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Parallel Each and other parallel things.
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+
+%build
+# write .gemspec
+%__gem_helper spec
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
+cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
+cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{ruby_vendorlibdir}/%{pkgname}.rb
+%{ruby_vendorlibdir}/%{pkgname}
+%{ruby_specdir}/%{pkgname}-%{version}.gemspec