summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraredridel2006-11-04 19:11:59 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitf005d749d76d10d956c1f1432f15c8aa9e5767e1 (patch)
treec3ac6873cb5c354f88d5d6c6e3813acfa2dcc66c
downloadruby-mime-types-f005d749d76d10d956c1f1432f15c8aa9e5767e1.zip
ruby-mime-types-f005d749d76d10d956c1f1432f15c8aa9e5767e1.tar.gz
- addedAC-branch
Changed files: ruby-mime-types.spec -> 1.1
-rw-r--r--ruby-mime-types.spec50
1 files changed, 50 insertions, 0 deletions
diff --git a/ruby-mime-types.spec b/ruby-mime-types.spec
new file mode 100644
index 0000000..3018094
--- /dev/null
+++ b/ruby-mime-types.spec
@@ -0,0 +1,50 @@
+Summary: MIME::Types for Ruby
+Name: ruby-mime-types
+Version: 1.13.1
+Release: 1
+License: Ruby's, Artistic or GPLv2+
+Group: Development/Languages
+Source0: http://raa.ruby-lang.org/cache/mime-types/mime-types-1.13.1.tar.gz
+# Source0-md5: 49fb7abf6730ebae1e32fc2d8ccc928e
+URL: http://raa.ruby-lang.org/project/mime-types/
+BuildRequires: rpmbuild(macros) >= 1.277
+BuildRequires: setup.rb = 3.3.1
+#BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+MIME::Types provides the ability for detailed information about MIME entities to be determined and used programmatically.
+
+This is largely based on Perl MIME::Types 1.13. Please see the main documentation for more information.
+
+%prep
+%setup -q -n mime-types-%{version}
+cp %{_datadir}/setup.rb .
+
+%build
+ruby setup.rb config \
+ --rbdir=%{ruby_rubylibdir} \
+ --sodir=%{ruby_archdir}
+
+ruby setup.rb setup
+
+rdoc --op rdoc lib
+rdoc --ri --op ri lib
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{ruby_archdir},%{ruby_ridir}}
+
+ruby setup.rb install \
+ --prefix=$RPM_BUILD_ROOT
+
+cp -a ri/ri/* $RPM_BUILD_ROOT%{ruby_ridir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc rdoc
+%{ruby_rubylibdir}/*
+%{ruby_ridir}/*