summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2013-04-25 19:11:25 (GMT)
committerElan Ruusamäe2013-04-25 19:12:05 (GMT)
commit153867effaec19098f1c62eb5469b89bce9b65c5 (patch)
treedb865440859727474b419fde9140f2baa50a3a9f
downloadruby-colored-master.zip
ruby-colored-master.tar.gz
new, version 1.2HEADmaster
based on fedora rubygem-colored package 0f8b26f3c3b5e23b124da54cb20d30c7cc2e6845
-rw-r--r--ruby-colored.spec54
1 files changed, 54 insertions, 0 deletions
diff --git a/ruby-colored.spec b/ruby-colored.spec
new file mode 100644
index 0000000..ff4f827
--- /dev/null
+++ b/ruby-colored.spec
@@ -0,0 +1,54 @@
+#
+# Conditional build:
+%bcond_without tests # build without tests
+
+%define gem_name colored
+Summary: Extends ruby string class in order to colorize terminal output
+Name: ruby-%{gem_name}
+Version: 1.2
+Release: 1
+License: MIT
+Group: Development/Languages
+Source0: http://rubygems.org/gems/%{gem_name}-%{version}.gem
+# Source0-md5: 1b1a0f16f7c6ab57d1a2d6de53b13c42
+URL: http://github.com/defunkt/colored
+BuildRequires: rpm-rubyprov
+BuildRequires: rpmbuild(macros) >= 1.656
+%if %{with tests}
+BuildRequires: ruby-minitest
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Rubygem extending the ruby string class to include methods that
+generates colored terminal output.
+
+%package doc
+Summary: Documentation for %{name}
+Group: Documentation
+Requires: %{name} = %{version}-%{release}
+
+%description doc
+Documentation for %{name}
+
+%prep
+%setup -q -n %{gem_name}-%{version}
+
+%build
+%if %{with tests}
+testrb -Ilib test/colored_test.rb
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{ruby_vendorlibdir}
+cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README LICENSE
+%{ruby_vendorlibdir}/colored.rb