summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2010-02-28 17:33:55 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit85e61527d22dc913d0d1a1fe0a3dfec881a64e6f (patch)
tree393283ff324e9c081c8dcd648e414d31d3220283
parentb1b59f08cafaa98ecee2be1fa8f4905dd2b005af (diff)
downloadruby-activerecord-85e61527d22dc913d0d1a1fe0a3dfec881a64e6f.zip
ruby-activerecord-85e61527d22dc913d0d1a1fe0a3dfec881a64e6f.tar.gz
- updated to 2.3.5
Changed files: ruby-activerecord-rubygems.patch -> 1.2 ruby-activerecord.spec -> 1.42
-rw-r--r--ruby-activerecord-rubygems.patch30
-rw-r--r--ruby-activerecord.spec15
2 files changed, 20 insertions, 25 deletions
diff --git a/ruby-activerecord-rubygems.patch b/ruby-activerecord-rubygems.patch
index ed99964..a5b8a9c 100644
--- a/ruby-activerecord-rubygems.patch
+++ b/ruby-activerecord-rubygems.patch
@@ -1,25 +1,21 @@
-diff -Nur activerecord-2.1.0.orig/lib/active_record.rb activerecord-2.1.0.rubygems/lib/active_record.rb
---- activerecord-2.1.0.orig/lib/active_record.rb 2008-05-31 19:52:51.000000000 -0600
-+++ activerecord-2.1.0.rubygems/lib/active_record.rb 2008-08-29 17:02:32.000000000 -0600
-@@ -21,20 +21,7 @@
+diff --git a/lib/active_record.rb b/lib/active_record.rb
+index 2f8c5c7..424faeb 100644
+--- a/lib/active_record.rb
++++ b/lib/active_record.rb
+@@ -21,15 +21,7 @@
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
#++
--$:.unshift(File.dirname(__FILE__)) unless
-- $:.include?(File.dirname(__FILE__)) || $:.include?(File.expand_path(File.dirname(__FILE__)))
--
--unless defined? ActiveSupport
-- active_support_path = File.dirname(__FILE__) + "/../../activesupport/lib"
-- if File.exist?(active_support_path)
-- $:.unshift active_support_path
-- require 'active_support'
-- else
-- require 'rubygems'
-- gem 'activesupport'
+-begin
+- require 'active_support'
+-rescue LoadError
+- activesupport_path = "#{File.dirname(__FILE__)}/../../activesupport/lib"
+- if File.directory?(activesupport_path)
+- $:.unshift activesupport_path
- require 'active_support'
- end
-end
+require 'active_support'
- require 'active_record/base'
- require 'active_record/named_scope'
+ module ActiveRecord
+ # TODO: Review explicit loads to see if they will automatically be handled by the initilizer.
diff --git a/ruby-activerecord.spec b/ruby-activerecord.spec
index da61147..ea31ab3 100644
--- a/ruby-activerecord.spec
+++ b/ruby-activerecord.spec
@@ -5,14 +5,13 @@
Summary: Object-Relational mapping library for Ruby
Summary(pl.UTF-8): Biblioteka odwzorowań obiektowo-relacyjnych dla Ruby
Name: ruby-%{pkgname}
-Version: 2.0.5
+Version: 2.3.5
Release: 1
License: Ruby-alike
Group: Development/Languages
-Source0: http://rubyforge.org/frs/download.php/45356/%{pkgname}-%{version}.tgz
-# Source0-md5: 66f03d75467fdf589daa59a93ff84001
-Patch0: %{name}-sqlitethreads.patch
-Patch1: %{name}-rubygems.patch
+Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
+# Source0-md5: 48a9ab7fbac97478fac9722fb5e14cda
+Patch0: %{name}-rubygems.patch
URL: http://rubyforge.org/projects/activerecord/
BuildRequires: rpmbuild(macros) >= 1.277
BuildRequires: ruby >= 1:1.8.6
@@ -48,10 +47,10 @@ Documentation files for ActiveRecord.
Dokumentacja do biblioteki ActiveRecord.
%prep
-%setup -q -n activerecord-%{version}
+%setup -q -c
+%{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
+find -newer README -o -print | xargs touch --reference %{SOURCE0}
%patch0 -p1
-%patch1 -p1
-rm -r lib/active_record/vendor
# cleanup backups after patching
find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f