summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2003-04-19 22:00:32 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit97d076c117153841bc33880045ea1f707265f04d (patch)
tree9f8e8d1465d74e10aaef4bd930b54d656ad4203c
parent92c3f7a8e36e23fbd18963ad8b95c6bba5f1ad7b (diff)
downloadrat-97d076c117153841bc33880045ea1f707265f04d.zip
rat-97d076c117153841bc33880045ea1f707265f04d.tar.gz
- updated to 4.2.23 (ucl-common 1.2.13)
- added common-shared patch - build ucl-common as shared library - added acfix and alsa patches, link alsa dynamically, allow building w/o alsa - missing dirs Changed files: rat-acfix.patch -> 1.1 rat-alsa.patch -> 1.1 rat-common-shared.patch -> 1.1 rat.spec -> 1.34
-rw-r--r--rat-acfix.patch65
-rw-r--r--rat-alsa.patch22
-rw-r--r--rat-common-shared.patch324
-rw-r--r--rat.spec121
4 files changed, 501 insertions, 31 deletions
diff --git a/rat-acfix.patch b/rat-acfix.patch
new file mode 100644
index 0000000..cac3a60
--- /dev/null
+++ b/rat-acfix.patch
@@ -0,0 +1,65 @@
+--- rat-4.2.23/common/configure.in.orig 2003-04-19 22:54:58.000000000 +0200
++++ rat-4.2.23/common/configure.in 2003-04-19 22:58:40.000000000 +0200
+@@ -205,7 +205,7 @@
+ case $i in
+ inria)
+ dnl http://www.kame.net/
+- AC_EGREP_CPP(yes, [dnl
++ AC_EGREP_CPP(yes, [
+ #include <netinet/in.h>
+ #ifdef IPV6_INRIA_VERSION
+ yes
+@@ -215,7 +215,7 @@
+ ;;
+ kame)
+ dnl http://www.kame.net/
+- AC_EGREP_CPP(yes, [dnl
++ AC_EGREP_CPP(yes, [
+ #include <netinet/in.h>
+ #ifdef __KAME__
+ yes
+@@ -233,7 +233,7 @@
+ ;;
+ linux-glibc)
+ dnl http://www.v6.linux.or.jp/
+- AC_EGREP_CPP(yes, [dnl
++ AC_EGREP_CPP(yes, [
+ #include <features.h>
+ #if defined(__GLIBC__) && __GLIBC__ >= 2 && __GLIBC_MINOR__ >= 1
+ yes
+@@ -252,7 +252,7 @@
+ fi
+ ;;
+ toshiba)
+- AC_EGREP_CPP(yes, [dnl
++ AC_EGREP_CPP(yes, [
+ #include <sys/param.h>
+ #ifdef _TOSHIBA_INET6
+ yes
+@@ -263,7 +263,7 @@
+ CFLAGS="-DINET6 $CFLAGS"])
+ ;;
+ v6d)
+- AC_EGREP_CPP(yes, [dnl
++ AC_EGREP_CPP(yes, [
+ #include </usr/local/v6/include/sys/v6config.h>
+ #ifdef __V6D__
+ yes
+@@ -274,7 +274,7 @@
+ CFLAGS="-I/usr/local/v6/include $CFLAGS"])
+ ;;
+ zeta)
+- AC_EGREP_CPP(yes, [dnl
++ AC_EGREP_CPP(yes, [
+ #include <sys/param.h>
+ #ifdef _ZETA_MINAMI_INET6
+ yes
+--- rat-4.2.23/rat/configure.in.orig 2003-04-19 23:09:24.000000000 +0200
++++ rat-4.2.23/rat/configure.in 2003-04-19 23:15:56.000000000 +0200
+@@ -627,3 +627,6 @@
+ #------------------------------------------------------------------------------
+ AC_OUTPUT(Makefile)
+
++m4_pattern_allow(AU_INC)
++m4_pattern_allow(AU_LIB)
++m4_pattern_allow(AU_OBJ)
diff --git a/rat-alsa.patch b/rat-alsa.patch
new file mode 100644
index 0000000..c675964
--- /dev/null
+++ b/rat-alsa.patch
@@ -0,0 +1,22 @@
+--- rat-4.2.23/rat/configure.in.orig 2003-04-19 22:59:24.000000000 +0200
++++ rat-4.2.23/rat/configure.in 2003-04-19 23:08:06.000000000 +0200
+@@ -186,14 +186,18 @@
+ ],AC_MSG_RESULT(missing))
+ ])
+ # Do we have ALSA?
++ AC_ARG_WITH(alsa, [AC_HELP_STRING([--without-alsa],[disable ALSA])],
++ [with_alsa="$withval"], [with_alsa=yes])
++ if test "$with_alsa" != "no"; then
+ AC_CHECK_HEADER(sys/asoundlib.h,[
+ AU_OBJ="$AU_OBJ auddev_alsa.o"
+- AU_LIB="$AU_LIB /usr/lib/libasound.a"
++ AU_LIB="$AU_LIB -lasound"
+ AC_DEFINE(HAVE_ALSA_AUDIO)
+ # HAVE_OSS_AUDIO is defined so that the ALSA OSS emulation
+ # works for those cards which are not supported natively
+ AC_DEFINE(HAVE_OSS_AUDIO)
+ ])
++ fi
+ # Default is to use OSS drivers...
+ AU_OBJ="$AU_OBJ auddev_oss.o"
+ AC_CHECK_HEADERS(sys/soundcard.h soundcard.h)
diff --git a/rat-common-shared.patch b/rat-common-shared.patch
new file mode 100644
index 0000000..a2981c6
--- /dev/null
+++ b/rat-common-shared.patch
@@ -0,0 +1,324 @@
+diff -Nur rat-4.2.23/common.orig/configure.in rat-4.2.23/common/configure.in
+--- rat-4.2.23/common.orig/configure.in 2003-04-02 13:03:12.000000000 +0200
++++ rat-4.2.23/common/configure.in 2003-04-19 22:47:39.000000000 +0200
+@@ -6,7 +6,8 @@
+
+ AC_PROG_CC
+ AC_PROG_CPP
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
++AC_PROG_INSTALL
+
+ AC_HEADER_STDC
+ AC_HEADER_SYS_WAIT
+@@ -109,7 +110,7 @@
+ if test $ucl_cv_inet_pton_in_inet_h = "no"
+ then
+ AC_DEFINE(NEED_INET_PTON)
+- LIBOBJS="$LIBOBJS inet_pton.o"
++ AC_LIBOBJ([inet_pton])
+ fi
+ AC_CACHE_CHECK(for inet_ntop in <arpa/inet.h>, ucl_cv_inet_ntop_in_inet_h,
+ AC_EGREP_HEADER(uint16_t,
+@@ -119,11 +120,10 @@
+ if test $ucl_cv_inet_ntop_in_inet_h = "no"
+ then
+ AC_DEFINE(NEED_INET_NTOP)
+- LIBOBJS="$LIBOBJS inet_ntop.o"
++ AC_LIBOBJ([inet_ntop])
+ else
+ AC_DEFINE(HAVE_INET_NTOP)
+ fi
+-AC_SUBST(LIBOBJS)
+
+ dnl AC_REPLACE_FUNCS(inet_pton inet_ntop)
+
+diff -Nur rat-4.2.23/common.orig/examples/rtp/Makefile.in rat-4.2.23/common/examples/rtp/Makefile.in
+--- rat-4.2.23/common.orig/examples/rtp/Makefile.in 2001-04-04 15:36:36.000000000 +0200
++++ rat-4.2.23/common/examples/rtp/Makefile.in 2003-04-19 22:49:44.000000000 +0200
+@@ -11,8 +11,10 @@
+
+ DEFS = @DEFS@
+ CFLAGS = @CFLAGS@ $(DEFS) -I$(CSRC)
+-LIBS = @LIBS@ -L$(CSRC) -l$(LNAME)
++LIBS = @LIBS@ $(CSRC)/lib$(LNAME).la
+ CC = @CC@
++LIBTOOL= @LIBTOOL@
++top_builddir = ../..
+
+ TARGET = rtpdemo
+ OBJS = rtpdemo.o
+@@ -20,17 +22,17 @@
+
+ all: $(TARGET)
+
+-rtpdemo: $(OBJS) $(CSRC)/lib$(LNAME).a
+- $(CC) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
++rtpdemo: $(OBJS) $(CSRC)/lib$(LNAME).la
++ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ .c.o:
+ $(CC) $(CFLAGS) $(INC) -c $<
+
+-$(CSRC)/lib$(LNAME).a:
++$(CSRC)/lib$(LNAME).la:
+ cd $(CSRC) && $(MAKE)
+
+ clean:
+ -rm -f $(OBJS) $(TARGET)
+
+ distclean: clean
+- -rm -f Makefile
+\ No newline at end of file
++ -rm -f Makefile
+diff -Nur rat-4.2.23/common.orig/src/boxes-fst.dat rat-4.2.23/common/src/boxes-fst.dat
+--- rat-4.2.23/common.orig/src/boxes-fst.dat 2001-04-27 02:36:23.000000000 +0200
++++ rat-4.2.23/common/src/boxes-fst.dat 2003-04-19 22:50:49.000000000 +0200
+@@ -1,4 +1,4 @@
+-word8 S[256] = {
++static word8 S[256] = {
+ 99, 124, 119, 123, 242, 107, 111, 197, 48, 1, 103, 43, 254, 215, 171, 118,
+ 202, 130, 201, 125, 250, 89, 71, 240, 173, 212, 162, 175, 156, 164, 114, 192,
+ 183, 253, 147, 38, 54, 63, 247, 204, 52, 165, 229, 241, 113, 216, 49, 21,
+@@ -17,8 +17,8 @@
+ 140, 161, 137, 13, 191, 230, 66, 104, 65, 153, 45, 15, 176, 84, 187, 22
+ };
+
+-#ifdef INTERMEDIATE_VALUE_KAT
+-word8 Si[256] = {
++#ifdef INTERMEDIATE_VALUE_KAT
++static word8 Si[256] = {
+ 82, 9, 106, 213, 48, 54, 165, 56, 191, 64, 163, 158, 129, 243, 215, 251,
+ 124, 227, 57, 130, 155, 47, 255, 135, 52, 142, 67, 68, 196, 222, 233, 203,
+ 84, 123, 148, 50, 166, 194, 35, 61, 238, 76, 149, 11, 66, 250, 195, 78,
+@@ -36,9 +36,9 @@
+ 160, 224, 59, 77, 174, 42, 245, 176, 200, 235, 187, 60, 131, 83, 153, 97,
+ 23, 43, 4, 126, 186, 119, 214, 38, 225, 105, 20, 99, 85, 33, 12, 125
+ };
+-#endif /* INTERMEDIATE_VALUE_KAT */
++#endif /* INTERMEDIATE_VALUE_KAT */
+
+-word8 T1[256][4] = {
++static word8 T1[256][4] = {
+ {0xc6,0x63,0x63,0xa5}, {0xf8,0x7c,0x7c,0x84}, {0xee,0x77,0x77,0x99}, {0xf6,0x7b,0x7b,0x8d},
+ {0xff,0xf2,0xf2,0x0d}, {0xd6,0x6b,0x6b,0xbd}, {0xde,0x6f,0x6f,0xb1}, {0x91,0xc5,0xc5,0x54},
+ {0x60,0x30,0x30,0x50}, {0x02,0x01,0x01,0x03}, {0xce,0x67,0x67,0xa9}, {0x56,0x2b,0x2b,0x7d},
+@@ -105,7 +105,7 @@
+ {0x7b,0xb0,0xb0,0xcb}, {0xa8,0x54,0x54,0xfc}, {0x6d,0xbb,0xbb,0xd6}, {0x2c,0x16,0x16,0x3a}
+ };
+
+-word8 T2[256][4] = {
++static word8 T2[256][4] = {
+ {0xa5,0xc6,0x63,0x63}, {0x84,0xf8,0x7c,0x7c}, {0x99,0xee,0x77,0x77}, {0x8d,0xf6,0x7b,0x7b},
+ {0x0d,0xff,0xf2,0xf2}, {0xbd,0xd6,0x6b,0x6b}, {0xb1,0xde,0x6f,0x6f}, {0x54,0x91,0xc5,0xc5},
+ {0x50,0x60,0x30,0x30}, {0x03,0x02,0x01,0x01}, {0xa9,0xce,0x67,0x67}, {0x7d,0x56,0x2b,0x2b},
+@@ -172,7 +172,7 @@
+ {0xcb,0x7b,0xb0,0xb0}, {0xfc,0xa8,0x54,0x54}, {0xd6,0x6d,0xbb,0xbb}, {0x3a,0x2c,0x16,0x16}
+ };
+
+-word8 T3[256][4] = {
++static word8 T3[256][4] = {
+ {0x63,0xa5,0xc6,0x63}, {0x7c,0x84,0xf8,0x7c}, {0x77,0x99,0xee,0x77}, {0x7b,0x8d,0xf6,0x7b},
+ {0xf2,0x0d,0xff,0xf2}, {0x6b,0xbd,0xd6,0x6b}, {0x6f,0xb1,0xde,0x6f}, {0xc5,0x54,0x91,0xc5},
+ {0x30,0x50,0x60,0x30}, {0x01,0x03,0x02,0x01}, {0x67,0xa9,0xce,0x67}, {0x2b,0x7d,0x56,0x2b},
+@@ -239,7 +239,7 @@
+ {0xb0,0xcb,0x7b,0xb0}, {0x54,0xfc,0xa8,0x54}, {0xbb,0xd6,0x6d,0xbb}, {0x16,0x3a,0x2c,0x16}
+ };
+
+-word8 T4[256][4] = {
++static word8 T4[256][4] = {
+ {0x63,0x63,0xa5,0xc6}, {0x7c,0x7c,0x84,0xf8}, {0x77,0x77,0x99,0xee}, {0x7b,0x7b,0x8d,0xf6},
+ {0xf2,0xf2,0x0d,0xff}, {0x6b,0x6b,0xbd,0xd6}, {0x6f,0x6f,0xb1,0xde}, {0xc5,0xc5,0x54,0x91},
+ {0x30,0x30,0x50,0x60}, {0x01,0x01,0x03,0x02}, {0x67,0x67,0xa9,0xce}, {0x2b,0x2b,0x7d,0x56},
+@@ -306,7 +306,7 @@
+ {0xb0,0xb0,0xcb,0x7b}, {0x54,0x54,0xfc,0xa8}, {0xbb,0xbb,0xd6,0x6d}, {0x16,0x16,0x3a,0x2c},
+ };
+
+-word8 T5[256][4] = {
++static word8 T5[256][4] = {
+ {0x51,0xf4,0xa7,0x50}, {0x7e,0x41,0x65,0x53}, {0x1a,0x17,0xa4,0xc3}, {0x3a,0x27,0x5e,0x96},
+ {0x3b,0xab,0x6b,0xcb}, {0x1f,0x9d,0x45,0xf1}, {0xac,0xfa,0x58,0xab}, {0x4b,0xe3,0x03,0x93},
+ {0x20,0x30,0xfa,0x55}, {0xad,0x76,0x6d,0xf6}, {0x88,0xcc,0x76,0x91}, {0xf5,0x02,0x4c,0x25},
+@@ -373,7 +373,7 @@
+ {0x7b,0xcb,0x84,0x61}, {0xd5,0x32,0xb6,0x70}, {0x48,0x6c,0x5c,0x74}, {0xd0,0xb8,0x57,0x42}
+ };
+
+-word8 T6[256][4] = {
++static word8 T6[256][4] = {
+ {0x50,0x51,0xf4,0xa7}, {0x53,0x7e,0x41,0x65}, {0xc3,0x1a,0x17,0xa4}, {0x96,0x3a,0x27,0x5e},
+ {0xcb,0x3b,0xab,0x6b}, {0xf1,0x1f,0x9d,0x45}, {0xab,0xac,0xfa,0x58}, {0x93,0x4b,0xe3,0x03},
+ {0x55,0x20,0x30,0xfa}, {0xf6,0xad,0x76,0x6d}, {0x91,0x88,0xcc,0x76}, {0x25,0xf5,0x02,0x4c},
+@@ -440,7 +440,7 @@
+ {0x61,0x7b,0xcb,0x84}, {0x70,0xd5,0x32,0xb6}, {0x74,0x48,0x6c,0x5c}, {0x42,0xd0,0xb8,0x57},
+ };
+
+-word8 T7[256][4] = {
++static word8 T7[256][4] = {
+ {0xa7,0x50,0x51,0xf4}, {0x65,0x53,0x7e,0x41}, {0xa4,0xc3,0x1a,0x17}, {0x5e,0x96,0x3a,0x27},
+ {0x6b,0xcb,0x3b,0xab}, {0x45,0xf1,0x1f,0x9d}, {0x58,0xab,0xac,0xfa}, {0x03,0x93,0x4b,0xe3},
+ {0xfa,0x55,0x20,0x30}, {0x6d,0xf6,0xad,0x76}, {0x76,0x91,0x88,0xcc}, {0x4c,0x25,0xf5,0x02},
+@@ -507,7 +507,7 @@
+ {0x84,0x61,0x7b,0xcb}, {0xb6,0x70,0xd5,0x32}, {0x5c,0x74,0x48,0x6c}, {0x57,0x42,0xd0,0xb8},
+ };
+
+-word8 T8[256][4] = {
++static word8 T8[256][4] = {
+ {0xf4,0xa7,0x50,0x51}, {0x41,0x65,0x53,0x7e}, {0x17,0xa4,0xc3,0x1a}, {0x27,0x5e,0x96,0x3a},
+ {0xab,0x6b,0xcb,0x3b}, {0x9d,0x45,0xf1,0x1f}, {0xfa,0x58,0xab,0xac}, {0xe3,0x03,0x93,0x4b},
+ {0x30,0xfa,0x55,0x20}, {0x76,0x6d,0xf6,0xad}, {0xcc,0x76,0x91,0x88}, {0x02,0x4c,0x25,0xf5},
+@@ -574,7 +574,7 @@
+ {0xcb,0x84,0x61,0x7b}, {0x32,0xb6,0x70,0xd5}, {0x6c,0x5c,0x74,0x48}, {0xb8,0x57,0x42,0xd0},
+ };
+
+-word8 S5[256] = {
++static word8 S5[256] = {
+ 0x52,0x09,0x6a,0xd5,
+ 0x30,0x36,0xa5,0x38,
+ 0xbf,0x40,0xa3,0x9e,
+@@ -641,7 +641,7 @@
+ 0x55,0x21,0x0c,0x7d
+ };
+
+-word8 U1[256][4] = {
++static word8 U1[256][4] = {
+ {0x00,0x00,0x00,0x00}, {0x0e,0x09,0x0d,0x0b}, {0x1c,0x12,0x1a,0x16}, {0x12,0x1b,0x17,0x1d},
+ {0x38,0x24,0x34,0x2c}, {0x36,0x2d,0x39,0x27}, {0x24,0x36,0x2e,0x3a}, {0x2a,0x3f,0x23,0x31},
+ {0x70,0x48,0x68,0x58}, {0x7e,0x41,0x65,0x53}, {0x6c,0x5a,0x72,0x4e}, {0x62,0x53,0x7f,0x45},
+@@ -708,7 +708,7 @@
+ {0x9f,0x5d,0x80,0xbe}, {0x91,0x54,0x8d,0xb5}, {0x83,0x4f,0x9a,0xa8}, {0x8d,0x46,0x97,0xa3}
+ };
+
+-word8 U2[256][4] = {
++static word8 U2[256][4] = {
+ {0x00,0x00,0x00,0x00}, {0x0b,0x0e,0x09,0x0d}, {0x16,0x1c,0x12,0x1a}, {0x1d,0x12,0x1b,0x17},
+ {0x2c,0x38,0x24,0x34}, {0x27,0x36,0x2d,0x39}, {0x3a,0x24,0x36,0x2e}, {0x31,0x2a,0x3f,0x23},
+ {0x58,0x70,0x48,0x68}, {0x53,0x7e,0x41,0x65}, {0x4e,0x6c,0x5a,0x72}, {0x45,0x62,0x53,0x7f},
+@@ -775,7 +775,7 @@
+ {0xbe,0x9f,0x5d,0x80}, {0xb5,0x91,0x54,0x8d}, {0xa8,0x83,0x4f,0x9a}, {0xa3,0x8d,0x46,0x97}
+ };
+
+-word8 U3[256][4] = {
++static word8 U3[256][4] = {
+ {0x00,0x00,0x00,0x00}, {0x0d,0x0b,0x0e,0x09}, {0x1a,0x16,0x1c,0x12}, {0x17,0x1d,0x12,0x1b},
+ {0x34,0x2c,0x38,0x24}, {0x39,0x27,0x36,0x2d}, {0x2e,0x3a,0x24,0x36}, {0x23,0x31,0x2a,0x3f},
+ {0x68,0x58,0x70,0x48}, {0x65,0x53,0x7e,0x41}, {0x72,0x4e,0x6c,0x5a}, {0x7f,0x45,0x62,0x53},
+@@ -842,7 +842,7 @@
+ {0x80,0xbe,0x9f,0x5d}, {0x8d,0xb5,0x91,0x54}, {0x9a,0xa8,0x83,0x4f}, {0x97,0xa3,0x8d,0x46}
+ };
+
+-word8 U4[256][4] = {
++static word8 U4[256][4] = {
+ {0x00,0x00,0x00,0x00}, {0x09,0x0d,0x0b,0x0e}, {0x12,0x1a,0x16,0x1c}, {0x1b,0x17,0x1d,0x12},
+ {0x24,0x34,0x2c,0x38}, {0x2d,0x39,0x27,0x36}, {0x36,0x2e,0x3a,0x24}, {0x3f,0x23,0x31,0x2a},
+ {0x48,0x68,0x58,0x70}, {0x41,0x65,0x53,0x7e}, {0x5a,0x72,0x4e,0x6c}, {0x53,0x7f,0x45,0x62},
+@@ -909,6 +909,6 @@
+ {0x5d,0x80,0xbe,0x9f}, {0x54,0x8d,0xb5,0x91}, {0x4f,0x9a,0xa8,0x83}, {0x46,0x97,0xa3,0x8d}
+ };
+
+-word32 rcon[30] = {
++static word32 rcon[30] = {
+ 0x01,0x02, 0x04, 0x08, 0x10, 0x20, 0x40, 0x80, 0x1b, 0x36, 0x6c, 0xd8, 0xab, 0x4d, 0x9a, 0x2f, 0x5e, 0xbc, 0x63, 0xc6, 0x97, 0x35, 0x6a, 0xd4, 0xb3, 0x7d, 0xfa, 0xef, 0xc5, 0x91
+ };
+diff -Nur rat-4.2.23/common.orig/src/Makefile.in rat-4.2.23/common/src/Makefile.in
+--- rat-4.2.23/common.orig/src/Makefile.in 2001-04-27 00:58:23.000000000 +0200
++++ rat-4.2.23/common/src/Makefile.in 2003-04-19 22:46:55.000000000 +0200
+@@ -10,27 +10,39 @@
+ AR = ar
+ RANLIB = @RANLIB@
+ HOST = @host@
+-TARGET = libuclmmbase.a
++TARGET = libuclmmbase.la
++LIBTOOL = @LIBTOOL@
++top_builddir = ..
+
+ exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
+
+-OBJS = crypt_random.o debug.o md5.o memory.o net_udp.o qfDES.o util.o hmac.o \
+- base64.o ntp.o rtp.o drand48.o mbus_parser.o mbus_config.o mbus_addr.o \
+- mbus.o btree.o asarray.o @LIBOBJS@ rijndael-alg-fst.o rijndael-api-fst.o
++OBJS = crypt_random.lo debug.lo md5.lo memory.lo net_udp.lo qfDES.lo util.lo hmac.lo \
++ base64.lo ntp.lo rtp.lo drand48.lo mbus_parser.lo mbus_config.lo mbus_addr.lo \
++ mbus.lo btree.lo asarray.lo @LTLIBOBJS@ rijndael-alg-fst.lo rijndael-api-fst.lo
++
++HEADERS = asarray.h base64.h btree.h crypt_random.h drand48.h hmac.h mbus.h \
++ mbus_addr.h mbus_config.h mbus_parser.h md5.h net_udp.h ntp.h qfDES.h \
++ rijndael-alg-fst.h rijndael-api-fst.h rtp.h version.h
+
+-SRCS = $(OBJS:%.o=%.c)
++SRCS = $(OBJS:%.lo=%.c)
+
+ all: version.h $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(AR) r $(TARGET) $(OBJS)
+- $(RANLIB) $(TARGET)
++ $(LIBTOOL) --mode=link $(CC) -o $(TARGET) $(OBJS) -rpath $(libdir)
+
+ version.h: ../VERSION
+ sed -e 's/.*/#define CCL_VERSION "v&"/' $? > version.h
+
+-.c.o:
+- $(CC) $(CFLAGS) $(INC) -c $<
++install:
++ install -d $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
++ $(LIBTOOL) --mode=install install $(TARGET) $(DESTDIR)$(libdir)
++ install -m644 $(HEADERS) $(DESTDIR)$(includedir)
++
++%.lo: %.c
++ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(INC) -c $<
+
+ clean:
+ -rm -f $(OBJS) version.h $(TARGET) tags
+diff -Nur rat-4.2.23/common.orig/tests/Makefile.in rat-4.2.23/common/tests/Makefile.in
+--- rat-4.2.23/common.orig/tests/Makefile.in 2001-03-09 17:39:57.000000000 +0100
++++ rat-4.2.23/common/tests/Makefile.in 2003-04-19 22:48:37.000000000 +0200
+@@ -5,7 +5,10 @@
+
+ COMMONLIB=uclmmbase
+ COMMONSRC=../src
+-COMMONTGT = $(COMMONSRC)/lib$(COMMONLIB).a
++COMMONTGT = $(COMMONSRC)/lib$(COMMONLIB).la
++
++LIBTOOL=@LIBTOOL@
++top_builddir=..
+
+ DEFS = @DEFS@
+ CFLAGS = -I$(COMMONSRC) @CFLAGS@ $(DEFS)
+@@ -21,7 +24,7 @@
+ all: test-libcommon
+
+ test-libcommon: $(OBJS) $(COMMONTGT)
+- $(CC) $(OBJS) $(CFLAGS) $(COMMONTGT) $(LIBS) -o test-libcommon
++ $(LIBTOOL) --mode=link $(CC) $(OBJS) $(CFLAGS) $(COMMONTGT) $(LIBS) -o test-libcommon
+
+ .c.o:
+ $(CC) $(CFLAGS) $(INC) -c $<
+--- rat-4.2.23/rat/configure.in.orig 2001-07-07 00:00:24.000000000 +0200
++++ rat-4.2.23/rat/configure.in 2003-04-19 22:53:12.000000000 +0200
+@@ -498,7 +498,7 @@
+ COMMON_LIB=${COMMON_LIB}/lib
+ fi
+
+-COMMON_DEP="${COMMON_LIB}/libuclmmbase.a"
++COMMON_DEP="${COMMON_LIB}/libuclmmbase.la"
+
+ AC_CHECK_LIB(uclmmbase,
+ mbus_init,
+@@ -515,13 +515,13 @@
+ else
+ exit
+ fi
+-], -L${COMMON_LIB})
++], -L${COMMON_LIB}/.libs)
+
+ # Convert paths into compiler arguments
+ COMMON_INC="-I${COMMON_INC}"
+ AC_SUBST(COMMON_INC)
+
+-COMMON_LIB="-L${COMMON_LIB} -luclmmbase"
++COMMON_LIB="-L${COMMON_LIB}/.libs -luclmmbase"
+ AC_SUBST(COMMON_LIB)
+
+ EXTERNAL_DEP="${EXTERNAL_DEP} ${COMMON_DEP}"
diff --git a/rat.spec b/rat.spec
index 092d420..72c24b3 100644
--- a/rat.spec
+++ b/rat.spec
@@ -1,24 +1,33 @@
-%define _commonlibver 1.2.8
+#
+# Conditional build:
+# _without_alsa - without ALSA support
+#
+%define _commonlibver 1.2.13
Summary: Audio conference tool
Summary(pl): Narzędzie do audio-konferencji
Name: rat
-Version: 4.2.21
+Version: 4.2.23
Release: 1
License: BSD-like
Group: X11/Applications/Sound
Source0: http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/releases/%{version}/%{name}-%{version}.tar.gz
Patch0: %{name}-FHS_DESTDIR.patch
Patch1: %{name}-ipv6.patch
+Patch2: %{name}-common-shared.patch
+Patch3: %{name}-acfix.patch
+Patch4: %{name}-alsa.patch
URL: http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/
-BuildRequires: alsa-lib-static
-#BuildRequires: autoconf
-#BuildRequires: automake
+%{!?_without_alsa:BuildRequires: alsa-lib-devel}
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: gtk-doc
+BuildRequires: libtool
BuildRequires: tcl-devel >= 8.3
BuildRequires: tk-devel >= 8.3
+Requires: ucl-common >= %{_commonlibver}
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-%define _commonlibdir /usr/lib
-%define _commonincludedir /usr/include/ucl
+%define _commonincludedir /usr/include/ucl
%description
RAT (Robust-Audio Tool) is a network audio tool that allows users to
@@ -35,76 +44,126 @@ profile for audio and video conferences with minimal control.
RAT (Robust-Audio Tool) jest programem pozwalającym użytkownikom brać
udział w konferencjach audio w Internecie. Mogą sie one odbywać
pomiędzy dwoma uczestnikami bezpośrednio lub pomiędzy uczestnikami
-grupy multicast'owej. Do używania RAT w trybie punkt-punkt nie jest
+grupy multicastowej. Do używania RAT w trybie punkt-punkt nie jest
potrzebna żadna specjalna konfiguracja, lecz aby korzystać z
-możliwości konferencji multicast'owej, przyłącze do sieci MBone lub
+możliwości konferencji multicastowej, przyłącze do sieci MBone lub
podobnej jest wymagane. RAT oparty jest na standardach IETF, używa RTP
po UDP/IP jako protokół transportowy i jest zgodny z profilem RTP
dotyczącym konferencji audio i video z minimalną kontrolą.
-%package -n ucl-common-devel
+%package -n ucl-common
Summary: UCL Common Code Library
-Summary(pl): Biblioteka używana przez multimedialne narzędzia UCL
-Version: 1.2.8
+Summary(pl): Biblioteka wspólnego kodu UCL
+Version: %{_commonlibver}
Group: Libraries
-%description -n ucl-common-devel
+%description -n ucl-common
Routines common to a number of multimedia tools like sdr, nte or wbd.
-This package is needed only for compiling them.
+The library originates from work on the RAT project: these are
+portions that are not directly related to an audio tool and
+potentially useful elsewhere.
-%description -n ucl-common-devel -l pl
+%description -n ucl-common -l pl
Procedury używane przez kilka narzędzi multimedialnych, takich jak
-sdr, nte czy wbd. Pakiet ten jest potrzebny wyłącznie do ich
-skompilowania.
+sdr, nte czy wbd. Biblioteka ta wywodzi się z prac nad projektem RAT,
+ale jej częsci nie są związane wyłącznie z narzędziami do dźwięku i
+mogą być przydatne do innych celów.
+
+%package -n ucl-common-devel
+Summary: Header files for UCL Common Code Library
+Summary(pl): Pliki nagłówkowe do biblioteki wspólnego kodu UCL
+Version: %{_commonlibver}
+Group: Development/Libraries
+Requires: ucl-common = %{_commonlibver}
+
+%description -n ucl-common-devel
+Header files for UCL Common Code Library.
+
+%description -n ucl-common-devel -l pl
+Pliki nagłówkowe biblioteki wspólnego kodu UCL.
+
+%package -n ucl-common-static
+Summary: UCL Common Code static library
+Summary(pl): Statyczna biblioteka wspólnego kodu UCL
+Group: Development/Libraries
+Requires: ucl-common-devel = %{_commonlibver}
+
+%description -n ucl-common-static
+UCL Common Code static library.
+
+%description -n ucl-common-static -l pl
+Statyczna biblioteka wspólnego kodu UCL.
%prep
%setup -q
%patch0 -p1
%patch1 -p0
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
%build
cd common
-#%%{__aclocal}
-#%%{__autoconf}
-%configure2_13 \
- --enable-ipv6
+cp -f /usr/share/automake/config.* .
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%configure \
+ --enable-ipv6 \
+ --includedir=%{_commonincludedir}
%{__make}
cd ../%{name}
-%configure2_13 \
+cp -f /usr/share/automake/config.* .
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%configure \
--with-tcltk-version=8.3 \
--with-tcl=/usr \
--with-tk=/usr \
--enable-ipv6 \
%{!?debug:--enable-optimize} \
- %{?debug:--enable-debug}
+ %{?debug:--enable-debug} \
+ %{?_without_alsa:--without-alsa}
# --with-common=/usr/include/ucl
%{__make} EXTERNAL_DEP=""
-
%install
rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_commonlibdir},%{_commonincludedir}}
-install common/src/lib*.a $RPM_BUILD_ROOT%{_commonlibdir}
-install common/src/*.h $RPM_BUILD_ROOT%{_commonincludedir}
+%{__make} -C common/src install \
+ DESTDIR=$RPM_BUILD_ROOT
-cd rat
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} -C rat install \
+ DESTDIR=$RPM_BUILD_ROOT
%clean
rm -rf $RPM_BUILD_ROOT
+%post -n ucl-common -p /sbin/ldconfig
+%postun -n ucl-common -p /sbin/ldconfig
+
%files
%defattr(644,root,root,755)
%doc rat/MODS* rat/README* rat/COPYRIGHT*
%attr(755,root,root) %{_bindir}/*
%{_mandir}/man1/*
+%dir %{_sysconfdir}/sdr
+%dir %{_sysconfdir}/sdr/plugins
%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sdr/plugins/*
+%files -n ucl-common
+%doc common/{COPYRIGHT,MODS,README,src/README.qfdes}
+%attr(755,root,root) %{_libdir}/libuclmmbase.so.*.*.*
+
%files -n ucl-common-devel
%defattr(644,root,root,755)
-%doc common/MODS* common/COPYRIGHT* common/README*
%doc common/doc/html/*.html
-%{_commonlibdir}/*
+%attr(755,root,root) %{_libdir}/libuclmmbase.so
+%{_libdir}/libuclmmbase.la
%{_commonincludedir}
+
+%files -n ucl-common-static
+%defattr(644,root,root,755)
+%{_libdir}/libuclmmbase.a